Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Too much clutch pedal pressure

Join Wrangler Forum Today


Thread: Too much clutch pedal pressure Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-25-2013 07:29 AM
dreamzx93 I wonder if an air bubble in the hydraulic system would cause this?
04-24-2013 09:58 PM
dreamzx93 The fork and bearing assembly move freely until it contacts pressure plate diaphragm then it stops. I took the slave cyl off and moved the bearing/fork back and forth with my hand through the sc hole.

The bearing was put on the fork using the clips on the bearing. They rest in the indentions on the fork. The other side of the fork is attached to the fixed point using that clip.
04-24-2013 09:27 PM
Jerry Bransford If the clutch pedal works normally after the slave cylinder is unbolted from the bell housing, I'd have to guess either the clutch fork or throwout bearing wasn't installed properly.
04-24-2013 09:19 PM
dreamzx93
Too much clutch pedal pressure

I just put a new clutch in my jeep. I've done several in my z and my buddy's cars. So I at least have some experience. Anyway I put flywheel on 105lbs to the crank. Then alignment tool and clutch plate and bolted pressure plate over that at 45lbs I believe it was. Then took alignment tool out and bolt trans, tc, and drive shafts up. Then I put slave cylinder in and went to check pedal pressure bc I did not drain or open hydraulic system when disassembled. I just unbolted from housing and set aside.

Anyway now I have this extremely stiff pedal pressure it will not even budge. I don't want to put anymore pressure on it bc I don't want to blow the slave cylinder. What's going on here I'm stumped? The pedal will not move towards the floor at all.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC