Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > CB Radio Issue

Join Wrangler Forum Today


Thread: CB Radio Issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-26-2013 12:25 PM
Jerry Bransford The antenna itself doesn't get grounded but its mount needs to have a good solid ground. The mount insulates itself from the antenna when put together properly, just make sure the mount is getting a solid ground connection to the Jeep. Running a ground wire between the mount & Jeep is not normally enough to provide a good solid "RF ground" which is different from and more demanding than a normal ground connection.
04-26-2013 12:06 PM
Rolly32 Well the coax cable should be working since it's the same coax I took from my rig. It does look like there is a little peice of the male connector part chipped off. I did try it on my rig and it still works with the peice messed up. I'm able to get replied over the cb. Do I have to ground the antenna with a ground wire? Iv'e seen some CB's with that setup.
04-26-2013 12:43 AM
caprob Yes, Check the continuity on the coax at the radio end. If you can remove it from the antenna end also, all the better, then you can check for and open or short...
04-26-2013 12:31 AM
Electricfoot Broken coax? Coax cables do wear out or break over time. What are your SWR's?
04-25-2013 09:07 PM
Rolly32
CB Radio Issue

I have been gathering parts for a CB radio and it seems I am now finished. Before I mount it on my overhead rack, I decided to test it. At first, I was not be able to get any sound from the radio. I figure it was a ground issue so I took some sand paper to the CB antenna mount and now I can hear a faint static noise if I adjust the squelch. My problem now is that either I am not broadcasting a signal or I can't hear anyone. I got an antenna from an 18wheeler. I have a full size Uniden CB radio and I tried to pop the cap off the antenna but it does not come off. I suppose it's not tunable. I know the radio works because it works on my little tractor trailer. I assume I am still having a ground issue? I read the instructions for the CB antenna stud so it is on properly. What could be my problem?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:40 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC