Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Wrangler 2012 -

Join Wrangler Forum Today


Thread: Wrangler 2012 - Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-29-2013 12:01 PM
Tommymoto I have a 2012 Rubicon Unlimited that has the same issue, sort of. I bought the jeep with 15K 3 months ago. It has now been in the shop 6 straight weeks and counting. The transmission went into limp mode every morning (that was below 65 degrees) and there were no trouble codes showing anywhere. Second problem was that there was a big delay in shifting from third to fourth where the engine would freewheel between gears and slam into fourth.
If the tranny went into limp mode and stuck in third, at times after idling would not engage into gear or would not go into reverse. Turning the key off and restarting would get it out of limp and back in gear. I also found that I could defeat limp mode in a pinch (it would go in at inopportune times like entering a highway) by getting to a speed above normal third gear operation, putting in neutral for two seconds and putting back in drive. That could at least keep me going ahead of the semi at my back until I could restart at the next stop. When in limp mode, manual shifting is disabled. That was an easy way to tell if it was in limp. Start up, start moving, move shifter left to shift down. If it worked, that equaled no limp mode
Three shops looked at it and could find nothing glaring. The first shop found the transmission control module set to base settings and base vehicle tire size. Second shop found nothing. This was then flashed and programmed properly and the engine control module programming was verified. Now back at the shop that sold me the jeep, their shop decided to change the torque converter and primary valve since they found some "pressure variations". Chrysler told them no, and instructed them to change the valve body. This fixed nothing. Shop decided to dismantle the transmission. They found a shift clutch actuator [servo?] for third gear wouldn't hold air (pass a pressure test?).
Chrysler is sending a new transmission.
Living in Durango and missing my entire summer of jeeping is a bit rough.
04-26-2013 10:43 PM
lari Thx for the posts guys, it really helps in days like these!
After 4 days now, the dealer still can't find what's the problem of my transmission. Apparently they sent pictures and info to Chrysler, they have to check it out but still no news....

So I decided to switch to the 2013 model. I think the other one is a really bad lemon ... they gave me a nice offer to replace it. Better package overall and the little loss of money will eventually be more rewarding in a long term. It's a fresh start with a new wrangler.... I've been driving it today and somehow it feels way better... It feel like a real wrangler!
04-25-2013 01:14 AM
rethyk so far I've taken it to the dealer I bought it from but then again they are a 5 star rated dealer and still way cheaper than the service costs for the VW I had before. can't say I've had any issues yet so not much help for you unfortunately but I know lemon law only applies to the same problem and not different problems. One way to look at you situation instead is you are getting free replacement on big ticket items while still under warranty. had a friend essentially get pretty much every part replaced on his avalanche right before warranty ended on it. who ever ended up with that truck essentially got an awesome deal since pretty much the only used part was the body panels. take advantage of the fact you are covered under warranty for these repairs since come warranty end your jeep will have that much less wear and tear on it.
04-24-2013 09:39 PM
lari So I called Chrysler Canada and they said that they will repair as long as it's in the warranty even if they have to fix it 100 times they will never buy back or replace! even if it's a security issue! lol...
but 2 days later and still in the garage at Chrysler dealer and they didn't figure out what's the problem...

I'm starting to find it funny!
Anybody take its Jeep to the dealerships for repairs and maintenance or you deal with private garages specialized in Jeep wranglers? what's better choice?

I feel dealerships always wants to lie to you to get the most out of your pocket! I don't know if I'm the only one who feels that way!
04-23-2013 05:54 AM
lari I don't have any large tires on it, just the standard 18, and no supercharge! I still think i'm lucky I was in traffic, like really we were not even moving!
Funny part of all this is that I had it checked at the dealer 2 weeks ago for safety inspection to be able to register it in Ontario... and it passed with no problem what so ever!

They told me at the dealer that for sure its all covered under warranty but since it's not my first issue in a year I'm having questions about this particular wrangler that i own! not sure if I feel like paying the 83 month left on it!

I'm going right now to the garage and have a talk with Chrysler Canada! I'll update you guys on what they will say!
04-22-2013 10:18 PM
jkjeeper06 I'm sorry to hear about the problems. That's very stressful especially the transmission issues. That's not good at all. I hope it gets straightened out. Unfortunately I don't believe you qualify for a lemon law replacement(if Canada has one). Hopefully they put a new transmission in it for free.

Do you have any mods that they could possibly try to blame the failure on like larger tires or a supercharger?
04-22-2013 10:16 PM
Tweak I have the seat issue as well. it doesnt go all the way back down but it does drop.
04-22-2013 09:37 PM
lari
Wrangler 2012 -

Hey everybody!
I was a proud owner of many Jeeps (wrangler, cherokee and grand cherokee) until i bought my Jeep wrangler unlimited 2012 sahara in June 2012. Not even 2 months old and I had sounds in the hand break of metal rubbing on each other. Took it to the dealer, they found a piece of metal that was left there from the factory and as the mechanic told me, that part isn't suppose to be there... I told my self this could happen, it's an accident... couple of month passed and I had a problem with the seat going back to the lowest position while i was driving... back to the dealer, they acknowledged that there is a problem and they changed the base... then came sounds of the driver's door, latch had to be replaced... wipers turned on my them selves! another thing to add to my list.... not to mention that I had my windshield broken too by rock at the end of the summer!

All this and I kept saying that these are minor things.. Overall I was really happy with the wrangler!

But today I had the worst of them all...I had my wrangler towed to the garage for a transmission issue that I still have no idea what happened! I was driving back from work, middle of traffic and suddenly I can't move forward! The engine was running, pressed on the gas pedal, the RPM was revving but the jeep was stationary... tried reverse same thing ...

Towed it to the closest dealer and they were shocked ... not sure if that's a good sign !
After explaining all the problems that I had, they gave me Chrysler Canada's number and told me that we can't do anything but just repair !

I'm really not happy with that... I've had it for less than a year and I've fixed it more than I ever fixed all my other Jeeps!

Anybody have any idea how I should aboard this with Chrysler?
Any advice would be great!!

thx
lari

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC