Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Possible neutral safety switch issue

Join Wrangler Forum Today


Thread: Possible neutral safety switch issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-27-2013 04:54 PM
RUBI 4 MY MRS When this is happening, do the gauges only swing back & forth when the ignition switch is held in the start position & go back when the key is released? When the key is on (not to start) do the gauges (like the fuel gauge) read normal or stay bottomed out (like off)?

I don’t see a connection between the neutral switch & the gauges acting as they are but you can test the switch by temporarily bypassing it. Be careful because doing so will allow it to start when in gear. You can ground the brown/blue wire going to the switch. Since the problem is intermittent you may have to try is that way for a while to see if it starts every time.

Another possibility is that it is an ignition switch problem. There is a connection between the shifter & the ignition switch. You know how you can’t shift out of park unless the key is on. There is a cable going from the shifter to the ignition switch. It could possibly be that when you move the shifter you are you are affecting the ignition switch. The wiring there can certainly affect starting & possibly the cluster as well. One thing you can try is when you get the no start, before moving the shifter & with the key on, check various electrical components like the wipers, turn signals, radio. Then with the brake pedal pushed, see if you can take it out of park. Also carefully check the connector to the ignition switch for melting or discoloration of any of the terminal connections (you have to unplug the connector to check that).
04-27-2013 01:57 PM
kenglong
Possible neutral safety switch issue

Can a bad neutral safety switch cause symptoms other than no click, no crank?

I have a 2001 TJ, 4.0, 32RH auto. A few months ago I started having an issue where the CHECK GAUGES light came on while driving. It didn't seem to cause an issue so I continued to my destination. The voltage gauge was wavering more that usual though. Got home and parked the Jeep. Next morning it would not start (no click, no crank) and the dash gauges were all swinging wildly. I thought it might be a dead battery so i charged it but still no go. Had it towed to a garage and they found nothing wrong. It started fine for them.

A few months later, same thing. No click, no crank, dash gauges all swinging wildly. This time I had bumped the shifter before trying to start it so I worked the shifter back and forth a few times and it started. The gauges were all normal again, including the voltage gauge. Last night on the way home I got the CHECK GAUGES light again and the voltage was varying several volts up and down. Got home ok and it would not restart. Worked the shifter a few times and it started normally. Volt meter is rock steady again.

Strange stuff. I'm thinking I should replace the neutral safety switch and see if that cures all the symptoms. Would love to hear opinions.

Kenny in Albuquerque

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:55 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC