Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > superchip for '13 Rubi

Join Wrangler Forum Today


Thread: superchip for '13 Rubi Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-27-2013 11:11 PM
PRS
Quote:
Originally Posted by terrabit View Post

Dead band?
Yeah, the initial dead spot where you push the throttle and nothing happens until you go far enough and then it reacts. The procal gets rid of that.
06-17-2013 10:22 PM
terrabit
Quote:
Originally Posted by PRS View Post
That's what the manual says. Read on some other threads and other boards about some success fixing the dead band so I tried it. Took several tries and you must do the procedure per the instructions. It eliminated my dead band.
Dead band?
06-17-2013 08:40 PM
PRS
Quote:
Originally Posted by relyt View Post

Somebody correct me if I'm wrong, but I was led to believe when reading the manual for my procal that the only thing it does for the throttle is to sync it to a new ECM, like when doing the hemi conversion.
That's what the manual says. Read on some other threads and other boards about some success fixing the dead band so I tried it. Took several tries and you must do the procedure per the instructions. It eliminated my dead band.
04-30-2013 02:16 PM
JimmEC I'd like to be able to use my lockers in 4H and I want to calibrate the speedometer since I regeared and put 35s.
04-29-2013 02:11 PM
jcrawler93 The AEV pro cal will give better results.
04-29-2013 02:04 PM
Sgt93 To sum it up:

Chips in a diesel= huge gains

Chips in a gasser= wasting money for dollars spent.

Save your money and return it. Spend it on something useful.
04-29-2013 01:27 PM
relyt
Quote:
Originally Posted by PRS View Post
I had a Flashcal and it didn't work. 6 spd seems to be the kicker. They called on Thursday to say they had an update fix, but I had returned it and bought a Procal. The Procal will fix the dead spot in the throttle. Lockers in other than Lo, turned out to be bogus for the Flashcal, which is why I initially bought it over the Procal.
Somebody correct me if I'm wrong, but I was led to believe when reading the manual for my procal that the only thing it does for the throttle is to sync it to a new ECM, like when doing the hemi conversion.
04-29-2013 12:19 PM
JimmEC Thanks
04-28-2013 06:40 PM
PRS I had a Flashcal and it didn't work. 6 spd seems to be the kicker. They called on Thursday to say they had an update fix, but I had returned it and bought a Procal. The Procal will fix the dead spot in the throttle. Lockers in other than Lo, turned out to be bogus for the Flashcal, which is why I initially bought it over the Procal.
04-28-2013 12:01 PM
JimmEC Oops, that's what I meant to say. I have a flashcal. It doesn't work even tho they advertise it does.
04-27-2013 09:41 PM
JTPhoto JK
Quote:
Originally Posted by JimmEC View Post
Got a flashpac for my '13 rubi and it doesn't work! My shops been calling superchip and they keep saying they'll have it fixed, but a week later and two updates later, it still doesn't work!
Far as I know Superchips has not released the Flashpaq for 2011-13. They have been unable to totally crack the code for the tunes so they released another product called the FlashCal. Check on the Superchips forum.
04-27-2013 08:29 PM
JimmEC
superchip for '13 Rubi

Got a flashpac for my '13 rubi and it doesn't work! My shops been calling superchip and they keep saying they'll have it fixed, but a week later and two updates later, it still doesn't work!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:26 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC