Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Build Forum > 1990 YJ Wont start

Join Wrangler Forum Today


Thread: 1990 YJ Wont start Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-29-2013 06:40 PM
Hankappstate
Quote:
Originally Posted by Wranglin4Life View Post
Silly question but did you try hitting the starter lightly with a hammer or socket wrench a few times? My dad did this on my sisters jeep when the starter was going bad. Worked for a few months then he had to change it out.
I did. I pulled a part off the firewall that I thought was the solenoid but turns out it may be an ignition relay. Trying to have the part cross referenced.
04-29-2013 02:54 PM
Wranglin4Life Silly question but did you try hitting the starter lightly with a hammer or socket wrench a few times? My dad did this on my sisters jeep when the starter was going bad. Worked for a few months then he had to change it out.
04-29-2013 02:03 PM
Hankappstate I had the battery tested at a parts store. I have tighten the terminal and done the battery maintenance. I will try a different battery.
04-29-2013 01:12 PM
sevenservices also verify your connections are good at both ends of the battery cables. I had it act just like that once, have someone try it with you looking under the hood in the dark. If you see a spark at the battery, theres your bad connection. I saw it spark down by the starter. Checked that end and the cable was only finger tight onto the starter.
04-29-2013 12:42 PM
JDsDream Are you sure that the battery is good? Have you had it load tested? Before throwing money at it, switch out the battery from another vehicle and see if it starts. Your battery may have enough power to run your lights, guages, stereo, etc, but not enough to start. Disconnect the cables and clean the posts and connectors with a wire brush to remove any and all corrosion. When replacing the cables make sure that they are tight enough that you can not twist them by hand. If this is not the case then on to step 2 but always try cheapest first when troubleshooting problems.
04-29-2013 12:38 PM
Hankappstate Its not a power issue, I think its a starter/solenoid issue
04-29-2013 12:15 PM
Wranglin4Life Check the alternator. Sounds like it could be bad
04-29-2013 10:52 AM
Hankappstate
1990 YJ Wont start

I have a 1990 YJ. The battery is good, but when I turn the key all that happens is a click. I think it is the solenoid that is clicking. I have had the jeep for about 3 months. It has always started slow, like the started was working very hard, but it always stared until 4 days ago.. Any ideas.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:40 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC