Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Need clutch help please!!!

Join Wrangler Forum Today


Thread: Need clutch help please!!! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-29-2013 08:16 PM
jerseyjk2007 Thanks for the info! I'm gonna try and bleed the slave tomorrow if that doesn't work I'm gonna replace it and hopefully that will do the trick.
04-29-2013 08:02 PM
SilverSport
Quote:
Originally Posted by jerseyjk2007 View Post
Thanks guys! I checked around the slave and master didnt see any signs of leakage. Brakes still works that's why I was leaning more towards the slave. Hopefully just need to swap the slave out. Easy fix? Take any help I can get!
A slave/master cylinder can be defective without it leaking. If the internal seals on the pistons get worn, fluid flows past the piston instead of being forced to move and do work.
04-29-2013 07:12 PM
jerseyjk2007 Thanks guys. Fluid in reservoir is at the minimum line right now maybe just needs more fluid and to be bleed air in line possibly? Think I'm gonna try that first before I put a slave in it. Never had to bleed anything before any easy ways?
04-29-2013 07:08 PM
Chipmunk
Quote:
Originally Posted by WatchThis! View Post
Never done one on a JK but I have never done one that was hard. They are a bitch to get all the air out of them sometimes.
Ditto. All of the ones I have replaced have been manageable. Simple hand tools is all you need. As stated above, make sure to get all the air out
04-29-2013 07:05 PM
WatchThis! Never done one on a JK but I have never done one that was hard. They are a bitch to get all the air out of them sometimes.
04-29-2013 07:01 PM
jerseyjk2007 Thanks guys! I checked around the slave and master didnt see any signs of leakage. Brakes still works that's why I was leaning more towards the slave. Hopefully just need to swap the slave out. Easy fix? Take any help I can get!
04-29-2013 06:56 PM
Chipmunk I would also say slave. I have had this problem before with other manual trans...
04-29-2013 06:56 PM
jkjeeper06 Yes it shares the same reservoir as the brakes. At normal level, they share fluid, but if it gets too low there is a divider in there so that if one system goes and leaks out all of its fluid the other can still function. If your fluid is fine then that's not it.

Like watch this, I'd also guess slave cylinder
04-29-2013 06:50 PM
WatchThis! If I had to guess without seeing your jeep. I would say your slave cylinder is out.
04-29-2013 06:26 PM
jerseyjk2007 I have a 2007 sahara 2 door. Just replaced clutch about a month ago driving home last night noticed that clutch started to have no tension. Went to go to work this morning and the pedal went right to the floor has no tension at all. What could it be Slave or Master?? Fluid in resovoir is a bit low. Shares the same as brake resovoir correct? someone help me please!!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:59 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC