Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > brake light/ turn signal problem

Join Wrangler Forum Today


Thread: brake light/ turn signal problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-07-2013 11:18 PM
CarloC I hope it does. I was going threw all of my wiring to make that was the problem before I went and bought the switch
05-07-2013 10:55 PM
MLaborde Thanks for posting the source of your problem. It will help people in the future.
05-07-2013 09:43 PM
CarloC Finally got around to it and it was the turn signal switch
05-01-2013 05:13 AM
CarloC Ok. From the sounds of it I'm thinking it does sound like the turn signal switch. I just finished checking all the fuses and they are good. Once I get time to replace the switch I will post up and let you know if that fixed it
05-01-2013 03:06 AM
jimmy_buckle I am having a similar problem. I had a thread on it the other day.... didn't really get a proper solution because electronics are such a fickle thing.
I replaced bulbs but didn't solve issues. Things like the left indicator works but when you put your foot on the brake it speeds up and then the reverse doesn't work on the left rear side.
Safe to say I went to see an auto electrician today....getting fixed on Friday.

I hate dealing with electronics
05-01-2013 01:21 AM
RUBI 4 MY MRS Since the turn signals blink the brake lights on the rear, the signal switch (multi-function switch) is supposed to disconnect the brake light on that side to allow the flasher to blink the light. If that disconnect is not happening it can back feed the brake lights into the front & indicator lights. I think if that happens, the center brake light might blink when you use the left signal without the brakes on. You can check the switch with a meter. The procedure is in the FSM, one linked below if you don’t have one. For ’99 it is on page 5 of the turn signal chapter.

See online read only FSMs here:
Jeep Knowledge Base
You may have to go to the bottom of the page & pick Jeep Resources & online manuals if it directs you to home page rather than the knowledge base.
Pick your model & year then on the drop down menu pick the chapter you need.
05-01-2013 12:56 AM
Big Sarge
Quote:
Originally Posted by CarloC View Post
I figured the fuses where good because everything was working correctly if I wasn't on the brakes. and all of the brake lights work too. But I will check the fuses on it tomorrow morning when I get home from work.

The bulbs I replaced everyone of them making sure they where all the correct bulbs.

I'm wondering could the signal switch be going bad? From what I hear it's like a three way swtich in it and I'm wondering if the brake light is bak feeding into it and into the front marker light?
Mine will do this on occasion. I turn the signal on and off a few times and it fixes it. My guess is the signal light switch is bad. Mine will be soon as well. I also had a similar problem with the 4 way flasher..... When turned on they would either not work or just illuminate constantly. About 15-20 quick itterations of on and off and it started working properly as well.
05-01-2013 12:09 AM
Bet I had an issue recently where I would get no signals, and if I did have the signal flipped, the brake light that SHOULD have been flashing would remain unlit when you hit the brakes. Turned out to be my ignition switch - keep digging if someone doesn't find the answer for you here.
04-30-2013 10:47 PM
CarloC I figured the fuses where good because everything was working correctly if I wasn't on the brakes. and all of the brake lights work too. But I will check the fuses on it tomorrow morning when I get home from work.

The bulbs I replaced everyone of them making sure they where all the correct bulbs.

I'm wondering could the signal switch be going bad? From what I hear it's like a three way swtich in it and I'm wondering if the brake light is bak feeding into it and into the front marker light?
04-30-2013 10:23 PM
kyjeep Check grounds and make sure all of the bulbs week the correct bulbs.
04-30-2013 10:20 PM
RevCo666
Quote:
Originally Posted by CarloC View Post
I just picked up a 99 wrangler for my nephew and whenever I step on the brake the left turn signal indicator comes on and stays on solid until I release the brake pedal. I went around and changed all of the bulbs. When I use the signals, or marker lights everything works as it should, that is until I step on the brake pedal. all of the bulb sockets look good.

any ideas on where I should start looking?
Wild guess: try checking your fuses?
04-30-2013 09:42 PM
CarloC
brake light/ turn signal problem

I just picked up a 99 wrangler for my nephew and whenever I step on the brake the left turn signal indicator comes on and stays on solid until I release the brake pedal. I went around and changed all of the bulbs. When I use the signals, or marker lights everything works as it should, that is until I step on the brake pedal. all of the bulb sockets look good.

any ideas on where I should start looking?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC