Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Freedom Top Alignment Problems

Join Wrangler Forum Today


Thread: Freedom Top Alignment Problems Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-05-2013 09:26 PM
sweetwillyswrangler Because of this post I went out on my lunch time and checked my top. 2014 JKU. I have had my jeep for about a month and have not taken the top off yet. To my surprise where the panels meet in the middle towards the back the seal was sticking thru! So I came home read the OM and watched the dvd. I took off the left side panel and repositioned the seal. Put it back together and ran it thru a car wash...and no leaks...now I cant wait to take em off again. Only having this vehicle for a short time I have driven it in 3 pretty good rain storms without any leaks.
09-03-2013 03:52 AM
Alohafire
Quote:
Originally Posted by Gewch View Post
Thanks for all of the advice and thanks to those of you that checked your tops out to compare.

Tried stopping by the dealer on the way home - they were way too busy to look at it. Going to try again tomorrow and if not schedule an appointment.

Ill let you guys know what they say.
What did dealer say
08-28-2013 09:40 PM
VooDoo7 Dang, I just noticed this on my new Jeep today too. And me being a little OCD, it's just eating at me.
05-06-2013 09:26 PM
Hoboscratch Yesterday as I was re-installing my panels, I recreated your picture with the flap sticking out. It was the first time it happened but it was purely due to the passenger side panel not being installed correctly. Once I removed both, and reseated the passenger side, making sure to set it down, not slide it, keeping it toward the front, then putting down the driver side, there was no flap. I'm guessing you've messed around with it more since then or had the dealer look at it, but unless there was a hardware defect with the hole or the panel, its just not installed right.
05-01-2013 11:20 AM
positrak That piece sticking out and up has to be the cause of that slight gap. You need to fix that first as its thickness equals that slight gap in the front. Compare the two panels at that point and see how it fits in or should be.

Check the right rear of the hard top, is it flush with the body? Maybe loosen the HT again and push that side forward while tightening the bolts. Even go so far and remove the HT and just install the two fron panels on their own to see if it is lined up.

Try installing the passenger side by first and securing the latch first so the panel is pulled forward by that before anything, then the drivers and its latch then the knob connecting the two at the front, then the ones at the rear and side and see if that solves it.

Are you using the bolts each time as well? Over tightenting them can also cause issues, loosen them up or leave them out for the summer and see if that has an affect.

Think it is that piece of rubber that is not seated correctly. If I am not mistaken the passenger side right thee has a rubber seat for the drivers side to sit on, that piece sticking out should be flush. Fiddle with it it should have a natural postion if you move it around.
05-01-2013 06:40 AM
Abnormal-JK
Quote:
Originally Posted by SilverSport View Post
Makes me wonder if there is a manufacturing variance in the location of the alignment pins on the panels.
I would think so. With the pin holes in the roll bar, there is room for a little slop. But having taken mine off many times and thrown them back on quickly once I got to the bar or wherever, they always seem to go in the same place, and not leak. I'd imagine each JK is a bit different, as the three pieces go together. If the back is off by 1/8" that would translate to 1/4" at the front or more. No leaks, no prob... can't see it from the drivers seat
05-01-2013 06:34 AM
SilverSport Makes me wonder if there is a manufacturing variance in the location of the alignment pins on the panels.
04-30-2013 10:29 PM
Gewch Thanks positrak.

That is the exact thread I followed when I tried adjusting the hard top. I even sent Matador a PM to clarify some of the steps.

Still no dice for me.
04-30-2013 10:04 PM
positrak same ordeal below with solution (loosen the whole HT and push it back as far as you can before tightening up the bolts):

http://www.wranglerforum.com/f33/fre...lp-133101.html
04-30-2013 09:54 PM
Gewch
Quote:
Originally Posted by AverageJK View Post
Are you remembering to install the passenger side first and then the drivers side?
Yes - line up the guide pins and I've tried dozens of latch patterns to try to get them to line up. Hopefully the dealer can shed some light on this for me.

Expecting snow tomorrow, so we'll see how it goes.
04-30-2013 09:45 PM
AverageJK Are you remembering to install the passenger side first and then the drivers side?
04-30-2013 09:33 PM
Doctorsti Mine is opposite, 2013 10th Anniversary rubicon painted hard top passenger panel is 1/8" further forward compared to driver side panel. 36 hours of rain and no leak.
04-30-2013 09:22 PM
Gewch Thanks for all of the advice and thanks to those of you that checked your tops out to compare.

Tried stopping by the dealer on the way home - they were way too busy to look at it. Going to try again tomorrow and if not schedule an appointment.

Ill let you guys know what they say.
04-30-2013 08:57 PM
Drmad7
Quote:
Originally Posted by Joshua_Pines View Post
Same as SilverSport... Misaligned by about 1/16".zz no weather strip shows... No leaks.

I tried to push the pass side forward, makes no diff.
My 13 is the same way. Never really noticed on the 2 previous JKs but with the painted top, it's noticeable. Tried pressure and adjusting and no difference was made. But no leaks and no weatherstripping sticking up either. Just not aesthetically pleasing.
04-30-2013 08:47 PM
Abnormal-JK Same as SilverSport... Misaligned by about 1/16".zz no weather strip shows... No leaks.

I tried to push the pass side forward, makes no diff.
04-30-2013 08:32 PM
MUEngineer
Quote:
Originally Posted by SilverSport View Post
My 2012 has an alignment pin on each of the Freedom Panels that mate with a hole in the roll bar. The front edge of the driver's side panel is maybe 1/16" farther forward than the passenger side. I can make out the rubber seal but it doesn't stick up like that either.
My 2013 has the same alignment pins, they locate the tops. However, mine has several misalignments. Firstly, like yours, mine has a driver side panel that is 1/16" further forward. My other issue is that the gap between the panels is wider in the back than the front.

Since September 2012, I've had one small leak on the passenger side at the corner of the windshield and that was due to my screw up on pushing the panel too far forward and crushing a seal. Once I reinstalled the panel correctly, even through a touch-less car wash, not one drop of water.

To the OP: the weatherstripping sticking up like that is not normal and the Jeep needs to go back to the dealer for that, but the misalignment won't mean leaks necessarily and I wouldn't go messing with the top just to fix the fit. I'm an automotive engineer and I will tell you from my professional experience that trying to fix an appearance issue that people really can't see isn't worth it. You will cause all kinds of issues including leaks by trying to improve that gap.
04-30-2013 08:23 PM
Hoboscratch 13 JKU here, just checked and mine doesn't look like that either. But when I took a peek I did notice I had some weatherstripping pinched in another spot, so good thing I took a look!
04-30-2013 08:00 PM
SilverSport My 2012 has an alignment pin on each of the Freedom Panels that mate with a hole in the roll bar. The front edge of the driver's side panel is maybe 1/16" farther forward than the passenger side. I can make out the rubber seal but it doesn't stick up like that either.
04-30-2013 06:59 PM
Blastek
Quote:
Originally Posted by Gewch View Post
The driver side panel sits closer to the windshield, so would the forward pressure throw the alignment further off?
sorry, I mixed it up. Apply forward pressure on the passenger side!
04-30-2013 06:16 PM
R1pilot I have a 2013 JKU and mine does the exact same thing (slightly misaligned freedom panels and small weather strip sticking up). I was also worried about leaks but we've had rain and I've hosed it off. So far, no leaks.
04-30-2013 05:39 PM
1quick1 Mine does not have that rubber lip exposed like that. It looks to me from the 1st pic that the passenger side panel needs to forward slightly as it may be sitting on that seal causing it to be slightly out of align. I'll text you pics of mine in about 15 minutes.
04-30-2013 04:29 PM
Gewch Thanks for the advice, gonna try to run it by the stealership before it snows again tomorrow.
04-30-2013 04:24 PM
Mcrock
Quote:
Originally Posted by Gewch View Post
Thanks Mcrock. I tried to lay it flat, but there is nowhere for it to go.

The weatherstripping of the back of the hard top is right against where the freedom top meets the hard top. It seems like it would be a lot of effort to have to constantly tuck it somewhere everytime the panels come off, which makes me feel that its not installed correctly...
Yah. You got issues there. I can see where it is causing the misalignment If you can't solve it I would make a trip to the dealer. You have a leak waiting to happen
04-30-2013 04:16 PM
Gewch Thanks Mcrock. I tried to lay it flat, but there is nowhere for it to go.

The weatherstripping of the back of the hard top is right against where the freedom top meets the hard top. It seems like it would be a lot of effort to have to constantly tuck it somewhere everytime the panels come off, which makes me feel that its not installed correctly...
04-30-2013 04:10 PM
Mcrock From the pic it looks like a piece of rubber sticks up where the two panels meet at the back. I am certain that it should be laying flat under the panels.
04-30-2013 04:04 PM
Gewch The driver side panel sits closer to the windshield, so would the forward pressure throw the alignment further off?
04-30-2013 04:02 PM
Blastek i think the lip is fine.

if you just latch the driver's side with the latch under the visor, it does not line up with the passenger side. you have to provide forward pressure while latching the driver's side.
04-30-2013 03:58 PM
Gewch That little lip in picture 2 is attached to the end of the Passenger Side Freedom Panel. I tried to tuck it in, but theres no room for it...

I also made sure the blocks on the back of the FTops were closed...
04-30-2013 03:57 PM
Gewch
Freedom Top Alignment Problems

Hello,

I am new to the Jeep world as of February, and I am having problems with aligning the Freedom Tops on my JKU.

I did find several threads on the forum about this issue and went through each, but none of them solved my problem.

First thing - I don't remember what they looked like before. I never thought to look at the alignment. I have only removed the Freedom Panels a handful of times until this last weekend - then I got adventerous.

I took the Freedom Panels off and unbolted the hardtop and removed it too! What an amazing experience. Anyway, when it came time to put it back together, I replaced the top and bolted it back down. I put the Freedom Panels back but the passenger side panel is not aligned with the driver side.






Also, I noticed a little "lip" of weatherstripping on the passenger side panel that sticks out above the top.



Figuring I screwed something up with expert novice skill level, I took the Freedom Tops off, took the hardtop off and tried to reposition it while putting effort to make sure it was aligned to the "back" position(I put it back on while pushing it to the rear of the vehicle). Rebolted, and put the panels back and still have the same issue...

Any ideas? Is this normal? Am I being TOO concerned?

We haven't had any rain yet to check for leaks and not much time to run the hose over it to look for leaks, but shouldn't they line up?

Thanks in advance!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:27 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC