Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Shop drove Jeep without a serpentine belt...

Join Wrangler Forum Today


Thread: Shop drove Jeep without a serpentine belt... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-01-2013 07:45 PM
Patrick H Have them make a note on the work order that they drove it without a belt. Then buy yourself a belt, check your pulleys, alternator, power steering, etc. to make sure something else isn't wrong. Slap the new belt on and drive it. See if any damage was done.
05-01-2013 07:40 PM
equinedanielle Thanks for all of the information, I didn't go pick it up today, I'm freaking out a bit now.
05-01-2013 04:43 PM
tjtime Alternator light should have lit up as soon as the belt let loose, not to mention the temp gauge should have been pegging after 4 or 5 minutes unless it got Midwest cold in Florida. If it overheated it should have thrown a code. Perhaps there is a Jeeper in your area that is handy with a wrench that is willing to go there with you when you go to pick it up. Don't just give these guy's a pass on this.
05-01-2013 03:53 PM
Gold Miner 20 minutes?
If it's not toast now it will be... and sooner than it should be.
They owe you a new engine but will be tuff to prove unless they'd have seized it... or blew the head gasket... or warped the head... or whatever while on their 20 minute joyride.
That sucks.
05-01-2013 03:45 PM
T2000J I would be worried about the gear job if they drove it without a belt and said they didn't know . It is a shame you Pay good money for a job and the people just do not take any pride in their work Just out for a paycheck .
05-01-2013 03:19 PM
mudmagnet63 The fact he drove it without a belt at all would scare the he!! out of me. My jeep takes about 5 min to get up to temp, in 20 it would be boiling over. Be very cautious on this one.
05-01-2013 03:10 PM
Water Dog That belt just didn't let go sittin' there with the engine off. Someone had to be running it when it let go. If it wasn't you when you brought it in, then it must have let go on their test drive which would lead me to believe that it probably didn't run that long without the water pump.
05-01-2013 02:02 PM
equinedanielle
Quote:
Originally Posted by mudmagnet63 View Post
I would document on the ticket that is was driven without a belt and hold them responsible for any damage. make them sign the ticket. You need some kind of documentation to CYA.
That's great advise, thank you.
05-01-2013 02:01 PM
equinedanielle
Quote:
Originally Posted by tangofox007 View Post
20 minutes with no water pump and it didn't overheat? That is a bit difficult to believe.

I had a belt break (due to a pulley failure) in a Cherokee. I was close to home and tried to drive it home; overheated in less than 1/4 mile.
I seriously hope there's no damage. I just sank $2100 into a new rear axle + regeared the front. This things gotta last til next tax season, lol
05-01-2013 12:13 PM
mudmagnet63 I would document on the ticket that is was driven without a belt and hold them responsible for any damage. make them sign the ticket. You need some kind of documentation to CYA.
05-01-2013 12:12 PM
tangofox007
Quote:
Originally Posted by equinedanielle View Post
They drove it like that for about 20 min right after the new gears were put in. He said it didn't overheat while he was driving
20 minutes with no water pump and it didn't overheat? That is a bit difficult to believe.

I had a belt break (due to a pulley failure) in a Cherokee. I was close to home and tried to drive it home; overheated in less than 1/4 mile.
05-01-2013 12:00 PM
equinedanielle Thank you... I don't know a whole lot about that kind of stuff. I can weld and do pretty much anything non engine related, lol. Still learning, thanks for the info.
05-01-2013 11:58 AM
Mr Mac It isn't likely that they did any damage to the engine but, by all means, they should have told you before they ever drove it!
05-01-2013 11:23 AM
equinedanielle
Shop drove Jeep without a serpentine belt...

Hello all, my 03 is currently at a shop having my gears changed. I went to pick it up, and had no power steering. I pulled back into the parking spot to look under the hood. No belt at all, the tensioner had seized up. They drove it like that for about 20 min right after the new gears were put in. He said it didn't overheat while he was driving, just thought I didn't have any power steering.

My question is this... Do you think this could have caused any major damage? I'm supposed to go pick it up later this evening. I appreciate any comments/advice that you can give.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:22 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC