Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Help, my Jeep keeps cutting out and stalling on heavy washboard roads…

Join Wrangler Forum Today


Thread: Help, my Jeep keeps cutting out and stalling on heavy washboard roads… Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-21-2011 09:46 PM
WensToy we were having the problem with jeep shutting down, but crank right back up and run fine and just die. no sensors showed, but was told to change crank shaft sensor, and we did and dont have the problem since!! cost around 27bucks.
05-12-2009 05:17 PM
Jerry Bransford I wouldn't be too quick to replace the CPS, I'd first check its wiring and connector to see if it's something simple like a frayed wire or loose plug where it connects to the main wiring harness. And if anyone has messed around with the wiring between the battery and engine, and the ground connections between the engine and chassis, and battery and chassis, they could be causing problems too if they're not tight.
05-12-2009 05:14 PM
Proud American
Quote:
Originally Posted by Jerry Bransford View Post
First, pumping the gas pedal doesn't cause more fuel to pump into the engine... those days went with carburetors.

How's the wiring to your crankshaft position sensor that is bolted up high on the driver's side where the transmission bolts to the engine? The CPS is what provides the engine's master timing signal and if gets interrupted, perhaps by a frayed CPS wire or loose connection where the CPS plugs into the main wiring harness, the engine would stall.
Jerry,

thanks again for your excellent post. I did a quick search on the internet and found this article that seems to describe by issues to a tee:

Crankshaft Position Sensor Replacement
There are several reason why you would need to replace your Jeep TJ Wrangler's Crankshaft Position Sensor (or CPS for short) with the most obvious one being that your 'check engine' light has illuminated and a quick check with an OBDII reader indicates you have thrown one of the following MIL codes.

P0219 - CPS Overspeed Signal
P0320 - No Crank Reference Signal at PCM
P0387 - CPS Voltage Supply too Low
P0388 - CPS Voltage Supply too High

For me, my Jeep wasn't throwing any codes and so I wasn't completely sure that this was something I needed to replace. What lead me to think that it may need to go was the fact that I now have over 120,000 miles on the odometer, I have already replaced my O2 sensors and still had various engine issues including a rough idle under specific conditions. Specifically, my engine would run very rough on cold mornings or after driving it a long time with the AC on, turning off the engine briefly and then starting it back up again. I had also experienced times when climbing up long highway hills the engine would run quite rough... almost as if it were misfiring. Now, I should tell you that things are better since installing a new CPS but my engine is still running far from perfect.
05-12-2009 05:07 PM
Jerry Bransford
Quote:
Originally Posted by Proud American View Post
Thanks Jerry for your reply. Is this crankshaft position sensor under the hood? what's my best way to get a good view of it?
Read my above post again where I described its location.
05-12-2009 05:04 PM
Proud American
Quote:
Originally Posted by Jerry Bransford View Post
First, pumping the gas pedal doesn't cause more fuel to pump into the engine... those days went with carburetors.

How's the wiring to your crankshaft position sensor that is bolted up high on the driver's side where the transmission bolts to the engine? The CPS is what provides the engine's master timing signal and if gets interrupted, perhaps by a frayed CPS wire or loose connection where the CPS plugs into the main wiring harness, the engine would stall.
Thanks Jerry for your reply. Is this crankshaft position sensor under the hood? what's my best way to get a good view of it?
05-12-2009 04:56 PM
Jerry Bransford First, pumping the gas pedal doesn't cause more fuel to pump into the engine... those days went with carburetors.

How's the wiring to your crankshaft position sensor that is bolted up high on the driver's side where the transmission bolts to the engine? The CPS is what provides the engine's master timing signal and if gets interrupted, perhaps by a frayed CPS wire or loose connection where the CPS plugs into the main wiring harness, the engine would stall.
05-12-2009 04:21 PM
MouthfulOfGrass Do you have an inline fuel filter added to your fuel line ? I'm not talking about the filter inside the tank, but if another was added. Sometimes if they get sediment in them, with enough shaking they'll clog a little.

Catalytic converter - if some of the element inside breaks loose and blocks the flow, it'll act something like your explaining, then unblock when stopped or sitting.

Loose wire. Or wire with internal crack or separation inside the insulation.

Loose fuse.

I've had problems in the past that are similar to yours, but not just like it. So it's hard to say for certain.
05-12-2009 02:33 PM
Proud American
Help, my Jeep keeps cutting out and stalling on heavy washboard roads…

Gentlemen,

I’m new to your forum and I was hoping for your suggestions to a problem I keep having with my TJ. I have 1997 Wrangler with a 4 cylinder engine and 125,000 miles on it. The Jeep is a second vehicle for me and runs perfect when I'm driving around town. However, when go camping I need to take the Jeep down an 8 mile washboard road. The road is not difficult to for a Jeep and most two wheel drive cars make it.

On the last two trips I’ll be driving down the washboard trail at various speeds (15-35 MPH) and all of sudden the Jeep will loss power and die. The radio will still be on but all gauges with go out. Once I feel the Jeep is dying (losing RPM’s) I’m sometimes able to shift into neutral and aggressively pump the gas gauge a couple of times to get my RPM’s up and get myself out of it.

Once the Jeep dies I'm usually able to start the vehicle up again. One time I couldn’t start it up again and tried it the next morning and it started up fine. When it wont start the motor cranks fine but it wont turn over. The faster I travel on the washboard the worst the problem gets and I’ll stall all of the time. The last trip I couldn’t the Jeep out of 1st gear! But, once on the highway I was fine at any speed.

I recently took the Jeep to my mechanic that specializes in electrical and they couldn’t find anything wrong with it. Probably because they couldn’t get it to stall in the city. They looked at it sparingly for the course of two week and drove it all around town without fail. This whole situation is a pain in my ass considering I only use the Jeep for camping. A couple of my colleagues think the problem might be the fuel pump after hearing “Once I feel the Jeep is dying I’m sometimes able to shift into neutral and pump the gas gauge a couple of times to get my RPMS up and get myself out of it.” At this stage I'm open for any suggestions I cant imagine I'm to only guy to have this problem.

Thank you in advance for any suggestions you might have.

Sincerely,

Proud American

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:33 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC