Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Help with fuel problem

Join Wrangler Forum Today


Thread: Help with fuel problem Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-05-2013 09:23 AM
kfdjason7620 It could easily be a leaking injector. But at $50 a piece, that's an expensive guess to replace all 6
05-05-2013 07:50 AM
Hightech I think it could be a leaking fuel injector. What about a bad PCM?
05-04-2013 09:49 AM
Hightech Less than a year old cranks strong. So after a TJ sits overnight, there should be fuel in the fuel rail? When I checked the valve this morning not a drop of fuel.
05-04-2013 09:28 AM
kfdjason7620 You are positive that the battery is good?
05-04-2013 08:52 AM
Hightech This morning I did this, still lazy start, but it did start
05-04-2013 08:23 AM
kfdjason7620 Next time it is cold, turn key to on for about 5 seconds and then off. Do this 3 times in a row and then immediately crank it. If it cranks up good then the new fuel regulator may be faulty.
05-04-2013 08:17 AM
Hightech
Help with fuel problem

Hello,

I'm a new member of the forum and need some opinions on what could be wrong with my 2001 4.0L Wrangler.

About a month ago I had the valve cover gasket replaced, no big deal. Then shortly after I noticed every morning a "lazy start". The battery is fine, the starter is fine.

So I checked the fuel rail one morning before the start and not one drop of fuel came out the valve, jeep sat about 12 hrs. So my mechanic pressure tested the system and it showed a drop after several hours. So last week had the fuel pump replaced with the regulator, all factory stuff. Also put in new factory spark plugs, cleaned throttle body, new air cleaner. Lastly had a new crank sensor replaced.

Still have the same problem, I went out and checked the fuel rail valve, still not one drop of fuel in the rail.

Jeep will start after cranking for awhile, after it starts it runs strong, idles fine.

What to check next????

Thanks,

Tim

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:36 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC