Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Error code help!

Join Wrangler Forum Today


Thread: Error code help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-19-2013 11:48 AM
Garyk The maintenance light will come on if the o2 sensor times out. In older models this could be disconnected, in these it has to be reset.....some disconnect the maintenance required light.
CEL is different. That one will clear .
05-19-2013 08:53 AM
OverkillYJ I replaced the MAP sensor and the MAP error went away. Then I changed the O2 sensor and the other 2 errors went away. No more check engine light. Not sure about Maint Req light though. I have never seen that one. I have only seen the Brake light, seatbelt light, and check engine light.
05-18-2013 11:17 PM
redneckbrat
Quote:
Originally Posted by OverkillYJ View Post
Thats wrong anyway. Will go off when fixed like every other code I have fixed.
It's been over 180 miles, still not off. I wonder what else I need to fix for it to go out.
05-05-2013 06:52 PM
OverkillYJ
Quote:
Originally Posted by redneckbrat View Post

That sucks.
Thats wrong anyway. Will go off when fixed like every other code I have fixed.
05-05-2013 05:01 PM
redneckbrat
Quote:
Originally Posted by Garyk View Post
Your maint light will not go off, has to reset by a dealer.
That sucks.
05-05-2013 12:31 PM
Garyk
Quote:
Originally Posted by redneckbrat View Post
Change your O2 sensor. I had the same codes, Check engine light went off. Still waiting for the Maint Req light to go out.
Your maint light will not go off, has to reset by a dealer.
05-04-2013 10:19 PM
redneckbrat Change your O2 sensor. I had the same codes, Check engine light went off. Still waiting for the Maint Req light to go out.
05-04-2013 07:07 PM
OverkillYJ bump
05-03-2013 08:16 AM
OverkillYJ So this is what they mean, but what would cause this? Could it be a clogged injector alone? That would be my first though, but would that trigger any problems with the MAP sensor?

51 O2S signal stays below center (lean)
21 O2S stays at center or O2S shorted to voltage
14 MAP sensor voltage too low or too high
05-02-2013 09:37 PM
wrangleryj90 I have the same problem with mine I am not throwing a code tho
05-02-2013 09:29 PM
OverkillYJ
Error code help!

I have an occasional low idle and error codes 51, 21, & 14. Anyone know what would cause all three of these error codes at the same time? Jeep is driving fine. No loss of power or anything. Just 1 in ever 10 times I stop or so id idles down around 600 rms. I would replace the MAP sensor, but sine I have the two other codes at the same time I am not sure if something else may be to blame.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:34 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC