Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Turn signal interfering with the radio ?

Join Wrangler Forum Today


Thread: Turn signal interfering with the radio ? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-14-2009 01:35 PM
Jerry Bransford Bad grounds are suggested way too often for problems like this but in this case, I believe that's what the problem likely is. I would make sure it has a good solid ground connection between the aftermarket radio's chassis or negative power wire and a bare metal connection somewhere on the tub. Or carefully splice it onto a known good solid ground connection.

One more thing that can cause that is if you powered the radio from an electrically noisy circuit (like a circuit that somehow connected to the turn signals) or perhaps you used or connected to an undersized power wire.
05-14-2009 01:30 PM
BARKDOG67 Its an aftermarket radio I just pulled it out of the dash and rechecked all of the wiring. I found that if you disconnect the 12v switch wire coming from the ignition switch and just wire the radio strait to the battery it dose not do it. So it has something to do with the ignition switch or the switch cluster for the turn signal and wipers. I wish there was a way to figure this out without throwing some parts at it. I might try grounding the radio in a different location to see if that helps I haven't tried that yet.
05-14-2009 12:47 PM
snwchris Is the radio, factory or aftermarket??? the only thing I canthink of off hand would be the power wires or leads. Almost the same thing with CB's interfering as well, if you sometimes tap into a wire like that can cause issues with interference.

Chris
05-14-2009 12:16 PM
BARKDOG67
Turn signal interfering with the radio ?

My wife has been driving the jeep for the past couple of days and was complaining about the turn signal interfering with the radio. I thought she was nuts at first because I had not noticed anything wrong with it. Today I was driving up north to my mother in laws and when I turned left the radio sounded like it cut out for a split second, it didn't loose power or anything but you can tell the turn signal is interfering with the radio I also noticed it with the winshield wipers also when you first switch them on. The wiring for the radio is fine I know this has to be a problem with the switch in the column of the steering wheel has anyone had this problem before My jeep is a 99' sport if that helps.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:14 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC