Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum > Front End Clunk

Join Wrangler Forum Today


Thread: Front End Clunk Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-25-2009 01:03 PM
leesmythe what did u figure out??
05-22-2009 03:21 PM
leesmythe and per ur other problem i would bet some money that it ur lower ball joint(s).

if ur not completely satisfied checking it the way snwchris said. (which is alwasy first step for me) second step being;

again jack it up, and get a crowbar and wedge it on the bottom of the tire to something sturdy on the axle(ball joint, u joint) and pull back and forth to see if there is excessive play.
05-22-2009 03:17 PM
leesmythe
Quote:
Originally Posted by tcomil2 View Post
Should I keep the jeep parked until this can be fixed? Will it cause other parts to fail? Is it unsafe?

I'll check related posts, but is it easy to fix a parking brake? The jeep rolls backward when it is pulled up. I tried it several times. It seems to stop the jeep from rolling forward... You guys are the best!

Thanks,
Christin

my jeep kinda rolls to.. if it does i just put it in first gear and let it be. and it shouldnt roll.
05-22-2009 12:37 PM
1997redTJ hey while were on this subject i have a noise that sounds kinda like a clunk and its only when i accerate in a forward gear, it will not do it in reverse, or when in nutral going down a hill any ideas?
05-15-2009 06:08 PM
tcomil2 Should I keep the jeep parked until this can be fixed? Will it cause other parts to fail? Is it unsafe?

I'll check related posts, but is it easy to fix a parking brake? The jeep rolls backward when it is pulled up. I tried it several times. It seems to stop the jeep from rolling forward... You guys are the best!

Thanks,
Christin
05-15-2009 10:45 AM
4point Judging by the looks of things and the mileage you have I'd say it time for some PM on it. Start replacing things before they fail, rod ends, U joints, unit bearings, bushings.... You don't have to do it all at once.
05-15-2009 10:28 AM
Rawkon dont forget about your upper control arm bushings.
05-15-2009 08:37 AM
tcomil2
Thanks!

Thanks guys, I'll let you know how it goes!

Christin
05-15-2009 08:17 AM
snwchris KellyK, check your Trackbar Bolts both frame side & axle side
05-14-2009 10:24 PM
KellyK I have the same issue. No idea what it is yet.
I have new jks quick disco's and my joints seem to be fine.
05-14-2009 07:56 PM
snwchris Hmmm... the seals around the u-joint caps definately look like they are fairly worn. During the 177k miles have the u-joints been replaced???? If not, for maintainence purposes might want to look into havnig them replaced. Those u-joints are usually about $20ea I think at Napa or most local autostores, that carry Precision (NAPA) or Nepco u-joints.

If you have a jack try the ball joint test mentioned above and while the wheels are turned out, slowly rotate one of the tires, watching the u-joint to see if they make any binding noises. If not then it might only be isolated to the Swaybar End Link.

I would start with replacment of the Swaybar End Link to remove that from the equation to see if that solves the other issue.

Chris
05-14-2009 07:42 PM
tcomil2 I think these can help. If they aren't right, I can re-shoot. I had to look up what a u-joint was.... learn something new every day.

Original owner, 177,000 miles, only off road on dirt roads.


Thanks Again!
Christin
05-14-2009 07:13 PM
SurfNaked2010 yea that does look pretty bad! lol im sry i cant tell anything from those pictures but maybe someone else could
05-14-2009 07:12 PM
snwchris The Lower Ball Joint in the first pic looks like it's not holding any grease compared to the other ball joints in the other pic.

One way to determine is to jack up the front end and grab the tire by the top & bottom and rock back n forth to see if there excessive play.

How many miles are on Jeep??? original owner??? If not the original owner, do you know if it was ever offroad???

it's hard to tell but from what I can see the u-joints seem ok, but wouldn't be bad idea to look into replace them down the road. They look like they've been in there a long time and I'm almost willing to bet that time alone that the needle bearings in the cap might be close to having no grease.

With the wheels turned out, any chance of a pic of the u-joint body or cross of the body. You might have to get a close-up or use the macro onthe camera.
05-14-2009 06:47 PM
tcomil2 Hahah, it looks like a rusty old dinosaur skeleton under there! Thanks for looking at these pics.
05-14-2009 06:24 PM
snwchris Yep, broken Swaybar End Link.
You'll want to go to the autostore and get some PB Blaster to spray on that and let soak in for a couple days and will some what help with trying to remove the bolts. Once the nut is off the bolt, sometime you need to persued it with a Big Hammer or another option is using a Pitman Arm Puller or a 2 Jaw Puller.

Depending on how your Jeep is used if mainly a Daily Driver then would get the stock end links. If it does see some offroad I would opt. for the JKS Quick Disconnects.

Your turning and clunk might also be related to this but I would look over the u-joints on the front axle on the inside of the wheel hub or end of axle tube. Seeing the amount of rust & corrosion makes me wonder what the u-joints look like.

If you can try taking a pic of both pass & drivers side u-joints. I would say try turning the wheels out on each side to get a better look & picture.

Chris
05-14-2009 06:24 PM
tcomil2
Thanks

Thanks for your reply. Would this broken part make the clunk? Is this something I can replace myself? I have few tools...

Christin
05-14-2009 06:12 PM
SurfNaked2010 your undercarriage looks pretty rusted im guessing you live somewhere near saltwater or just go offroading a lot? when you change the link soak the old bolt and nut in penetration spray and let it soak in for a while. it will make it a lot easier to remove
05-14-2009 06:06 PM
SurfNaked2010 thats a Sway Bar Link. you can get a new one from quadratec here is the link

Original Replacement Parts 52087771 - Front Sway Bar Link for 97-06 Jeep® Wrangler TJ & Unlimited w/o Lift - Quadratec

and no you should not get any bump steer while in 2wd and i dont think the sway bar link could cause that. check your steering stabilizer and make sure all of the bolts are tight on your tie rod and all your steering linkage.
05-14-2009 05:43 PM
tcomil2
Front End Clunk

I have recently been hearing a clunk on the driver's side underneath, when turning and going over a bump at the same time, or going over a bump with the driver side tire.. I am a mom... and don't know much about the jeep.... but found, this part (in photo) that is obviously broken. Is it possible that this noise is making the clunk?

Another strange thing; when turning on pavement, the front tire acts a little like it is in 4wd. It jerks a little. Does this point toward the broken item in the photo?

What is the broken thing in the photo?

97 wrangler manual transmission

Thanks a lot!
Christin

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC