Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Tech Forums > General Jeep Discussion > Having difficulties getting my new winch to work...

Join Wrangler Forum Today


Thread: Having difficulties getting my new winch to work... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-07-2013 06:03 AM
kisportolt happy to help, glad to hear you got it working. I know, those directions are terrible and that one diagram in it doesn't really show that post well.
05-06-2013 11:17 PM
Billmummey I didn't see that stud on the bottom of the winch and it didn't show it in the pics, I wish I would of caught that before I mounted it but I managed to get it on and it works great thanks
05-06-2013 11:11 PM
Billmummey Thanks I got it going, that's what it was too
05-06-2013 09:14 PM
kisportolt the smaller black wire attaches to the bolt on the winch where the battery negative wire attaches (the bottom post on the underside of the cylinder portion of the winch) the winch won't work until that wire is connected
05-06-2013 07:44 PM
cbell77 I would recommend grounding to your chassis make sure there is exposed metal clean it up a bit with some sand paper and a towel (always use a bolted ground). Your battery ground just grounds out through your alternator ground. Another reason is if for some reason your batterys connection to the alternator were to ever come loose it could cause your battery to attempt to ground out through your winch. electricity is lazy and will always take the path of least resistance to ground.
05-06-2013 01:58 PM
Billmummey
Having difficulties getting my new winch to work...

It's a badlands 12,000.... The instructions are good until I get to the ground that goes to the battery, it does not tell me where to connect it to the winch Or the smaller black wire I'm assuming is a body ground

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 06:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC