Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Body Mount Rust Help

Join Wrangler Forum Today


Thread: Body Mount Rust Help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-08-2013 11:05 PM
G-LOVE Having done something very similar to this, I would like to weigh in. First, it looks like your frame is is good shape. What I see is rust on the underside of your tub (body). Your body mounts look good as well. Have you tried to loosen any of your body mount bolts yet? This could give you an indication as to any rust you may have inside the tub, where the bolts thread into.

At the least I would poke around and chip away all of the scale and rust to get the best look at what you are dealing with. If you're lucky, you can weld a plate over that section, and call it a day. Good luck.

-Jim
05-08-2013 08:31 PM
Duckmasterlack Thanks guys is there a kit I can buy and cut the old sections out and weld in new ones or will I need to make something out of flat bar. I was aware the rear was prone to rust everything else on this jeep is solid even the body. This is the only place I have anything other than surface rust.

Kshaws I actually need to drop my transfer case skid pan soon as I have a 2 bolts on my transmission pan that were striped by the PO. After doing a little research on doing so and I don't know if I want to run the risk of breaking the nuts off the frame. I plan on making a new thread on that subject.
05-08-2013 07:17 PM
kshaws21 Make sure to check where the transfer case skid mounts to the frame, you could end up with this:



Attachment 246798
05-08-2013 07:14 PM
larjeep That's more then rust there is a whole in the frame. It is coo on for them to rust but more in the rear. U need to clean it up ASAP and weld in a piece to replace that mess or it it spread.
05-08-2013 07:05 PM
Duckmasterlack Since no one has responded to my post here I guess it can be one of three things I am the only one with this problem, this is a lost cause or am I beating a dead horse.
05-07-2013 08:39 PM
Duckmasterlack
Body Mount Rust Help

Okay on my 99 Sport I was crawling around underneath for the first time sine I bought it. Well everything is in great shape except for two spots where my body mounts to the frame. This is located on the driver side about center with the



Is this a common problem and is there a fix. Is this a serious safety issue or can I let it slide for a little while. This isn't my DD so I can work on it when I have the time. I have a little metal working experience and not afraid to grab a grinder and a mig welder.

Thanks for the help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC