Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Click sound and slight vibe when coasting

Join Wrangler Forum Today


Thread: Click sound and slight vibe when coasting Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-11-2013 09:18 PM
Jkfletch7
Quote:
Originally Posted by jagerhelix View Post

Winner winner chicken dinner.

4 out of 5 lugs had nearly walked off
Good thing you found it !
05-11-2013 05:24 PM
jagerhelix
Quote:
Originally Posted by Jkfletch7 View Post
Check the lugs, sounds like they are loose and you definitely do not want to lose a wheel while driving
Winner winner chicken dinner.

4 out of 5 lugs had nearly walked off
05-11-2013 03:46 PM
Jkfletch7 Check the lugs, sounds like they are loose and you definitely do not want to lose a wheel while driving
05-11-2013 03:36 PM
jagerhelix Just noticed today I'm getting a strange click sound from the left rear tire area. It speeds up as my speed increases. I also started getting a slight (non-steering) vibe when I let off the gas. I am still on stock drive shafts with 3.5" lift so I'm not sure if that's the issue. Or if it's two seperate issues. They both started off at the same time so they seem related.

Suggestions right off the bat? Not sure if I'll have time to dig into it today.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:58 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC