Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Horn going off when door opens

Join Wrangler Forum Today


Thread: Horn going off when door opens Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-21-2013 11:46 AM
BManz I had the problem intermittently and a STAR case determined it was a bad cruise-control switch in the steering wheel (2012 JK). They replaced the switch with another and the problem recurred again right away so replaced it yet again to solve the problem. Supposedly there are a number of bad switches out there in the parts inventory chain. The new cruise switch fixed the problem and I've gone many months and many thousands of miles since, problem free. I know it sounds strange as a clock spring or horn contact inside the steering wheel would have been my guess.
07-21-2013 10:52 AM
Wrong Way Hal Hey,

Had / Have same problem. The second attempted fix was back in March 2013. According to the worksheet, dealer replaced the horn switch, steering wheel harness, clock spring, speed control switch and then clock spring again.

Since the computer error codes were not providing any useful information, the dealer had to contact "STAR" and submit a case with them. STAR recommended the replacement of all of the above parts.

This was all done on 3/9. The EXACT same problem returned on 7/19. I'll be calling the dealer Monday morning to schedule another appointment.

Regards,
05-14-2013 11:14 AM
yjswampthing There is another couple of threads on this. Started on my 2012 the day after I got it (9k miles).

http://www.wranglerforum.com/f33/hor...on-214952.html



Was taking off the top and the horn stayed on like someone was laying on it. Took it right back to the dealer as it kept happening. They thought it was the alarm system but I knew that wasn't it right off the bat (kinda disheartening when you realize you have better sense about car issues than a service guy at a dealership)

Anyways did some research, found out others had this with different culprits. Water in the Horn, Radio, and cruise control buttons, etc seem to be the common ones so I shared my concern with the dealer on having to bring it back and forth while they played guessing games on what might be wrong.

They went the extra mile and replaced the whole unit (forgetting what they called it) but all the control module in the steering wheel instead of just the cruise switch or clockspring or whatever and I have not had the issue come back (knock on wood) for about 2 months now.
05-13-2013 01:20 PM
heinzbean Check your door plug/connectors my left side was full of water (don't ask)
sent everything crazy on my jeep and very easy to check.

Then I found out why some idiot had cut a hole in a factory grommet (to install parking sensors (probably a dealer). Water was running along this cable and dripping into the door plug.

Just unplug then tap see if any water comes out .
05-13-2013 07:19 AM
Lithium Lotus Sounds like the computer is reading something weird.
05-13-2013 06:21 AM
TechDan
Horn going off when door opens

Started yesterday, every time I would open a door or unlock with my fob, the horn would sound a constant honk. Not the honk-honk-honk of the alarm. I'd jump in, start it, push on the horn, everything I could think of to stop it. After about 30 seconds, it would go off. Don't know if it was on its own or from something I did. I disconnected the battery to reset the system but as soon as I made contact again the horn went off. So I just unhooked both horns until I get a chance to get it in the shop.
Has anyone else seen this? I'm thinking about just taking it to a local auto parts store and checking and clearing the code instead of messing with a dealership.
Any ideas or suggestions would be great!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:14 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC