Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ General Discussion Forum > Fuel problem or ecu

Join Wrangler Forum Today


Thread: Fuel problem or ecu Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-23-2013 10:22 AM
Wrangleriffic Gonna turn in the old one for a core charge. On an unrelated topic.... does anyone know how to remove the original factory skins from the frame? The soft winows I mean. The replacement skins attach with velcro. The originals look like they are sewn on. do I need to Cut the sewn areas to remove it?
05-22-2013 08:33 AM
95YamJam Fix the caps in your old ecu and sell it.
05-21-2013 11:09 PM
ChicoJeepy
Quote:
Originally Posted by Wrangleriffic View Post
Yeah hope this nailed it. Been trying at different times of the day and it keeps turning over and starting! Also the previous owner just told me she still has the bikini top and brand new plastic windows for the soft top that she will give me !
Nice man glad it's working out for you. She must be a really nice lady to give you that top.
05-21-2013 06:28 PM
Wrangleriffic Yeah hope this nailed it. Been trying at different times of the day and it keeps turning over and starting! Also the previous owner just told me she still has the bikini top and brand new plastic windows for the soft top that she will give me !
05-17-2013 08:29 AM
sevenservices yupper, those capicitors in there do that for sure. On really cold mornings I had to wait almost 20 minutes sometimes for mine to kick in. Def. the PCU/ECM. Been great since replacing it a few yrs back.
05-17-2013 12:23 AM
Keymo
Quote:
Originally Posted by Wrangleriffic View Post
Hello all

I am a very happy Jeeper today! Found the answer to the other half of my problem. On a very expensive hunch i bought a new ecm plugged it in and the beast roared to life with the first crank! dont want to jinx it so ill try several different times throughout the next couple of days and see how it acts. There was a definite fuel pressure problem which is fixed and the gas tank is mounted back up. Had to take it back down when i reversed the rubber fuel lines! But all good now!
That's GREAT to hear!
Hopefully she keeps firing for you!
05-16-2013 11:35 PM
Wrangleriffic Hello all

I am a very happy Jeeper today! Found the answer to the other half of my problem. On a very expensive hunch i bought a new ecm plugged it in and the beast roared to life with the first crank! dont want to jinx it so ill try several different times throughout the next couple of days and see how it acts. There was a definite fuel pressure problem which is fixed and the gas tank is mounted back up. Had to take it back down when i reversed the rubber fuel lines! But all good now!
04-28-2013 09:27 PM
Keymo
Quote:
Originally Posted by Redrider94 View Post
Search ECU BRAIN SURGERY I think this may help you.
x2 on this!
I never even thought of that and then when I read Redrider94's post I was: Should've thought to mention it...
04-28-2013 01:20 PM
Redrider94
Quote:
Originally Posted by Wrangleriffic View Post
Just to add another idea i warmed up the ecu with a hair dryer not sure why just a hunch. turned the key on and it fired right up. Any one else ever heard of this?
Search ECU BRAIN SURGERY I think this may help you.
04-28-2013 12:23 PM
Wrangleriffic Just to add another idea i warmed up the ecu with a hair dryer not sure why just a hunch. turned the key on and it fired right up. Any one else ever heard of this?
04-28-2013 11:32 AM
Wrangleriffic Ok update to the problem, Tried starting it this morning same deal had to turn on key and wait ten minutes then it fired right up. Its a 95 wrangler fuel injected I have replaced the tps and the fuel pump. Fuel is at the proper pressure now fuel pump engages and i see the pressure gauge jump to 40 psi for a second so I know the fuel rail is pressurized. Its a 2.5 l 4 cyl. not sure where to start next.
04-28-2013 07:01 AM
Keymo

First off, so your "turn the key on for 10 years (jokes) to prime the pump before you start" problem is solved, right??

What year is that bad boy? Is it EFI or Carb'd? Have you checked your cylinders for compression? You said the "Check Engine Light" comes on?? Have you checked the computer for codes?

If you're getting proper pressure the whole time, and you KNOW that fuel is making it all the way to the engine - I wouldn't think that it's a fuel problem... Unless your carb jets or injectors are bad...

If it's carb'd, for the initial rough running condition, I would suggest that your choke on the carb could be either shot or going bad... I know that's what happened to my J-truck when the thermostatic choke finally bit the dust. She'd take a few more cranks than normal to start and then would stall and run rough for a little bit because the air/fuel mixture was off. It could still be a number of other things if it's carb'd - but that would be the first thing I would think of if this was happening to one of my vehicles. (Actually, I think the thermostatic choke IS going out on my YJ's carb as well, but I plan on getting a totally new carb - so I'm leaving it be) An easy fix is rigging up your own manual choke - like what's on old tractors. You can also install a new thermostatic choke - but that's just another part that one day will fail again. A properly set up manual choke will never fail. But I really REALLY don't think the "Check Engine Light" would come on with a bad choke on your carb...

With EFI, I'm not so confident - I know a bit about it, but I'm better with carbs... Have you checked your O2 sensor (though I don't think that's your problem)? MAP sensor? I know the TPS and CPS can cause some rough starting and stalling issues... With EFI, in my mind, it started getting a lot more complicated because a majority of the sensors and what-not are needed to be working properly for the computer to tell the injectors (and other systems) what they need to be doing in order for your engine to be running properly. Your ECU COULD be bad - though if it's ONLY during the initial starting/"warming up" thats running rough, I would doubt that it would be strictly the ECU that's at fault.

Give us some more info and we might be able to help diagnose a little better... What all has been replaced recently? What all have you checked other than the fuel pressure?

Sorry... That's all I got for now.
04-26-2013 08:35 PM
Wrangleriffic
Fuel problem or ecu

Hello All
i recently had to replace my fuel pump. Well i have the proper amount of fuel pressure now. Had a problem with the Jeep not starting and having to wait 10 minutes with the key on to get it to start. It would do this every time. Replaced the fuel pump and this seems to have fixed some of the problem. Now when it sits for a while I turn the key on and it will attempt to start but then it will run very rough and stall. Eventually it will smooth out and run just fine. Also the check engine light will go on and off while it's running very rough The fuel pump pressure is right where it should be while it's doing all of this any ideas please help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:29 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC