Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Check Gauges/Starting Issue

Join Wrangler Forum Today


Thread: Check Gauges/Starting Issue Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-18-2013 09:50 AM
docpowers Thank you, I am waiting patiently on UPS right now, I'm going to change plugs, rotor, cap, wires... and clean the battery terminals. I'm not the most competent when it comes to electricity.. there's no way I will get shocked right lol, I once touched a distributor cap while the truck was on.. while my father watched...
05-17-2013 09:10 AM
Big Sarge I would pull the battery cables first. Clean them up really well and also clean the battery posts. May be the problem with both the voltage spike and hard cranking. You will soon have a no crank problem if this is the issue.
05-17-2013 08:07 AM
docpowers
Check Gauges/Starting Issue

Any information on what would causes the battery level to spike to the right and the check gauges light to come on for around 20 seconds? I had just replaced the water pump at this time, but it still had a light leak due to some mechanical ignorance.. Any ideas?

Also... it has become progressively harder to crank.. I am changing the cap, rotor, plugs, and wires today... should this help? Thank you.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:01 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC