Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > General Jeep Discussion > Smittybilt tire carrier rusted and broke

Join Wrangler Forum Today


Thread: Smittybilt tire carrier rusted and broke Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-31-2013 09:49 AM
VTBalla34 Just an update I went and picked up the new carrier over memorial day weekend. The shop was only doing a replacement part but not the labor, which is understandable.

They quoted about 2 hours at $70/hr so I just had them take off the old one for $30 and would install it myself. Figured it would be a fun project to get my hands dirty on.

This thing was a huge pain in the ass. There is no key/legend for the parts, only a list. The list was totally wrong on most of the bolt sizes and quantities so that was a pretty frustrating guessing game. There was also way more parts than actually needed with absolutely no mention of them in the instructions.The instructions were pretty good and easy to follow once you figured out which parts they actually wanted you to use though.

Took me about 4 hours I would guess working alone. Half of that time was spent trying to sort the parts discrepancies out. Pretty shitty job on SB's part putting the package together.

I still have about an hour of rework to do because I mounted the tire bracket up too high on the mount and it partially blocks my third brake light. It would not be hard at all for them to put a guideline together for different tire sizes but they obviously didn't feel like that was worth the effort.

Decided not to coat it and just to keep an eye on this one. It seemed rougher than the original so hopefully the material is a bit more robust. I have a garage now too so it won't see shitty weather as much as it had.
05-18-2013 04:57 AM
blkrubi88
Quote:
Originally Posted by VTBalla34 View Post
Awesome. That's what I was looking for. I'll check into it. Appreciate you taking the time to read the actual question. Thanks brother.
No problem. Good luck.
05-17-2013 11:34 PM
VTBalla34
Quote:
Originally Posted by Evian View Post
Avoid Smittybilt! They have too many complaints about their products.
Well that ship has already sailed obviously so I don't think its at all relevant to the problem at hand.
05-17-2013 11:33 PM
VTBalla34
Quote:
Originally Posted by blkrubi88 View Post

Maybe try POR-15, a lot of people coat their frame with it. It prevents rust.
Awesome. That's what I was looking for. I'll check into it. Appreciate you taking the time to read the actual question. Thanks brother.
05-17-2013 09:31 PM
Evian Avoid Smittybilt! They have too many complaints about their products.
05-17-2013 03:31 PM
blkrubi88
Quote:
Originally Posted by VTBalla34 View Post
Dealer had a local shop put everything on it, including bumper and carrier, in February 2012.

I have seen more than one complaint for this exact issue. It is obviously a problem. My question is what can I use to coat it to protect it?
Maybe try POR-15, a lot of people coat their frame with it. It prevents rust.
05-17-2013 03:12 PM
VTBalla34
Quote:
Originally Posted by blkrubi88 View Post
Was the bumper put on by the original owner or the dealer?
Do you know if the Jeep was a local trade? Because it could have came from somewhere up North and was bought at an auction.
Dealer had a local shop put everything on it, including bumper and carrier, in February 2012.

I have seen more than one complaint for this exact issue. It is obviously a problem. My question is what can I use to coat it to protect it?
05-17-2013 11:08 AM
blkrubi88 Was the bumper put on by the original owner or the dealer?
Do you know if the Jeep was a local trade? Because it could have came from somewhere up North and was bought at an auction.
05-17-2013 10:36 AM
VTBalla34
Quote:
Originally Posted by XTZach View Post

VTBalla,

I just realized what you meant now. I'm sorry, I was looking at the pictures all wrong. That bolt was rusted and might have been too weak to hold the carrier. When you get the new carrier, go to your local hardware store and get some grade 8 bolts that will fit in there. You can even get stainless steel hardware which shouldn't rust away like that.

-Zach
Cool I will definitely do that but its not just the bolt that rusted--its the whole darn hinge. I'm sure the broken bolt head put a lot of torque on the hinge plate but it cracked in half too which looks like from rust (and torque of course). Was thinking it would be beneficial to somehow coat the whole setup.

Is there not some sort of clear coat product that would fit the bill?
05-17-2013 09:44 AM
XTRyan
Quote:
Originally Posted by VTBalla34 View Post
Its not really the finish I don't think. I may not be describing it correctly but it is the actual metal piece that connects the tire carrier to the bumper. It has 3 bolt holes into the bumper and swivels out when you open it up, if that makes sense. I will try your idea though. Thanks.
VTBalla,

I just realized what you meant now. I'm sorry, I was looking at the pictures all wrong. That bolt was rusted and might have been too weak to hold the carrier. When you get the new carrier, go to your local hardware store and get some grade 8 bolts that will fit in there. You can even get stainless steel hardware which shouldn't rust away like that.

-Zach
05-17-2013 05:15 AM
blkrubi88
Quote:
Originally Posted by VTBalla34 View Post
Do you keep yours parked in a garage?
Only in the summer I do, because I run bikini top and no doors all summer.
05-17-2013 12:13 AM
SuicideSaints
Quote:
Originally Posted by VTBalla34 View Post

Eh I would be surprised if they gave me a credit after 15 months, especially since I am not the original owner. I am fine with a replacement if I can keep it in working order.
You are probably right. It was just a thought, at least you are getting it fixed for free. Like I said though I do love the look of SB products.
05-16-2013 11:08 PM
VTBalla34
Quote:
Originally Posted by XTZach View Post

I can't really tell from the pictures, but it looks like it's the textured finish, right? If so, Duplicolor Bed Armor dries to look almost identical to the Smittybilt powder coating. If you want to make sure it won't happen again, get a can of that and coat the area you're worried about. Sand the current finish off, or as close to bare metal as you can get. Then just spray the bed liner on and you'll be set.

Hope this helps! PM me if you have any questions.

-Zach
Its not really the finish I don't think. I may not be describing it correctly but it is the actual metal piece that connects the tire carrier to the bumper. It has 3 bolt holes into the bumper and swivels out when you open it up, if that makes sense. I will try your idea though. Thanks.
05-16-2013 11:06 PM
VTBalla34
Quote:
Originally Posted by blkrubi88 View Post
I've had mine on for over four years now and no issues.
Do you keep yours parked in a garage?
05-16-2013 11:06 PM
VTBalla34
Quote:
Originally Posted by SuicideSaints View Post
I love the look of SB products but I do not get them for this reason. The bed liner will help the next one but IMO SBs quality has gone down. I would ask for credit for the price of the bumper and select a better quality bumper. Just my 2 cents....
Eh I would be surprised if they gave me a credit after 15 months, especially since I am not the original owner. I am fine with a replacement if I can keep it in working order.
05-16-2013 12:54 PM
blkrubi88 I've had mine on for over four years now and no issues.
05-16-2013 12:26 PM
SuicideSaints I love the look of SB products but I do not get them for this reason. The bed liner will help the next one but IMO SBs quality has gone down. I would ask for credit for the price of the bumper and select a better quality bumper. Just my 2 cents....
05-16-2013 10:52 AM
XTRyan
Quote:
Originally Posted by VTBalla34 View Post
Well I agree there is no reason for it but I'm not sure what a phone call will accomplish. I'm already getting a replacement part at no cost.

Anybody have any advice on the Rust-oleum?
I can't really tell from the pictures, but it looks like it's the textured finish, right? If so, Duplicolor Bed Armor dries to look almost identical to the Smittybilt powder coating. If you want to make sure it won't happen again, get a can of that and coat the area you're worried about. Sand the current finish off, or as close to bare metal as you can get. Then just spray the bed liner on and you'll be set.

Hope this helps! PM me if you have any questions.

-Zach
05-16-2013 10:08 AM
VTBalla34
Quote:
Originally Posted by justin-branam View Post
Good that the shop is going to replace it, but I would still call Smittybilt directly and see what they say. There is no reason it should be rusting like that after only a year, much less be cracked.

Contact Us - Smittybilt
Well I agree there is no reason for it but I'm not sure what a phone call will accomplish. I'm already getting a replacement part at no cost.

Anybody have any advice on the Rust-oleum?
05-15-2013 03:15 PM
justin-branam Good that the shop is going to replace it, but I would still call Smittybilt directly and see what they say. There is no reason it should be rusting like that after only a year, much less be cracked.

Contact Us - Smittybilt
05-15-2013 03:02 PM
VTBalla34 Hey guys, bought my rig from the dealer with a SB bumper/carrier on it last October and didn't notice any issues at the time. Last week I noticed the carrier was leaning sideways and upon further inspection noticed the hinge was shot. One of the bolt heads had rusted completely off and the attachment itself is cracked in half. Its a wonder it didn't fall off on the highway and kill somebody!

I've attached pics.

Anyways the shop that did the work for the dealer said they would replace it but I've seen this issue on a couple Jeeps from searching around and want to make sure Im not replacing a carrier once a year (it was just installed back in February 2012).

Would a spray of rustoleum be enough to protect it? If so do I need to prime it or anything or just spray it on? I suppose its available in clear coat and not color? Anything else I need to consider?

Thanks!



Attachment 249440


Attachment 249441

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:34 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC