Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Dies after warm up

Join Wrangler Forum Today


Thread: Dies after warm up Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-19-2013 09:38 AM
Nubby55 Run a can of SeaFoam in the gas tank and see if it helps, I've seen that stuff do Great Things.
05-19-2013 09:37 AM
LUISB310 almost forgot, check the throttle plate/ base of the carburetor,they come loose and create a air leak, grab the top of the carb and wiggle it to see if there is any play, if it is you can just remove it and tighten the screws from the bottom of the carb
05-19-2013 09:32 AM
LUISB310 usually build up in the carb, pull the top cover and take a look, very easy to do,also check the intake manifold for leaks
05-18-2013 05:49 PM
kik Your carb might need a rebuild or replacement. Make sure you change the fuel filter. You can first try and clean the carb. Carb and choke cleaner works. And, your idle hot and in park/neutral should be at least 750-800 rpm.
05-18-2013 03:45 PM
SpartaYJ I'm new to the jeep world and the forum, but I am having a very similar problem. As soon as mine warms up, it will not idle and doesn't run very well under throttle either. It dies at every stop sign. It's got a new fuel pump, filter, pressure regulator, Weber 32/36 carb, and ignition coil. Runs great cold, but not well warm.
09-12-2012 12:52 PM
Bill_FL
Dies after warm up

I have a 90 YJ, carb'd 258. I bought it about a week ago and when you fire it up, as soon as it got to operating temp, it died. Wait a minute, and it would fire right back up and be fine. The PO had cobbled up the fuel system, so I had a new pump put in, we took out the tank its been cleaned and clean fuel back in. That did not solve it. From a cold start, when it gets up to operating temps, it dies. Sit for a minute, and fire it off and it wll go again and not die. I have read that this seems to be a common issue but suggestions have ranged on other threads from CPS, to nutter bypass, to ICM. Anyone have the problem and fixed it?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:23 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC