Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > 2013 JKU Audio Upgrade

Join Wrangler Forum Today


Thread: 2013 JKU Audio Upgrade Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-22-2013 03:17 PM
alaska_av8r Thanks Corey I may just do that because I cannot figure out if these factory speakers are wired at 2 ohms or 4 ohms....grrrr
05-22-2013 11:50 AM
CoreyZ No prob...

Let me just throw my 2 cents in on the install....

Since you are already going to have to pull the front speaker buckets out to put the new speakers in, I would suggest running all new speaker wire to your amp. Same goes for your sound bar. It actually in the long haul makes it easier and more versatile in the end when you upgrade the rest of the system or add on to it. Running new wire means that you only have 4 wires coming from up front to your amp (from the speakers), 4 wires coming down your roll bar from the speaker bar (from the speakers), then 8 wires going back up to the head unit wire harness from the amp for your signal. Then when you upgrade your head unit with one that has RCA outputs, you can remove that extra set of 8 wires to the amp and pull the RCA's in their place.
05-22-2013 10:51 AM
alaska_av8r I was hoping the sound bar would not be such a pain to run the wires through, oh well.

Thanks for the warning on the 2 ohms, I am planning on replacing the fronts and sound bar all at the same time, actually beginning today...hopefully...
05-22-2013 08:49 AM
CoreyZ
Quote:
Originally Posted by alaska_av8r View Post
Corey pardon my ignorance, but

How does that work? Isn't the remote amp power, a wire sending a small current to the amp causing it to power on?
With the new line of alpine amps, if you use the speaker level input (which is a little wire harness, easy to use) it can auto sense and turn the amp on rather than have to use a switched power source to tell the amp to turn on. It just saves 1 wire really, but it is nice.

Quote:
Originally Posted by gleek View Post
You are correct about the lack of RCA outputs out of the factory headunit, but I think the speaker level outs will pose somewhat problematic and have "weird" frequency curves. I was told if you wanted to go with the stock Headunit, you need a processor like the JL Cleansweep or the AudioControl LC series.
Quote:
Originally Posted by woansleftpeg View Post
Actually, I think Corey's right - looking at the specs, it seems that the Alpine MRX range is capable of handling speaker level inputs for this very purpose i.e. add-ons to factory head units that have no pre-outs. The fact that it senses the higher voltage and uses that as the turn-on signal is very clever.
Gracias... and yeah, it actually cleans up the sound nicely from the reviews ive read. Seems like they put some good thought into that part of the amp as to remove yet another random box in the setup for most folks that want to retain a factory system.

Quote:
Originally Posted by alaska_av8r View Post
Well I have the amp on the way along with Polk 6501 components for the front and 650's for the bar.

I am just trying to prepare as much in advance as I can, so my next question is does anyone know the path the speaker wires take to get to the sound bar. I plan on replacing those as well.
If you are splicing into the speakers anyways for the amp, no need to do it anywhere other than at the factory wire harness at the back of the stock radio. It sucks but you would run 2 sets of wires. One set for the speakers from the radio to the amp. THen another set from the amp back to the speaker wires you originally cut to run to the amp. Its just a back and forth if that makes sense. 16 wires total (8 each way). Once you get new speakers in the sound bar, you can either get the adapter or just cut off the stock plug and use some butt connectors to the new speaker's wires.

I will warn you though. The stock system is a 2 ohm speaker system from what ive read. The amp is a 4ohm so you will also want to replace the fronts fairly quickly.
05-21-2013 07:58 PM
woansleftpeg I ran new wires. I had to drill the soundbar to do it, and frankly it wasn't worth the massive ballache to do. Just tap the existing ones.
05-21-2013 07:44 PM
Mattk11
Quote:
Originally Posted by alaska_av8r View Post
Well I have the amp on the way along with Polk 6501 components for the front and 650's for the bar.

I am just trying to prepare as much in advance as I can, so my next question is does anyone know the path the speaker wires take to get to the sound bar. I plan on replacing those as well.
The sound bar plugs in on the passenger side. I just tapped into the existing speaker wires for the sound bar but replaced the speaker wire for the other speakers and sub.
05-21-2013 06:30 PM
alaska_av8r Well I have the amp on the way along with Polk 6501 components for the front and 650's for the bar.

I am just trying to prepare as much in advance as I can, so my next question is does anyone know the path the speaker wires take to get to the sound bar. I plan on replacing those as well.
05-21-2013 12:33 PM
alaska_av8r ty
05-20-2013 10:36 PM
woansleftpeg I don't believe so, no.
05-20-2013 09:32 PM
alaska_av8r Since the amp has that feature (sensing the higher voltage as a turn on signal) do I still need one of these (JL Cleansweep or the AudioControl LC series)? Really hate to spend money on something like that since I will likely add a new HU in the near future.
05-20-2013 09:14 PM
woansleftpeg
Quote:
Originally Posted by gleek View Post
You are correct about the lack of RCA outputs out of the factory headunit, but I think the speaker level outs will pose somewhat problematic and have "weird" frequency curves. I was told if you wanted to go with the stock Headunit, you need a processor like the JL Cleansweep or the AudioControl LC series.
Actually, I think Corey's right - looking at the specs, it seems that the Alpine MRX range is capable of handling speaker level inputs for this very purpose i.e. add-ons to factory head units that have no pre-outs. The fact that it senses the higher voltage and uses that as the turn-on signal is very clever.
05-20-2013 09:01 PM
gleek
Quote:
Originally Posted by alaska_av8r View Post
Wow thanks for all of the information, fantastic.

Let me see if I get this correct (old fart with near dimentia=me) When you guys are talking about speaker level inputs etc... I am assuming what you mean is the stock radio does not have RCA outputs for an AMP? And due to this I will actually take the speaker wire from the stock Radio and use that as the input to the Amp, instead of just using RCA's to connect the Amp.

Also a LOC I am assuming as you said just cleans the sound up and gains it down for input into the amp?

Corey pardon my ignorance, but

How does that work? Isn't the remote amp power, a wire sending a small current to the amp causing it to power on?
You are correct about the lack of RCA outputs out of the factory headunit, but I think the speaker level outs will pose somewhat problematic and have "weird" frequency curves. I was told if you wanted to go with the stock Headunit, you need a processor like the JL Cleansweep or the AudioControl LC series.
05-20-2013 05:37 PM
alaska_av8r Wow thanks for all of the information, fantastic.

Let me see if I get this correct (old fart with near dimentia=me) When you guys are talking about speaker level inputs etc... I am assuming what you mean is the stock radio does not have RCA outputs for an AMP? And due to this I will actually take the speaker wire from the stock Radio and use that as the input to the Amp, instead of just using RCA's to connect the Amp.

Also a LOC I am assuming as you said just cleans the sound up and gains it down for input into the amp?

Corey pardon my ignorance, but
Quote:
In fact if he uses them, he won't need a remote amp turn on lead.
How does that work? Isn't the remote amp power, a wire sending a small current to the amp causing it to power on?
05-20-2013 06:14 AM
CoreyZ Amp is 1 3/8" x 5 1/2" x 8 1/4". Holes are on one side 2 1/4" and 6 1/8" from bottom. Other side holes are 2 1/4" and 6 3/4" from bottom. Holes are all 1/4" from sides. All on center.
05-20-2013 06:08 AM
CoreyZ
Quote:
Originally Posted by woansleftpeg View Post
It will at least help with locations and dimensions for the mounting holes.
I'll post them in about 10 minutes then if it will help.
05-20-2013 06:08 AM
CoreyZ The v70 has speaker level inputs so no need for a LOC. In fact if he uses them, he won't need a remote amp turn on lead.

Quote:
Originally Posted by woansleftpeg View Post
I'll measure the amp bracket for you tomorrow, I have mine de-installed currently but I'm watching the hockey right now.

You won't need a harness, but you might need a line output converter to take the speaker level outputs from the head unit and convert them to an amp-ready pre-out signal. I believe that some people have connected the line outs of their factory HU directly to an amp, but if you do you'll probably get a "pop" on start up and it isn't great for the amp, I don't think. LOCs are relatively inexpensive.

KnuKonceptz do very good amp wiring kits, you can find them on Amazon.
05-19-2013 07:07 PM
woansleftpeg
Quote:
Originally Posted by CoreyZ View Post
The stock amp is pretty tiny and the v70 is larger.... So its dimensions won't help much.
It will at least help with locations and dimensions for the mounting holes.
05-19-2013 07:05 PM
woansleftpeg I'll measure the amp bracket for you tomorrow, I have mine de-installed currently but I'm watching the hockey right now.

You won't need a harness, but you might need a line output converter to take the speaker level outputs from the head unit and convert them to an amp-ready pre-out signal. I believe that some people have connected the line outs of their factory HU directly to an amp, but if you do you'll probably get a "pop" on start up and it isn't great for the amp, I don't think. LOCs are relatively inexpensive.

KnuKonceptz do very good amp wiring kits, you can find them on Amazon.
05-19-2013 07:01 PM
CoreyZ Oh and as for hooking it up, the head unit outputs high level / speaker level sound. This means either wire up a LOC or use the speaker inputs on the new amp (my suggestion). You will need to run new wire to the spot you spliced into to run to your amp. Essentially you will be sticking your amp between your current head unit and current speakers.
05-19-2013 06:58 PM
CoreyZ The stock amp is pretty tiny and the v70 is larger.... So its dimensions won't help much.
As for amp kits, you'll be using 4 gauge which you might find cheaper to buy by the foot from some local stereo shops. Also pick up a fuse and holder. Usually much cheaper than kits.
05-19-2013 06:48 PM
alaska_av8r
2013 JKU Audio Upgrade

I have a 2013 JKU that has the stock 130 radio with uConnect. I do not have a factory amp or sub.

Throughout my audio upgrade I do not want to lose the functionality of the steering wheel controls, I have already gotten spoiled.

I am going to install an Alpine MRX V70, 5 channel amp in the slot where the factory amp would have been located. For speakers I am going with the Polk mm651's, mm 6501's and mm840 sub.

I am not replacing the head unit at this time. I know I will have tons of questions but for now only have two.

Does anyone have the dimensions of the "amp bracket" as it appears I will have to fabricate one.

Also, my main question is since I will be installing the amp and connecting it to the factory 130, will I need some sort of wiring harness to plug into the 130? I also am looking for suggestions on which "amp wiring kit" to order.

thank you
tim

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:46 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC