Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Ticking noise

Join Wrangler Forum Today


Thread: Ticking noise Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
05-26-2013 08:05 AM
Sdt
Quote:
Originally Posted by Binx View Post
My transmission makes this noise like a ticking,tapping almost like an exhaust leak. Yours similar? Does it increase with speed? The ticking go faster as you do?
No the ticking,clicking stays the same and begins @45 and doesn't stop until you get below 45
05-26-2013 07:58 AM
Binx My transmission makes this noise like a ticking,tapping almost like an exhaust leak. Yours similar? Does it increase with speed? The ticking go faster as you do?
05-26-2013 07:45 AM
Sdt Would the differential cause a ticking noise?? I did notice a grey silicone seal around this
05-26-2013 07:36 AM
Sdt Manual
05-26-2013 07:35 AM
Sdt The front and starts at 45mph
05-26-2013 07:34 AM
Sdt I have checked that also, the dealership has installed new front hubs, however when I picked it up yesterday I was informed that I had a rear seal leaking, so it has to go back...... No one can figure this noise out
05-26-2013 07:31 AM
Rooster76 I have gotten a rock stuck in the rubicon KM tire's tread that made a ticking sound about like that. I thought I had messed up my differential before I found it. At low speed it didn't make the click, and at about 35 it would start up.
05-26-2013 07:26 AM
Binx Where is the sound coming from or where it sounds like its coming from? Auto or manual
05-26-2013 07:22 AM
Sdt Hey out there can anyone give me some feed back, this noise is driving me crazy
05-25-2013 08:27 AM
Sdt Forgot to mention its a JK
05-25-2013 08:12 AM
Sdt Yes, it's been back at the dealership for a week and they can not pin point the problem, it's starts @ 45 mph with the same consistency
05-25-2013 08:00 AM
kjeeper10 Hubs and joints already ? Was this to fix the clicking ?
05-25-2013 07:57 AM
Sdt
Ticking noise

I just purchased a 2012 Artic Edition with 18000 miles and for the past 2 weeks it has a clicking noise that now one can find, it's had new hubs installed, u joint checked...... Any Toughts??

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:09 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC