Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Uconnect Software Upgrade

Join Wrangler Forum Today


Thread: Uconnect Software Upgrade Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-09-2014 11:14 AM
xsdbs The RER does not support A2DP which is the profile needed to stream audio over BT.



Quote:
Originally Posted by FrozenPuma View Post
So I have a 730N RER and would like to keep it if possible. Other than using a aux bluetooth adapter is there any way to have bluetooth play from my iphone 5s through the radio?

If not what would be some suggestions on what to use instead of an adapter sticking out of the unit?

Also attached is the system info on it now. What are the current updates and how do I go about getting them?

Thanks
04-09-2014 11:09 AM
xsdbs you may be able to call the sales person that you purchased the vehicle from and ask them to get the Service mgr to go online to get it for you. They should only need the VIN # especially if the sales person remembers you.



Quote:
Originally Posted by soberbyker View Post
Thanks for the reply, I bought it new and there was no card in with the manual, already looked.
04-09-2014 09:29 AM
FrozenPuma So I have a 730N RER and would like to keep it if possible. Other than using a aux bluetooth adapter is there any way to have bluetooth play from my iphone 5s through the radio?

If not what would be some suggestions on what to use instead of an adapter sticking out of the unit?

Also attached is the system info on it now. What are the current updates and how do I go about getting them?

Thanks
03-26-2014 10:20 AM
soberbyker
Quote:
Originally Posted by xsdbs View Post
You can go to the dealer and have the service writers go online and get the code. I think that if the vehicle was purchased new, there may be a code card in the owners manual package.
Thanks for the reply, I bought it new and there was no card in with the manual, already looked.
03-26-2014 07:45 AM
xsdbs You can go to the dealer and have the service writers go online and get the code. I think that if the vehicle was purchased new, there may be a code card in the owners manual package.



Quote:
Originally Posted by soberbyker View Post
Anyone?
03-26-2014 05:46 AM
soberbyker
Quote:
Originally Posted by soberbyker View Post
~snip~

I made one mistake and thought I bricked it though, I had the ignition in ACC mode not ON (but not running), and after the GPS updates were done and the system rebooted I got a Enter your security code screen and couldn't do a thing not knowing the code. I couldn't even eject the CD.

So while surfing the web for a way to figure out my security code I found a thread elsewhere on this site with a similar topic and someone mentioned in the ACC mode the radio isn't able to read the VIN number of the Jeep and wouldn't be able to turn on. Turning the key one more notch to the ON/RUN spot, without firing up the motor, and I was able to eject the CD and everything was fine. WHEW!!!

~snip~

Another question, where can I figure out what the security code it was asking for is?
Anyone?
03-26-2014 04:44 AM
JoseRubicon
Quote:
Originally Posted by bouche03 View Post
Anyone have problems with their RBZ 430 not recognizing their iPhone via the USB port in the front of the head unit? It charges my phone but will not let me stream music while plugged in...HELP!
Try using a different cable. I've had that issue and it's usually the USB cable. Try using the cable that came with the phone.

Both ports (head unit and center console) can be used for both things. I also have an iPhone and I have noticed that if you don't use the right cable, the iPhone won't work. Most aftermarket cables give issues.

It works with my iPhone 5
03-25-2014 02:59 PM
JedFromAZ
Quote:
Originally Posted by misfit1981 View Post
What software version is in the picture? I updated mine to version 50, the background is black but the icons are all white, no color...doesn't look as sharp as my RAM (same year, same radio)...
Misfit1981,


The software version is 50.00.07. If you need any of the other numbers that might associate with the different icons feel free to ask and I'll take a look.
03-25-2014 01:48 PM
LewdDude
Quote:
Originally Posted by victor1955 View Post
The USB port on the front of the head unit is for charging or power only. The USB port in the console is the one to use for streaming music from and iPod or MP3 device. Of course you can also stream via bluetooth.

Uhm, I use the front USB on the head unit to stream and upload mp3 all the time...
03-24-2014 01:55 PM
soberbyker Did the update with the ISO provided by hgmeganet, thanks.

I have a 2013 Sahara, built in January of 2013 with the 430N RHB.

here are the before and after screen info:


BEFORE



AFTER



BEFORE



AFTER



I made one mistake and thought I bricked it though, I had the ignition in ACC mode not ON (but not running), and after the GPS updates were done and the system rebooted I got a Enter your security code screen and couldn't do a thing not knowing the code. I couldn't even eject the CD.

So while surfing the web for a way to figure out my security code I found a thread elsewhere on this site with a similar topic and someone mentioned in the ACC mode the radio isn't able to read the VIN number of the Jeep and wouldn't be able to turn on. Turning the key one more notch to the ON/RUN spot, without firing up the motor, and I was able to eject the CD and everything was fine. WHEW!!!

Looking at the shots above, most things seem to have been updated with a higher number, two exceptions. The GPS Audio number went backwards (and the voice person changed) and the AUDIO CPU number seems to have gone backward as well, from 100412 to 022113. Is the 022113 tied to the new Application number or did it in fact go backwards?

Another question, where can I figure out what the security code it was asking for is?
03-22-2014 10:13 PM
misfit1981
Quote:
Originally Posted by JedFromAZ View Post
Well I got my 430N replaced under warranty yesterday. Good news is that the maps and icons are more vivid. Bad news is that it came with the Jeep ghost image brand new from the factory. So much for Chrysler's QC. The stereo tech guy said that they should have a newer update disk in next week.
What software version is in the picture? I updated mine to version 50, the background is black but the icons are all white, no color...doesn't look as sharp as my RAM (same year, same radio)...
03-22-2014 09:04 PM
TylerRyan
Much appreciated!

Quote:
Originally Posted by xsdbs View Post
I got a reply back from a buddy about this TSB, If you'd rather have the dealer perform the update instead of doing it yourself, then you can tell them that you want:
TSB #08-061-13 performed, the TSB info is below if you'd like to check out,
Quote:
Originally Posted by hgmeganet View Post
Hey guys

I thought I could help out and share the August 2013 v50 upgrade for the 430N (RHB).

I received my disc in the mail last week and decided to make an ISO for the Jeep and Ram community.

You can download the file from this link
https://app.box.com/s/nrspftiq7dmgmegcsga0

I have a 2012 Ram Sport with the 430N and received the incorrect disc in the mail which downgraded my system from v43 to v33 with the ugly blue backgrounds. Many searches and calls to Uconnect later I got the disc and all is good!

Good luck!
Quote:
Originally Posted by hgmeganet View Post
No worries, glad it worked for you guys!

When I essentially downgraded myself to v33 I went to my local dealer to get v43 put back on, I was told they did not have ANY UConnect discs or upgrades and I would need to get it directly from UConnect. Sounded like BS but I got the same response from another dealer?

Whatever

Props to UConnect for supplying the disc AND acknowledging their mistake!

"Dear Valued Customer:

A few weeks ago you received a complimentary software upgrade for your 2012 UConnect 430 or 430N system. Unfortunately, the wrong disc was sent to you. We are sorry for the inconvenience this may have caused and have enclosed the correct disc with this mailing. As a next step:

1. Please discard and do not use the prior disc to perform the software upgrade.

2. If you have already completed the software upgrade with the prior disc, please perform the process afain with the enclosed updated disc and instructions. After completeing this upgrade you will notice:

- Improved radio graphics
- Improved connected device functionality
- Navigation feature improvements

if you have any questions, please contact us at 1-877-855-8400

Sincerely,

The Uconnect Team"
Quote:
Originally Posted by lasvegasguy12 View Post
Thanks hgmeganet. Your download worked flawlessly. I was able to go from 30.01.00 to 50.00.07

For anyone interested use the download link and burn to a CD-R not a DVD. Print out the service bulletin and follow it to a "t". Be patient! If you think it stopped working it hasn't just wait it out.
Quote:
Originally Posted by sr870 View Post

Thank y'all for all the help, especially with sharing the ISO. Much appreciated! Upgraded my 430N RHB Application Software from 33.01.23 to 50.00.07. This totally just made my day!
02-14-2014 07:31 AM
jkdave1 Does anyone have the 43.00.13 FW iso anywhere? I can't seem to find this update anywhere, been looking for a few days. To clarify i'm not looking for the 50.00.07, only the 43.00.13.
01-22-2014 10:29 AM
cent628 subscribed
01-10-2014 03:45 PM
BLK2012 Thanks for this update.....much easier on the eyes than the update I got that started this thread...
01-08-2014 11:17 PM
BubbaEinstein Any updates for the 730?
01-06-2014 04:13 PM
Rico1111 Just upgraded also ...following this thread..burnt the cdr and now I'm at 50.00.07
Thanks to all who posted and provided necessary materials.
01-02-2014 02:14 PM
Seaker Just finished upgrading my 1202 Jeep Wrangler 430n RHB radio from 33.00.41 to 50.00.07 using the ISO and PDF posted in this thread with zero problems. Made sure the key was in the ON position and was patient. Thanks everyone!!

12-22-2013 03:42 PM
krumby
question on upgrade

Can you do the upgrade on a flash drive or does it have to be burned to a cd?
I put it on a flashdrive and all it says is no files on usb when I put it in the jeep
Thanks
Dave
12-10-2013 06:29 PM
Mack207 So is there any way to change the "Yellow Theme" on the 50.00.07 to another color?
12-09-2013 11:24 PM
victor1955
Quote:
Originally Posted by Klschaefer View Post

This is actually why I didn't upgrade my radio. I just don't understand why they wouldn't make that USB port also play your phone or mp3 music through it.
Yep, I hear you man! Didn't make sense to me either.......
12-09-2013 09:27 PM
Klschaefer
Quote:
Originally Posted by victor1955 View Post
The USB port on the front of the head unit is for charging or power only. The USB port in the console is the one to use for streaming music from and iPod or MP3 device. Of course you can also stream via bluetooth.
This is actually why I didn't upgrade my radio. I just don't understand why they wouldn't make that USB port also play your phone or mp3 music through it.
12-08-2013 11:17 PM
victor1955
Quote:
Originally Posted by bouche03 View Post
Anyone have problems with their RBZ 430 not recognizing their iPhone via the USB port in the front of the head unit? It charges my phone but will not let me stream music while plugged in...HELP!
The USB port on the front of the head unit is for charging or power only. The USB port in the console is the one to use for streaming music from and iPod or MP3 device. Of course you can also stream via bluetooth.
12-08-2013 10:17 PM
bouche03 Anyone have problems with their RBZ 430 not recognizing their iPhone via the USB port in the front of the head unit? It charges my phone but will not let me stream music while plugged in...HELP!
11-05-2013 06:40 PM
JedFromAZ Well I got my 430N replaced under warranty yesterday. Good news is that the maps and icons are more vivid. Bad news is that it came with the Jeep ghost image brand new from the factory. So much for Chrysler's QC. The stereo tech guy said that they should have a newer update disk in next week.
10-13-2013 04:57 PM
bravens1
Quote:
Originally Posted by jjbroze View Post
For those of you with 430/430N radios with application version 23.04.41, who have been sitting on the fence concerning this update, do it.
After reading your post I burned a copy of the 50.00.07 iso (thanks "hgmeganet") and just updated my RBZ/430 radio (P05064879AH) today from version 23.04.41.....love the new colors!

10-13-2013 09:38 AM
bravens1 Subscribed
10-04-2013 10:46 AM
Navydave73 I just performed the update. Thanks to the member that reliables the download thread for the .iso file. I followed the PDF instructions exactly and it worked great. No update to the maps though. In fact my radio just hit me up to buy the new map package this morning. Thanks everyone for help and recommendations. I went from 30.xx to 50.00.07. Thanks again
10-03-2013 06:14 AM
lesgoff
Quote:
Originally Posted by sean.busse View Post
Hey guys, I think I really screwed up. I downloaded the update for the RHB for my father in law and the RBZ update for myself. In some sort of confusion I ran the wrong update in my RBZ and now my uconnect is stuck on the start screen no matter what I do...anybody have any ideas?

I had the same problem but my problem was because I had a mygig lockpick. I disconnected the lockpick and reconnected the radio to the stock wiring and it solved my problem. Once the radio restarted I was able to reconnect my lockpick.
10-02-2013 06:38 AM
xsdbs Have yo tried disconnecting the battery for about 20 minutes? This sometimes will let the radio reboot. If it's still under warranty, take it back to the dealer.


Quote:
Originally Posted by sean.busse View Post
Hey guys, I think I really screwed up. I downloaded the update for the RHB for my father in law and the RBZ update for myself. In some sort of confusion I ran the wrong update in my RBZ and now my uconnect is stuck on the start screen no matter what I do...anybody have any ideas?
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:16 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC