Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Help! 10A transmission...

Join Wrangler Forum Today


Thread: Help! 10A transmission... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-12-2013 05:35 PM
lovn95
Quote:
Originally Posted by Finn Sizzle View Post

What recall are you referring to? Link please. Thanks!
http://www-odi.nhtsa.dot.gov/acms/cs...3V234-6547.pdf
06-12-2013 05:29 PM
lovn95
Quote:
Originally Posted by Kiddmen57 View Post
Sounds rather familiar....at least you got some use out of the jeep prior to this occurrence. Mine let go less than 24 hours after delivery and less than 2 hours with me behind the wheel. 43 miles on the ODO.

http://www.wranglerforum.com/f33/les...er-234669.html

they gave me the same story, attached tube, filled her up and sent me on my way. Then it started shifting weird. Now its at the dealer again today for the 3rd time to see what the next repair to the tranny is. I'm STILL trying to get a new tranny put in...no luck yet.

http://www.wranglerforum.com/f33/13-...er-240741.html



BTW - this was all that was left after a mile long trail on my way home. Still can see the huge slick where it let go as a reminder every time I drive home. It's been 2 months and still highly visible in the street.
Even though it was a different problem, this person got a new transmission out of Chrysler...

http://www.wranglerforum.com/f33/201...ml#post3731139
06-12-2013 05:02 PM
Finn Sizzle
Quote:
Originally Posted by J33P4M3 View Post
I'm assuming you read the thread on the transmission recall affecting your vehicle (and mine). I have the same ride as you and am thinking about being proactive and scheduling the repair instead of waiting on Chrysler to "contact" me
What recall are you referring to? Link please. Thanks!
06-12-2013 04:55 PM
lovn95
Quote:
Originally Posted by J33P4M3 View Post
I'm assuming you read the thread on the transmission recall affecting your vehicle (and mine). I have the same ride as you and am thinking about being proactive and scheduling the repair instead of waiting on Chrysler to "contact" me
I told my dealer about the recall (they didn't know). They said that wasn't the cause of the problem and that they can't do anything with the recall problem until the recall is officially issued.
06-12-2013 04:27 PM
Kiddmen57
Quote:
Originally Posted by J33P4M3 View Post
I'm assuming you read the thread on the transmission recall affecting your vehicle (and mine). I have the same ride as you and am thinking about being proactive and scheduling the repair instead of waiting on Chrysler to "contact" me
Different issue. The recall is regarding the transmission cooler line contacting the power steering line and rubbing through. If your was built after February 2013 like mine, it's already taken care of.

Crouch down and look at the front of the wheel well on front driver side. You'll see two hard lines connecting to a cooler. The lower one should have a black sleeve on it (like in the pic, but the upper line should still be connected ). Follow the lower line back just a bit towards the rear. there will be another line with a foam sleeve that crosses close to it. If you've got the black plastic sleeve as seen in my pic on the lower tranny cooler line, and the foam sleeve on the PS line, then you're OK.

06-12-2013 04:22 PM
Kiddmen57 Sounds rather familiar....at least you got some use out of the jeep prior to this occurrence. Mine let go less than 24 hours after delivery and less than 2 hours with me behind the wheel. 43 miles on the ODO.

http://www.wranglerforum.com/f33/les...er-234669.html

they gave me the same story, attached tube, filled her up and sent me on my way. Then it started shifting weird. Now its at the dealer again today for the 3rd time to see what the next repair to the tranny is. I'm STILL trying to get a new tranny put in...no luck yet.

http://www.wranglerforum.com/f33/13-...er-240741.html



BTW - this was all that was left after a mile long trail on my way home. Still can see the huge slick where it let go as a reminder every time I drive home. It's been 2 months and still highly visible in the street.
06-12-2013 04:18 PM
J33P4M3 I'm assuming you read the thread on the transmission recall affecting your vehicle (and mine). I have the same ride as you and am thinking about being proactive and scheduling the repair instead of waiting on Chrysler to "contact" me
06-12-2013 04:09 PM
legitposter demand new tranny. you won't get it though.
06-12-2013 04:05 PM
TOK This exact same thing happened to someone else here a month or so ago... I don't remember the user name, hopefully he see's it.
06-12-2013 03:08 PM
lovn95
Help! 10A transmission...

The other day I was driving my automatic JKR 10A (with only 900 miles on it) in a bad thunderstorm, and I kept thinking it was acting kind of funny (shifting strangely, RPM's too high). When I got to my destination (25 miles/45 minutes), I parked it. 7 hours later I came out to a huge puddle of pink/red fluid under my Jeep. I had it towed to my dealer.

According to my dealer, a hose came loose that caused my Jeep to quickly lose pretty much all of its transmission fluid. They say they have reattached the hose and refilled the fluid and it's ready to be picked up.

Should I pick it up and hope for the best...or demand a new transmission? Help!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:23 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC