Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > squeaky Clutch new to form

Join Wrangler Forum Today


Thread: squeaky Clutch new to form Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-13-2013 06:32 AM
Willshire
Quote:
Originally Posted by RB-10rubicon View Post
same as mine sometimes i hear it if i dont have the radio on
Ya I usually just turn up the tunes now.
06-13-2013 06:29 AM
RB-10rubicon
Quote:
Originally Posted by willshire View Post
the dealer has replaced the slave cylinder on mine worked for about a month then it came back. Glad to know i'm not the only one with this issue.
same as mine sometimes i hear it if i dont have the radio on
06-12-2013 11:15 PM
Willshire
Quote:
Originally Posted by Greg__Berger View Post
The dealership drove mine today and drove two brand new ones off the lot. Said they all did it and it was normal. I said we'll it may be normal, but that doesn't make it right - it sounds like a clunker! Looked at the notes from the mechanic and although he stated that it was operating as it should, he did lube the clutch spring. Didn't hear the noise on the way home. We'll see how it pans out.
Hope that works for it maybe that's all it needs. I come to live with it but still annoying as hell.
06-12-2013 09:21 PM
Greg__Berger The dealership drove mine today and drove two brand new ones off the lot. Said they all did it and it was normal. I said we'll it may be normal, but that doesn't make it right - it sounds like a clunker! Looked at the notes from the mechanic and although he stated that it was operating as it should, he did lube the clutch spring. Didn't hear the noise on the way home. We'll see how it pans out.
06-12-2013 07:19 PM
Willshire
Quote:
Originally Posted by jaxs1984 View Post

I have an 09 and took it to dealer, they too replace the slave cylinder. It's been about a month and so far so good. If it squeaks I'll take it right back since I paid about 275. for the parts/labor.
Ya I have taken it back couple of time and say normal ware and tear but it shouldn't be doing that. And now mine is not under Warrinty so will wait to the clutch stops working and replace everything.
06-12-2013 07:17 PM
jaxs1984
Quote:
Originally Posted by Willshire View Post
The dealer has replaced the slave cylinder on mine worked for about a month then it came back. Glad to know I'm not the only one with this issue.
I have an 09 and took it to dealer, they too replace the slave cylinder. It's been about a month and so far so good. If it squeaks I'll take it right back since I paid about 275. for the parts/labor.
06-12-2013 07:04 PM
Willshire The dealer has replaced the slave cylinder on mine worked for about a month then it came back. Glad to know I'm not the only one with this issue.
06-12-2013 10:38 AM
Greg__Berger Mine does this as well. Only after it's been driven a little while and then it's consistent. Funny thing is that I only hear it from the outside, but I'll tell you - when the windows or open, or top and doors off - it's embarrassing. It sounds like I'm driving a beater to hear it "squeeeeekk" every time I press and release the clutch. I'm headed into the stealership this afternoon to see if I can get them to do something about it.
06-12-2013 10:10 AM
jiminmanjr My 2003 Wrangler has started doing this as well. Any time I press the clutch to the floor, there is a creaky-squeak. It does not squeak when I release the pedal. It is constant... and getting frustrating.

Long trips, short trips, slow or fast, it is there.

Any suggestions?
05-27-2013 10:18 PM
Willshire no its a continuos thing as soon as the jeep gets warm and its stays there until i let the jeep cool down for a couple of hours. then starts again when i drive for 20 mins
05-27-2013 10:13 PM
jkjeeper06 Mine chirps sometimes when I let the clutch out? Is that what you're talking about? Or is it a prolonged squeal?
05-27-2013 10:01 PM
Willshire
squeaky Clutch new to form

Hi new to the form have a question 09 jeep jk 6 speed and after driving for 20 minutes to half when i depress the clutch it makes an awfull squeak noise. Only does it after i have driving it. Have taken into dealer when it was under warranty and the said it was normal wear and tear on the clutch was wondering if anyone has experienced this as well

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:51 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC