Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Wiper problems?

Join Wrangler Forum Today


Thread: Wiper problems? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
01-31-2014 08:02 AM
Jeeper9912 last year i had to get a new wiper motor, put it in about march? this morning (0degrees) The wipers worked once, then once the defroster kicked in, the wipers stopped working. Wasn't able to check the fuses, but any help?
06-17-2013 01:19 AM
InvisiblePants
Quote:
Originally Posted by CommissionerGordon View Post
I have a '98 Wrangler so there's only a setting for low and high. So I don't know if there's even a multi-switch.
My 97 had the same switch with just Hi/low. I swapped it out with an one from a neon that had delay/Low/high. pulled it from a pick a part scrap yard, cost about $12 and took 10 mins to change out.
06-16-2013 01:57 AM
CommissionerGordon
Quote:
Originally Posted by RevCo666 View Post
I've had some good luck with rockauto.com, here's a discount code too that saves ya 5%(better then nothing) and there pretty much the cheapest companies out there (tho it costs me an arm and a leg for shipping since I live far up north in Canada.) Just make sure to follow what make/model/year of your jeep when searching for parts that way you don't order the wrong one. 1509819412371497 Using Your Discount Code Enter the code above in the "How did you hear about us" line of the shopping cart. If you are using our traditional HTML catalog, please click the "Apply" button to the right of the field. Your discount will automatically appear, subtracted from your parts order total. Orders using discount codes must be placed online. Phone orders are not eligible for discounts. PS its good till July 21/2013 and I just got my first jeep last summer so were all new
Thanks a bunch!! I just ordered a new one!!
06-15-2013 07:57 PM
Jeepfixer1 My experience is that is usually in the timer part of the motor assembly. Try turning them on low then tapping the motor with a hammer also wiggle the plug ins. If it starts working when doing this then replace the motor otherwise you'll have to check the wires with a schematic to be sure.
06-15-2013 07:52 PM
RevCo666
Quote:
Originally Posted by CommissionerGordon View Post
Where could I pick up a replacement one like this??

Thanks for all your help, I'm new to the Jeep world.
I've had some good luck with rockauto.com, here's a discount code too that saves ya 5%(better then nothing) and there pretty much the cheapest companies out there (tho it costs me an arm and a leg for shipping since I live far up north in Canada.) Just make sure to follow what make/model/year of your jeep when searching for parts that way you don't order the wrong one.

1509819412371497

Using Your Discount Code

Enter the code above in the "How did you hear about us" line of the shopping cart. If you are using our traditional HTML catalog, please click the "Apply" button to the right of the field. Your discount will automatically appear, subtracted from your parts order total. Orders using discount codes must be placed online. Phone orders are not eligible for discounts.

PS its good till July 21/2013 and I just got my first jeep last summer so were all new
06-15-2013 04:27 PM
CommissionerGordon
Quote:
Originally Posted by RevCo666 View Post
I meant the signal switch(some call it a multi-switch), thats where your high/low setting is located on your jeep right?
Where could I pick up a replacement one like this??

Thanks for all your help, I'm new to the Jeep world.
06-15-2013 01:22 AM
Wesboy CommissionerGordons wiper control would look like this.

Attachment 261623

I agree with Revco666, the controller needs to replaced.
The really good news is you can replace your old controller with with an intermittent controller like the one in Revco666s post - it will plug straight in to existing connections
06-14-2013 11:23 PM
RevCo666
Quote:
Originally Posted by CommissionerGordon View Post
I have a '98 Wrangler so there's only a setting for low and high. So I don't know if there's even a multi-switch.
I meant the signal switch(some call it a multi-switch), thats where your high/low setting is located on your jeep right?
06-14-2013 11:17 PM
CommissionerGordon
Quote:
Originally Posted by RevCo666 View Post

Maybe there's a problem with your multi-switch?
I have a '98 Wrangler so there's only a setting for low and high. So I don't know if there's even a multi-switch.
06-14-2013 10:09 PM
RevCo666
Quote:
Originally Posted by CommissionerGordon View Post
Hi,

Does anyone know why my windshield wipers would work only on high mode but won't work when they're on the low setting??
Maybe there's a problem with your multi-switch?
06-14-2013 09:59 PM
CommissionerGordon
Wiper problems?

Hi,

Does anyone know why my windshield wipers would work only on high mode but won't work when they're on the low setting??

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:08 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC