Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > clutch issues

Join Wrangler Forum Today


Thread: clutch issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-18-2013 03:19 PM
mwx Sure sounds to me like a blown Slave - or line leading to it.

If the master bled completely dry then you're going to have a hard time getting it to pressurize without bench-bleeding it.
06-18-2013 03:17 PM
NattyP gonna bump this just once
06-17-2013 08:38 PM
NattyP
clutch issues

Hey, 1989 Wrangler YJ, 5-speed, 2.5L.

Pulling into my work parking lot this morning, my clutch started acting funny. The pedal went all the way to the floor, without much resistance, until it got to the last few inches, where it didnt wanna come back up.

It did that a couple times, I tried shifting into higher gears and they kinda slammed into gear, like I was shifting without the clutch. After that, I had nothing, no pressure behind the pedal.

I checked for leaks and saw the bellhousing was wet on the bottom, and my master cylinder was empty.

Here's the weird part though. I took a friend's car to the local gas station, bought some brake fluid and filled it. Then had him help me bleed the clutch.

It built up no pressure, and didnt seem to be forcing it out very forcefully. But even with pressing the pedal in a million times, the level didnt drop much at all. and there were bubbles coming up in the master cylinder.

It can't be a leak then can it? Wouldnt the level drop when I pressed on the clutch pedal? all the fluid just stays in there.

I have been having issues with needing to add fluid and bleed the clutch about once every two weeks. I tried replacing the master cylinder and that didnt do anything.

the slave cylinder and lines are all about a a year and a half old. :/

Thanks for any help.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:25 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC