Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Yj starts then dies out

Join Wrangler Forum Today


Thread: Yj starts then dies out Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-10-2013 08:08 PM
MightBeDJ turns out it was the fuel pump
08-09-2013 12:53 PM
MightBeDJ ]so with the 02 sensor on it ran a lot better takes off better and everything untill i try full throttle and then itll spit itll sputter and missfire or backfire i just got a iac (tps? ) and the screw thats on it is fully extended am i supposed to adjust this thing?

i also picked up a fuel pump for justin case
08-05-2013 05:10 PM
MightBeDJ well it took this long but turns out i had an exhaust manifold leak and two broken studs as icing on the cake my local junkyard drilled out those put a manifold on and welded my front shackle mount back on for 200$ not bad if you ask me.
drove it around and she was still stumbling backfiring and and not wanting to accelerate they scanned it for me, turned out to be the o2 sensor wasnt reading, i couldnt find out of the 2.5 cherokee they had their so i bit the bullet paid 46$ at advanced and itll be in tomorrow ill update then.
and all this time i didnt think you could scan the these because they dont have a CEL lol my bad

@sevenservices i just wanted to thank you seemed like you took part in all the threads i made, you're good help thanks
06-30-2013 08:20 AM
JaimeJ After few miles, all electronics & motor stops instantly. After restart - the engine stops sooner and more frequently. Mechanic said Clutch sensor, It checked out - OK. Rotor and cap replaced - not it. Replaced computer, also not the problem.
What else?
06-19-2013 03:00 PM
MightBeDJ i took the injector off blasted it with carb cleaner then checked my fuel filter was a real nice dark looking color, so i blasted carb cleaner down through the inlet of the filter untill it came out crystal clear through it back and voila she runs and idles now i just got to find out where all this oil is coming from
i sold it to a friend who said they were going to fix her but he never did and just ended up letting her sit for over six months and he gave it back it back to me for free so its pretty sweet to get her running
06-19-2013 10:41 AM
anotheridiot think thats an injected motor so the fuel injectors would be where to look. I dont know how often it happens on fuel injected jeeps, but GM motors are notorious for doing this when the cooling sensor goes bad since the temp of the antifreeze changes the fuel pressure and mixture, so if it is not getting a reading then its fat or lean because of it.

not saying its a fix or if yours even has a temp sensor, but when you did as much as you have done, its time to check some odd ball things.
06-19-2013 08:56 AM
sevenservices did it ever run good?

If it ran good then started doing this all of a sudden, and you've replaced the fuel filter, it might be time for a rebuild of the carb.
06-19-2013 08:06 AM
MightBeDJ
Yj starts then dies out

1987
2.5

what ive already done and checked.
sparkplugs : replaced
cap: replaced
rotor.: Replaced
idle control motor : replaced
fuel pump. checked ( is not even a year old)
didn't check the filter its the same age as the pump
also checked the gas and its fine

now what its doing is that when i turn the key to on, my buddy says that its supposed to spit some fuel on the butterfly but he says it isnt, but when i start the jeep itll run but will act like its "getting choked out" (run up to about 3000 rpms then drop down to nothing and stall) unless i feather the throttle then it will stay running. when putting a constant stream of carb cleaner in the tb and it idled perfect. the engine didnt make any noises. couldnt see or hear any vacuum leaks
so this would be a fuel issue? do i have to adjust that idle control motor differently?
i'm headed down to the shop now to pull off the tb and clean it and see if its the injector gunked up.

thanks in advance

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC