Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Team Rush gone south. Help needed

Join Wrangler Forum Today


Thread: Team Rush gone south. Help needed Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-21-2013 03:48 PM
indirocz28 Get a gallon of carb cleaner to soak it in when you take it apart.

You may want to replace the choke, the choke pull off vacuum diaphragm, and the throttle up motor that idles up the carb when you turn on the a/c (if you have ac)

I got lucky and I just cleaned some of the crud off the choke and pull off and they work perfectly fine.

I would say that's rare though for something that's been sitting in the junk yard for lord knows how long and is already almost 30yrs old.
06-21-2013 01:16 PM
Cashcrazy Am I missing any parts required from this list:

1. Carb $50
2. Rebuild kit $40
3. Adapter plate $18

I already have cleaner, air filter and scraps to make linkage.
06-21-2013 08:51 AM
indirocz28 Every once in a while it will pop/ cough, but I can feel it miss in the ignition system. A 23 yr old coil and dizzy can't be as good as it once was.. It runs 100x better than it did with the carter. I have no complaints about my 2150.

Either spend the $50, and after you rebuild it you'll have $200 in putting it on, or buy the one off of eBay brand new for $300, then you will have $360-370 in putting it on..

Its up to you on how to go, but do the swap regardless. You will be happier.
I can't complain about the 2150 so far.
06-21-2013 08:20 AM
Cashcrazy Do you still have the idle cough or was that corrected with the 2150? I found a 1.08 for $50 that is two hours from me. I haven't decided if its worth the drive and time.
06-21-2013 06:44 AM
indirocz28 I am all for the MC2100/2150 swap.

Most of the time it starts the first time I turn the key. Occasionally I have to crank it twice, but it is still carbureted. I love my 2150 though.
06-20-2013 09:13 PM
Cashcrazy Update: I had some time to mess with the carb to tonight. I replaced a couple vacuum lines that looked questionable, but no change in idle. I checked the idle jets and they have no drip. Finally I sprayed the base of the carb with cleaner while it was running and the RPM's started to increase. I tightened up everything for the carb and sprayed again and the RPM's remained constant. It will die in reverse and at a stop if I don't watch the RPM guage, but it wouldn't even run when I started so there has been improvement.

I had originally said I was going to keep the jeep stock since the entire jeep had been kept in stock condition and well maintained since 1989, but I am getting real tired of fighting the Carter symptoms and thinking about the 2100/2150 swap. I have never heard anyone say they didnt like the results of the swap. I want to increase the dependability and as of now I am searching for a 2100/2150 to rebuild.
06-20-2013 04:26 AM
indirocz28 I paid $20 for the carb at the JY. I found it on a 1981 mercury cougar with a 4.2L v8.

And i would spray it into the bottom vent. I do not know if it matters, but I sprayed my top one and then thats when I noticed gas leaking from the throttle shaft (as seen in video).
06-19-2013 11:27 PM
Cashcrazy I just responded to your thread. I ran out of daylight so I will try the rag method tomorrow. What did that salvage yard charge for carbs in your area?

Also, which bowl vent did you spray into? I believe there are two. One on the top connected to the white plastic piece and one a little below that.
06-19-2013 11:04 PM
indirocz28 There are some on You tube. Did you try the rag method though? also did you try spraying the carb cleaner into the fuel bowl vent ports?

This is how I found MY issue :/

https://www.youtube.com/watch?v=p5dJTcDAUy0
06-19-2013 10:02 PM
Cashcrazy You guys were right. This is a carb issue. I should have known with the number of coincidences I have had with this jeep. I guess the carb picked up some trash the last time I drove it and it happened to be the same time I did all the ignition maintenance. I worked the carb over with some carb cleaner and have it idling somewhat again. It will still die at a stop if i dont watch the RPM's. I believe the idle jets need a serious cleaning. Has anyone stumbled across a pictorial or video for cleaning the carter? I would really like to see the Venturi cluster removal so I know what to expect. Thanks again for all the responses.
06-19-2013 01:16 PM
bc3_Jeep HOLD ON TO THE RAG...........so it does not suck it into the intake...........

Just because you had the carb rebuilt, does NOT mean it is not the carb.....oodles of things can go bad with a carb just USING it...... bad gas, crap loose in the lines, float develops a leak, needle valve decomposition, passageway obstruction..... and on... and on... and on.....
06-19-2013 08:03 AM
Cashcrazy No nutter bypass, it is all stock. I can tell the coil has been replaced but I do not know when. I will also try the rag trick tonight. Right now I just need to get it running again. I may do the motorcraft 2150 in 3-4 months. I just sank about $500 into it so ill have to wait a bit before another big purchase.
06-19-2013 07:58 AM
Cashcrazy It's trying to idle about 600-700 RPM. It has the CArter carb rebuilt in 2012. I did not mess with the carb at all during the swap. It was idling a little rough before the team rush but no where near this bad.

I looked for vacuum lines that may have been knocked off and I didnt see any. I try the carb cleaner and see what happens with that.
06-19-2013 07:36 AM
indirocz28 Have you done the Nutter Bypass?

Did you make sure you adjusted your timing correctly, without the vacuum advance?

You should change your coil to something new as well. Those old coils tend to get weak over the years and shaken about which loosens the windings inside.


Putting an MC 2150 on my 4.2L solved almost all of its issues. Every once in a while it will miss, but for now, I can deal with that. It idles smooth as ever and the performance is great. Just putting it on gained me 5mpg over the Carter BBD.
I haven't re-tuned the carb yet either. Just re-built it, and put it back together.

I agree with BC3- go ahead and check for vacuum leaks.
Also,get a couple of clean rags, take off your air cleaner, with it running and idling the best you can get it, hold the rags over the intake of the carb so that it nearly kills the engine, then take them off and let it rev back to idle on its own. After that, do the same process a couple more times. It may die the first few times.

This is a red neck way to help suck any crap out of the idle tubes and passageways inside.
06-19-2013 01:22 AM
bc3_Jeep What is it TRYING to idle at???? have you tried adjusting THAT speed up???

If it is idling smooth with the choke ON..... then I would have to assume there is a fuel issue, or maybe a vacuum leak..... try the old carb cleaner spray around the intake and see if it smooths out or revs up...... for vacuum leaks.

you say OLD 4.2...... BUT is it a carb model or a TBI???? Carbs can be VERY tricky if you have never messed about with them. IF carb, I would suggest doing a rebuild and pay close attention to the float setting, jet clogging, passage clogging.....which can cause this kind of issue, as well.

If TBI, you MAY be looking at a clogged injector or some OTHER fuel delivery issue.
06-18-2013 11:08 PM
Cashcrazy
Team Rush gone south. Help needed

I just did the Team Rush upgrade on the old 4.2 and it made things much worse. I changed the cap, rotor, added the adapter, new plugs, and MSD wires. I used the stock coil and gapped the plugs to the factory 35. When I first started it the electric choke took it to about 1200 RPM and it was running as smooth as ever. Then I guess it kicked off and wouldn't idle. I kept it running to warm up some and it eventually would idle on its own. It feels like all cylinders are firing but it has a miss. At times it's almost like the computer is keeping from a smooth idle. Any help to get this going is very appreciated. I have been trying to get a smooth running Jeep since I bought it and I am about ready to throw in the towel.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 11:59 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC