Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > General Jeep Discussions > Communications and Electronics > Automatic Shutdown Relay Fuse Issues

Join Wrangler Forum Today


Thread: Automatic Shutdown Relay Fuse Issues Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-27-2013 10:47 PM
JasenBragg
Automatic Shutdown Relay Fuse Issues

Well. I have a 2012 Wrangler Sahara 4dr and this past week I had to tow my jeep into a dealership in Texarkana. I was driving 45 mph and not trying to gun the rpms. I had total shutdown but was able to get off the road. The dealership hooked it up and told me that my ASD 25 amp fuse had blown but couldn't figure out why. My jeep ran okay for much of the day but by night it blew another fuse as I accelerated from a green light. I replaced it with a 30 amp fuse but fear that is too much for a burn out but i wanted to make sure i got home. I drove back home (an hour drive up and down hills) and it seemed to always want to ramp up the RPMs suddenly. I would love to know if anyone else has had this kinda issue? I have less than 20,000 miles on my jeep.

I have now had three fuses blow and two tows to dealerships because i couldnt keep a good fuse. I hope someone can please help me point out the direction the dealership needs to be looking for. This is getting frustrating. It seems to blow a fuse when I hit any type of bump in the road. No electrical mods were made except my warm winch which was installed at the dealership.

JasenBragg@gmail.com

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC