Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Intake help!

Join Wrangler Forum Today


Thread: Intake help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
06-28-2013 09:20 PM
Vstrefling Thank you for your response!
06-28-2013 07:01 AM
roadyrob its the manifold heater. if you disconnect it your jeep may run alittle rough until warm in cold weather. its really not needed, my offenhauser manifold doesn't have it.
the only things on my intake are the water inlet and outlet, vacuum for the brake booster, and vacuum on the rear of the manifold for the heater. if you run the cto valve you will need that too.
06-27-2013 09:46 PM
Vstrefling
Intake help!

I just got feed up with the original carb and went with a new Weber. Every time I thought it was running good just give a day or two and the rough idle to no idle, rough start... Freaking just had enough. In the process of taking carb off I decided to put a aluminum head cover on and get the intake and exhaust manifolds sandblasted. My question is when I put everything back together tomorrow what do I need put back on the intake? I've done a nutter and just want to clean things up a bit! There was a lot of sensors that didn't have anything running to them. Plus there was a red wire cut off coming from the bottom of the intake. It goes into where the center piece with the cones shape things are... Sorry that's the best way I could describe it.

Any help would be appreciated I just want to do the jeep thing this weekend!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC