Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > distributor probs

Join Wrangler Forum Today


Thread: distributor probs Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-02-2013 10:41 AM
AllMudd I would say start with charging your battery. You might have drained it to much to actually accept the voltage draw from cranking it so much. Charge it recheck plug wires ensure everything is tight. Then borrow a timing light from your local auto parts store and five it a go!
07-02-2013 10:24 AM
aaron.ochoa1 my first issues was the jeep cranking but not firing. I took apart my hei distributor down to the rotor put it back and now all im getting is a clicking, constant...at first for a quick second it sounds like it wants to crank but goes into a constant clicking. putting back the distributor cap I put my wires back to 1,5,3,6,2,4. but yes I will try to figure out if my coil is actually getting any juice as I had failed to do that. and might need to replace or charge the battery. thank you for the advice
07-02-2013 08:19 AM
AllMudd You also said that it cranks but then goes to a clicking sound? This sounds to me like a dead battery or bad starter. Not really related to the distributor at all IMO. Please explain your original issue and sounds that occur when you do something ex. Turn the key.
07-02-2013 07:28 AM
harleydragon
Quote:
Originally Posted by aaron.ochoa1 View Post
So my 88 yj isn't starting and have diagnosed it to the distributor. I replaced my rotor, cap and coil in my hei distributor because im not getting any power from my coil and the cap and rotor just needed to be replaced. in doing this I am still getting the same results...it will sound like it wants to crank but goes to a clicking sound. do I need to adjust my timing from replacing those parts? what else could it be?
your timing should not have changed unless you loosened the distributor and turned it..make sure that you have power coming to your coil and make sure that the mechanical advance inside the distributor is working..I am assuming that when you replaced the cap that you got the plug wires back in their proper locations
07-02-2013 01:18 AM
aaron.ochoa1
distributor probs

So my 88 yj isn't starting and have diagnosed it to the distributor. I replaced my rotor, cap and coil in my hei distributor because im not getting any power from my coil and the cap and rotor just needed to be replaced. in doing this I am still getting the same results...it will sound like it wants to crank but goes to a clicking sound. do I need to adjust my timing from replacing those parts? what else could it be?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC