Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Check Engine light question

Join Wrangler Forum Today


Thread: Check Engine light question Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-03-2013 10:26 AM
jokerchief462 The Maintenance Required light was an emissions timer to remind folks to replace the O2 sensor at 82500K and it just needs to stay removed as useless as the shift light.
07-02-2013 06:32 PM
Milkman I just got my TJ inspected and my bulb was blown which failed my inspection. Mechanic was able to remove dash and replace bulb on mine. Every time I start it up it shows for a couple of seconds now.
07-02-2013 06:29 PM
Garyk The light should come on when you first start up and then go off after a few seconds
07-02-2013 03:52 PM
Michigan jeeper Turn it from off position to on position 3 times then leave it in on position and it should flash a code
07-02-2013 03:49 PM
TipperD
Check Engine light question

How do you know it is working or not?....does it normally come on with the first key position and then go off?....have yet to see mine...the bulb is in place, have not tested the bulb however. I see there is a maintenance required position as well in the panel without a bulb behind it. Trying to get all the stuff from the PO straight.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:26 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC