Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Urgent help needed

Join Wrangler Forum Today


Thread: Urgent help needed Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-20-2013 08:15 PM
Sahara1995 Excellent!
07-20-2013 11:42 AM
wasomma sweet dude glad it worked out for you
07-20-2013 09:43 AM
Megamonster Good News everyone:

Finally received all the parts and finished installing them. Test drive went ok. I will be mall crawling all next week to make sure issue was resolved. Now i'm just enjoying that brand new exhaust smell.

Thank you all.
07-07-2013 06:13 PM
Megamonster Bought a cat back since the wife approved it. Not a Borla but looks good enough for me.
07-07-2013 06:05 PM
wasomma i would just get a cat back system as well, I went Borla and I loved it
07-07-2013 05:43 PM
Megamonster
Quote:
Originally Posted by Sahara1995 View Post
Heat the hell out of it. Preferably with and oxygen and acetylene torch. If you don't have that which I, guessing you don't you can try a map gas torch it burns hotter than a propane torch. You can get me Home Depot. If you can get real hot you can hammer it right out.
That is a great idea. Fortunately my wife just suggested that I change the rest of the exhaust since it is only a matter of time that I will have to buy a new muffler. It is stock.

I'll keep trying to take it apart without resorting to cutting it out until the new parts arrive
07-07-2013 05:28 PM
Sahara1995 Heat the hell out of it. Preferably with and oxygen and acetylene torch. If you don't have that which I, guessing you don't you can try a map gas torch it burns hotter than a propane torch. You can get me Home Depot. If you can get real hot you can hammer it right out.
07-07-2013 02:23 PM
Megamonster
Quote:
Originally Posted by wasomma View Post
check your muffler, when my cat went the pieces fouled the muffler as well.

It depends if the cat is stock, but either way you should not have to remove the TC skid place to get it out
I got it to wiggle but the muffler still not letting go of the cat even with a pry bar and a hammer

I am going to soak the cat in liquid wrench and I will give it another try tomorrow.
07-07-2013 01:51 PM
wasomma check your muffler, when my cat went the pieces fouled the muffler as well.

It depends if the cat is stock, but either way you should not have to remove the TC skid place to get it out
07-07-2013 01:10 PM
Megamonster I am in the process of taking the cat completely out since the new one should be here tomorrow. I remove the clamps that connect the cat to the muffler but the cat does not want to let go of the muffler. It is welded inside? Do i need to remove the TC skid plate to get the cat completely out?

Thanks.
07-01-2013 07:42 PM
Sahara1995 If the O2 you replaced was bad that could be what caused the cat to go. Can cause the cat to run hot n melt down causing the clog that left you high n dry
07-01-2013 11:19 AM
Megamonster Update:

I went to get the Jeep today at the city that it left me stranded in. I did not wanted to take any chances with it so I took the cat out and drove back home loud and slow. Made it home without incident. A new kitty is on the way should be here by Friday.

Is there any other things that I should check while is apart? Thanks for the help.
06-29-2013 05:51 PM
AllMudd
Quote:
Originally Posted by maverick1979 View Post
sounds like a cat to me too
x2
06-29-2013 04:18 PM
maverick1979 Sounds like a cat to me too
06-29-2013 04:15 PM
Megamonster
Quote:
Originally Posted by Sahara1995 View Post
I had a similar problem with a dodge ram truck, it ended up being an O2 sensor. My cats actually glowed red so I thought it was the cats but it was an O2.
I replaced the o2 sensor recently and it ran fine until now. It was a spectra Premium brand.
06-29-2013 03:18 PM
Sahara1995 I had a similar problem with a dodge ram truck, it ended up being an O2 sensor. My cats actually glowed red so I thought it was the cats but it was an O2.
06-29-2013 01:51 PM
Megamonster
Quote:
Originally Posted by AllMudd View Post
The prop prop noise is it happen while downshifting? And how is the power while driving? If your cat is bad you will notice almost no power while you try to accelerate.
After the pop noise, which sounded like a .22, I could only accelerate for about ten seconds then it lost power and shut down. I did notice that the rpm stayed the same, for a few seconds, while the engine lost power.

My guess is that the cat is plugged and after continuous use in the highway, the pressure increases? Is this possible?

Thanks.
06-29-2013 01:28 PM
AllMudd The prop prop noise is it happen while downshifting? And how is the power while driving? If your cat is bad you will notice almost no power while you try to accelerate.
06-29-2013 01:00 PM
Megamonster Any other ideas?
06-29-2013 07:47 AM
Megamonster No. Every thing looks normal. After the tow ( of course) it started back up. But now it makes a prop prop sound when it revs down. So I'm thinking the cat might have gone bad. Any other areas that I can check? It left me stranded away from home.
06-29-2013 06:32 AM
DirtyRob Is there any oil on the ground under the engine?
06-29-2013 05:07 AM
Megamonster
Urgent help needed

My YJ 91 2.5L died after it started to lose power and a loud pop that seemed to come from under the jeep. Now it does not start. Any idea what could be the reason? Thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:25 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC