Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > jeep losing power and backfiring intake side

Join Wrangler Forum Today


Thread: jeep losing power and backfiring intake side Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-07-2013 10:57 PM
AllMudd Could be a couple things. I would start with the heap stuff. Clean all contacts and rotor on he distributor cap. Also pull all your plugs and make sure they have strong spark and are free of debris. Then if you still have the problem with the 52 code try replacing your O2 sensor it may be throwing your ECM for a loop while its running.
07-07-2013 10:46 PM
Michigan jeeper Fuel pump? Something to do with fuel delivery would be my guess
07-07-2013 10:44 PM
highjumper2009 code 12,33,52,55 code 33 ac relay no ac code 52 rich ,
07-07-2013 10:26 PM
AllMudd
Quote:
Originally Posted by jfbilbro View Post
crank position sensor
I would think this would make it not start. He is having trouble with it running with loss of power.
07-07-2013 09:34 PM
jfbilbro crank position sensor
07-07-2013 08:20 PM
AllMudd Have you pulled the codes to see what it's throwing? Is the Check Engine light on?
07-07-2013 08:05 PM
highjumper2009 1991 2.5 4cyl
07-07-2013 02:44 PM
AllMudd Year and engine?
07-07-2013 02:31 PM
highjumper2009
jeep losing power and backfiring intake side

jeep starts fine drive for about 5 min and loses power and starts to back fire thru intake for about 1 min and then run ok , some time it will idle a little rough but will not stall and then starts idling ok again have check fuel pump 32pound and 39 pounds with vacum line unhooked replace about a year ago replace cat and muffler about 3 week ago o-2 4 week ago and water temp this week I first thought I had water in gas have added additive to fuel running out of idea any idea would help thanks

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 07:37 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC