Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > ESC light

Join Wrangler Forum Today


Thread: ESC light Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-21-2013 11:24 AM
michiganadam ESC sounds like a useless piece of crap after some of these posts
08-19-2013 09:21 PM
Ricky Dog My case was a broken or shorted wire in the powertrain wiring harness. Dealer installed a new PCM which blew out, then a new harness with another new Powertrain Control Module.
08-19-2013 04:06 PM
MRT2 Had one wheel that was >10PSI over the other wheels. Aired that one down to match, and the ESC light went off. Weird thing was that it was >10PSI for a few weeks now, and it the ESC malfunction came on today of all days? Lets hope airing down the tire keeps it off.
07-11-2013 08:25 PM
BacaraJKU I was aired down to 13 psi, didn't happen again the entire weekend. I did spin the wheels pretty good and that is what triggered it.
07-11-2013 06:01 PM
michiganadam
Quote:
Originally Posted by BacaraJKU View Post
Last time I was driving on the beach in loose sand my esc light turned on and stayed on for probably 30 min. Finally went off, but my guess was a tripped up wheel sensor that fixed itself. I'll be keeping an eye on this, hopefully doesn't break after warranty runs out.
i have a can bus scanner and pulled the ABS codes (theyre still stored even if the light turns off, unless you pull the battery cable), and it said, basically, two of the sensors detected no wheel speed

no shit, the wheels were stopped. so it shut down because it was working properly and it didnt understand what was going on. LOL.

nothing wrong with your jeep.

If you air down it wont do that though
07-11-2013 05:06 PM
BacaraJKU Last time I was driving on the beach in loose sand my esc light turned on and stayed on for probably 30 min. Finally went off, but my guess was a tripped up wheel sensor that fixed itself. I'll be keeping an eye on this, hopefully doesn't break after warranty runs out.
07-11-2013 04:59 PM
michiganadam Spun my tires in sand (not aired down) in 2 wheel drive while completely still and it turned the abs/bas/esc lights on.

pretty retarded.
07-11-2013 04:27 PM
Ricky Dog Back at the dealership, not fixed..
07-10-2013 03:16 PM
derf Nice!

Glad to hear you got it sorted out.
07-10-2013 02:41 PM
Ricky Dog
Quote:
Originally Posted by derf View Post
I had the ESC light come on when I was driving down the interstate because I hit a bump in the road with the cruise control on. Wouldn't go off until I stopped, shut the engine off, and started it back up.

Given the number of people who post about problems with ESC that turn out to be no real failure, I'd put my money on the programming being way too sensitive.
You were right ! No real problem.. Service dept Flashed Transmission and Power Train. Now it's not a "Lazy Shifter" holding the gears longer before the auto-shift and more quick to lock the gear, rather than riding the clutches.

Purposefully ran over rough railroad crossing several times trying to get the lights & codes back, on the way home. Nada !
07-09-2013 11:41 PM
derf I had the ESC light come on when I was driving down the interstate because I hit a bump in the road with the cruise control on. Wouldn't go off until I stopped, shut the engine off, and started it back up.

Given the number of people who post about problems with ESC that turn out to be no real failure, I'd put my money on the programming being way too sensitive.
07-09-2013 09:45 PM
Ricky Dog Yeah, but highway speeds on a state highway is not like highway speeds over the Lunar surface..

We'll find out manana with the dealer service dept, I guess..
07-09-2013 05:24 PM
Getnoff
Quote:
Originally Posted by derf View Post
The fact that you're running over rough surfaces when it happens leads me to believe that the signals from the wheel sensors is confusing the computer too much. If the wheels all start going different speeds the computer may decide to give up trying to figure it out and throw a code.
I agree. Pretty easy to change out also.
Troy
07-09-2013 03:15 PM
derf The fact that you're running over rough surfaces when it happens leads me to believe that the signals from the wheel sensors is confusing the computer too much. If the wheels all start going different speeds the computer may decide to give up trying to figure it out and throw a code.
07-09-2013 02:39 PM
Ricky Dog 33"s have been on it since day 1. Now 32.5K miles with no issues. However I did rotate them about 700 miles back, I always rotate at 5000 mile intervals when I change the oil.
After a little research Im leaning toward a shorted wire, perhaps to the cam shaft sensor of all things..

Service appt. in the morning !
07-09-2013 02:30 PM
inspwylie Look in your manual, It says if you put bigger tires on it could confuse the ECS. It tells you how to disable the ESC.
07-09-2013 01:44 PM
Scott2373 Definitely sounds like some sort of loose wire causing an arc or short. Take it to the dealer and don't mess around with it, as long as you're still under warranty. If not, have fun...I hate electrical gremlins *ugh*
07-09-2013 01:16 PM
Ricky Dog
ESC light

Made a railroad crossing a few days ago and the ESC light came on and power dropped off to about 50%. Cycled the ignition and all was OK.

Hit a pothole today light back on. Cycled the ignition all was good for about another 20 miles, hit a bump light back on..
Anyone else experience anything similar and what was the cause. I'm thinking an unsecured ground wire someplace.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 02:08 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC