Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 3rd brake light help

Join Wrangler Forum Today


Thread: 3rd brake light help Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-29-2013 01:21 PM
TJ Green I just had to wire brush mine again to get it working .
07-17-2013 03:05 PM
G8RDave And have you checked to make sure the wires are connected to the backside of the contacts? One of mine had come off.
07-17-2013 10:05 AM
Jerry Bransford You said it's not the contacts but have you actually taken a wire brush to them to ensure it's not just an oxidated surface on the contacts that is preventing the 3rd brake light from working? My 3rd brake light contacts (next to the tail gate hinges) looked fine but an oxidation coating on them proved to be the cause of mine not working... wire brushing them fixed the problem.
07-17-2013 10:01 AM
Water Dog
Quote:
Originally Posted by GI Jeep View Post
I know I'm two years late on this post, but I'm having a problem with my third brake light as well, and it's not the contacts. I can't find the fuse location you're talking about. M1? I only have one 15A fuse, and it's for aux power. I was hoping you could help!
You didn't say what year your TJ is, but if it's "97-03" it would be fuse #2 (20 amp) in the fuse box behind the glove compartment (not sure about the newer years). If your regular brake lights are working and just your center one is out, it wouldn't be the fuse (same fuse for all brake lights)
07-17-2013 02:01 AM
GI Jeep
Third brake light fuse

I know I'm two years late on this post, but I'm having a problem with my third brake light as well, and it's not the contacts. I can't find the fuse location you're talking about. M1? I only have one 15A fuse, and it's for aux power. I was hoping you could help!
10-27-2012 10:35 AM
Beastmaster My 3rd brakelight stopped working after I put on new tires (I have a license plate w/brake light in the middle of my spare). I determined it shorted out when I put the license plate bracket back on.

I Googled the problem and it led me here, funny how things happen.

This thread didn't fix my problem but I found the solution elsewhere and thought I'd share the info here.

My problem wasn't contacts, it was a fuse. Come to find out, the 3rd brake light is on a seperate fuse from the regular brake lights. It is a 15A fuse in position M1.

Problem solved.
02-26-2012 01:48 PM
TJ Green Hey thank's for the help, I pulled the wires off the button contacts and it would work on and off again, then I saw where the buttons were on the tub(dirty) so I hit them with the wire brush, so far so good thank's for the help. It made perfect sense how it worked once you guys pointed out the buttons on the tub.
02-25-2012 10:45 PM
Wesboy
Quote:
Originally Posted by coley View Post
A wire came off mine where it connects to the "button" underneath. I was able to get my arm up into the fender and "plug" it back in.
X2
Fairly common for wires to come off the contacts.
Doesn't matter which way they are put back on unless you have aftermarket LEDS in the brake light.

They will need to be pushed back on with some authority or they will fall off again.

You will feel a definate 'click' when they are on correctly.
02-25-2012 10:15 PM
Wheel2Work Using a multimeter check the contacts as follows:
1. Check for continuity on the tailgate side buttons. You should read very close to 0 ohms on the meter. If you get a high resistance reading, replace the bulb, as it has a bad filament.
2. Check for voltage on the tub contacts. You should read very close to 12V on the contacts when the brake pedal is depressed. If no voltage is present, then you need to dig a little deeper.

It is common for the wires to come loose from the contact buttons , so look under the wheel well liner and make sure that everything is connected and tight. The pins may look like they are connected, but if they are not properly seated, you will not have good contact.

Beyond that, you are going to be looking for wiring issues such as rubs or breaks that have exposed the conductors.

Fuse Position#2 - 20 amp yellow fuse - Stop Lights; but if your Brake lights are working normally, then this won't be the problem.

Good Luck & keep us posted
02-25-2012 04:46 PM
coley A wire came off mine where it connects to the "button" underneath. I was able to get my arm up into the fender and "plug" it back in.
02-25-2012 04:15 PM
RUBI 4 MY MRS check & clean the "button" contacts from the tailgate to body which touch when the gate is closed. That is what powers the center brake light. From the body side, one should have power when the pedal is pushed, the other is the ground. Usually they just need a LIGHT sanding.
02-25-2012 02:30 PM
TJ Green
3rd brake light help

can someone help me with the third brake light fuse location? i have checked the stop lamp fuse but not sure if they are the same fuse,my brake lights work, there is some water in the third brake light but the bulb is not blown.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC