Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Not sure what to do with my YJ...

Join Wrangler Forum Today


Thread: Not sure what to do with my YJ... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-02-2013 09:16 PM
harleydragon your initial problem sounds like the gas tank might not have been venting
08-02-2013 09:04 PM
sfhusser This may be a dumb question, but almost everything you've mentioned: computer, fuel pump, sensors, etc, all have one thing in common. Power. Have you checked the voltage to the computer? A drop of one volt can throw the whole thing out of whack.
08-02-2013 01:52 PM
lOlllOl Hi all...thanks for the replies. I did forget to mention that the mechanic found a corroded ECU ground wire behind the fuse box. He fixed it but the problem still persisted. He also noticed my fuel still wasn't holding pressure, so threw on a new regulator. The pressure remains perfect while idling, driving, etc. But, the starting issue is still there. I will certainly double check the rest of the wires. Where should I start checking, considering the mechanic checked behind the fuse box already??
08-02-2013 09:18 AM
panzer-yj Check your ground wires. Had a vehicle do this once. Spent days working on it, crank & no start and would die after driving a while when it did start. Turns out the fuel pump had a bad ground and any vibration or slight movement could and would break the circuit. I ended up making a new ground and fixed the issue.
08-02-2013 08:54 AM
Brohawk We've (now) also replaced the spark plug wires, distributor cap & rotor, ignition coil, & fuel filter. We've been investigating the fuel pressure regulator & checking that the pressure is correct.

One can rent a gauge at Autozone for a deposit, BTW. Since we're all spending money on parts...

I'll be in touch.
08-01-2013 09:04 AM
wranglertask91 If one sensor is bad, replace both.
08-01-2013 09:03 AM
wranglertask91 Check your throttle body. Completely take it off and look on the inside of it. Check both of your sensors that are attached to it. Specifically your air/fuel sensor. Take it off and check your stem, if it's gunked up it could really cause a problem and not run right. If the entire TB has gunk all over it, leave it in acetone overnight, both sensors off, and wipe it down in the morning, will come out completely new.
08-01-2013 08:53 AM
macker I also have a YJ with 4.2 with the same issue. I also have had numerous mechanics look at the vehicle with no success. I have several vehicles so I don't drive the YJ much. I have had this problem for about 2 years. Very frustrating. Looking forward to a solution. I even went as far as to replace the distributor. Still same problem.
08-01-2013 08:22 AM
Boystaysin Any luck with this? I'm having similar issues with mine.
07-30-2013 05:46 PM
lOlllOl Not quite yet...the mechanic fixed the fuel issue, but now it will only start every once in a while. He said that when he was working on the car, he had the engine all ready to be fired up and when he cranked it, there was absolutely no spark!! He didn't even touch anything spark-related! So he threw on a new crankshaft position sensor and that didn't fix the problem until I reset the battery. After that, it would crank and fire every time...until now.

The mechanic also said that throughout the repair process, he kept checking the computer's codes and was getting all sorts of readings, including 54 (distributor sync pickup, controlled by the CAM position sensor inside the distributor) and 27 (cylinder four not firing properly). However, since neither of these codes were accurate, he suggested that I swap the computer out again for a warranty replacement. So, I'm going to do this and see what happens. Like I said, it will fire somethings, and then not fire; it's very sporadic and extremely frustrating. Six mechanics and I still have a defective vehicle...

I'll report back IF I ever get it fixed!
07-27-2013 05:40 PM
Brohawk
Quote:
Originally Posted by lOlllOl View Post
Hello,

-New fuel filter
-New fuel pump (2 actually...after i installed the first one, the Jeep would not hold a steady fuel pressure. It would drop to zero immediately after turning the car off. I replaced it again with a warranty replacement and that problem went away)
-New fuel pressure regulator
-New crank position sensor
-New exhaust manifold gasket (there was a leak)
-New ECU
-Fixed a corroded ground wire behind the fuse box
-New exhaust pipe, muffler, cat converter
-Fresh tune-up

NO ONE can figure out this issue and, seeing that I am a college kid, I cannot keep dumping money into this vehicle!! I really love the Jeep and want to keep it, but I simply don't know if it's worth it anymore.

So, if you have any suggestions at all, please let me know! I am up for one last crack at this thing....

Thanks!
Did you figure out what the problem was?
I've also completed about 80% of that list, including the coil, the MAP, the O2 sensor, the TPS, and my Jeep will turn over but not start.
07-21-2013 03:20 PM
bill9274 i would check the coil also
07-21-2013 03:14 PM
lOlllOl Sorry, it's a 1995 2.5L.
07-21-2013 03:04 PM
2xs Coil or ignition module could be getting hot and crapping out.

What YEAR 2.5L? Mine is a 90 TBI, which is WAY different then a 91 PFI....


I would also check your cat, if its starting to plug it could do what you are describing, but since you replaced it already.....
07-21-2013 02:38 PM
AllMudd Compression check each cylinder, also have you looked into seeing if the injectors or clogged?
07-21-2013 02:31 PM
lOlllOl Also, I'm running a 2.5L 5sp YJ
07-21-2013 02:29 PM
lOlllOl No codes except for 62 which means the computer can't read the odometer. This is fine because the computer is new and I haven't taken it anywhere to have the mileage stored in the new ECU.
07-21-2013 02:23 PM
AllMudd Pull the codes see if your Jeep is recording any faulty sensors like the O2 without throwing the CEL.
07-21-2013 02:01 PM
OregonPlinker Fill out your sig so people know what your running. I had this problem on my old BII and it was the O2 sensor. O2 sensor have some of the most diverse symptoms Ive dealt with...
07-21-2013 12:43 PM
lOlllOl
Not sure what to do with my YJ...

Hello,

Once again, I'm at the point where I don't know what to do with my Jeep. It's giving me one major problem and no mechanic so far (I'm up to 5 now...) has been able to resolve the issue. I've just about exhausted my mechanical ability in trying to solve the problem. Here's what's happening -- the Jeep cranks just fine. After driving for about ten minutes, the Jeep starts sputtering and hesitating; it's like the Jeep is running out of gas. Once it stalls, it will start up again after a few minutes and do the exact same thing. See the list below for everything that's been done to the Jeep in an attempt to solve this issue:

-New fuel filter
-New fuel pump (2 actually...after i installed the first one, the Jeep would not hold a steady fuel pressure. It would drop to zero immediately after turning the car off. I replaced it again with a warranty replacement and that problem went away)
-New fuel pressure regulator
-New crank position sensor
-New exhaust manifold gasket (there was a leak)
-New ECU
-Fixed a corroded ground wire behind the fuse box
-New exhaust pipe, muffler, cat converter
-Fresh tune-up

NO ONE can figure out this issue and, seeing that I am a college kid, I cannot keep dumping money into this vehicle!! I really love the Jeep and want to keep it, but I simply don't know if it's worth it anymore.

So, if you have any suggestions at all, please let me know! I am up for one last crack at this thing....

Thanks!

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:52 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC