Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > Pioneer avh-x5500 head unit. Whats your thoughts?

Join Wrangler Forum Today


Thread: Pioneer avh-x5500 head unit. Whats your thoughts? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-11-2013 08:48 PM
woansleftpeg
Quote:
Originally Posted by Ivoryring View Post
Much as I'm not real happy about the reverse feature not working on my RP4-CH11 - I can't fault Crutchfield for this, as the firmware fix for it was released by PAC in May of 2013 - many months after I purchased and installed. I fault PAC for the initial error and for (what I gather to be) their policy of trying to force users to return to an authorized dealer to get firmware updates.

I'm not being apologetic about Crutchfield - I think they are to blame for not having the correct adapter (even though they claim and list that it IS correct) and/or not knowing how to modify it for correct fit and/or not accepting my report (and photos) that what they supplied didn't fit properly. I just think it's important to be fair about assigning blame.
I'm sure you're right, but I've seen so many people saying that "I did this because Crutchfield told me to", when anyone with the first idea about ICE or even basic %&£$ing electrics would be able to tell you that they're flat out wrong, that I've no time at all for them as a company, and will tell anyone who will listen to avoid them like the plague.
08-11-2013 07:49 PM
WhiskeyMike
Quote:
Originally Posted by WhiskeyMike View Post
Good thread that shows the difference of the 5500 and 8500. I just put the 8500 in mine nd absolutely love it. The hdmi mirroring of my phone was crucial so I could use apps that are not made for app radio.
Sorry, would help if I included the link... Pioneer AVH-x8500 / x5500 Confusion - Receivers - Car Audio, Video, & GPS - Crutchfield Forums
08-11-2013 06:56 PM
Ivoryring Much as I'm not real happy about the reverse feature not working on my RP4-CH11 - I can't fault Crutchfield for this, as the firmware fix for it was released by PAC in May of 2013 - many months after I purchased and installed. I fault PAC for the initial error and for (what I gather to be) their policy of trying to force users to return to an authorized dealer to get firmware updates.

I'm not being apologetic about Crutchfield - I think they are to blame for not having the correct adapter (even though they claim and list that it IS correct) and/or not knowing how to modify it for correct fit and/or not accepting my report (and photos) that what they supplied didn't fit properly. I just think it's important to be fair about assigning blame.
08-11-2013 04:37 PM
WhiskeyMike Good thread that shows the difference of the 5500 and 8500. I just put the 8500 in mine nd absolutely love it. The hdmi mirroring of my phone was crucial so I could use apps that are not made for app radio.
08-11-2013 04:11 PM
woansleftpeg So Crutchfield sent you an outdated PAC harness and then gave you duff advice about fitting? I've said it before on here many times before, but the sooner people stop giving money to that company the better off we'll all be.
08-11-2013 03:53 PM
Ivoryring
Quote:
Originally Posted by Mattk11 View Post
I'm amazed by this. I have had no problems.

The rear bracket is held in with a couple screws, you didn't need to saw it out.
I may not have been clear - the rear bracket is held in by two screws, and I removed it in order to cut away the bottom portion of it. I needed the top portion intact as that is where the screw in the 'tray' on top of the dash screws down. I need that anchor point because I have a Vector eDock, which bolts down to that location. After cutting away the bottom of the bracket, it's clear that the radio has no support in the back, hence the use of a zip to support while bouncing around offroad.

Quote:
Originally Posted by Mattk11 View Post
You probably had to twist the install kit because you didn't trim the plastic on the top held of the inner dash with a dremel. Not the outer trim piece, but the one that is inside the dash. If you shave it down an 1/8", the unit tilts up a little and fits perfectly. Crutchfield won't tell you that.
Yes, in retrospect there were two choices, twist the visible trim or trim inside. I spent time back and forth with Crutchfield, including photos - they insisted that it fit correctly and that I didn't have a problem. Note that the straight on photo posted by MotoRockstar777 shows the same type of twist on the visible trim that I also have.

Quote:
Originally Posted by Mattk11 View Post
Sounds like you had an older PAC unit that wasn't flashed up to date.
Correct. I got my Pioneer and PAC about a year ago. Unfortuantely, as far as I can tell, in order to update the firmware you need a module from PAC that they don't sell to the public, only to authorized installers.

Quote:
Originally Posted by Mattk11 View Post
I re-used my factory Sirius antenna that is located on the roll bar just above the passenger. No reception probs with hard or soft tops.
I didn't even think to try the stock antenna (which I left in place), as I thought it was Sirius & GPS and a different connector - perhaps I'll look into that the next time I have the dash apart.

Quote:
Originally Posted by Mattk11 View Post
Your soundbar rattles are because of the badly designed sound bar. It's thin plastic, not very air tight and needs some modification to sound decent. I reinforced mine with fiberglass, expanding foam, dynamat and polyfill and it actually sound good. No rattles, buzzing - nice mid-bass from it now.

Wish I would have read about your probs during install, I may have been able to help you out.
There may be problems with the sound bar design, but I didn't have any problem with rattles for about 10 months (perhaps I just don't turn up my head unit loud enough to put enough acoustic energy into the sound bar to show the problems) - and the rattles I have are with there with the head unit on mute. I am certain it's from the adapter having come loose or the speaker having come loose from the adapter.
08-11-2013 07:45 AM
Tink8909 I bought mine through crutchfield and they tolde Me to take the bracket completely out and take a 1/8th of a in off the top side of the space to put it in and it fits perfect and looks clean. On the other hand I don't have serious radio yet. So I can't help u out there
08-11-2013 06:34 AM
Mattk11
Quote:
Originally Posted by Ivoryring View Post
I can comment on this head unit because I have it in my Jeep.

My install with Crutchfield kit has three problems plus a maybe problem:

1.) support bracket on the back side needs to be cut or modified. I just cut mine with a dremel - it comes out completely with two screws so if ever needed to go back to stock, I hope it isn't too expensive. I use a large zip strap to provide support back there. This is likely to be a problem with any double-din since the stock head units are something like 1/8th of an inch shy of double din height in the back.
2.) the dash adapter that Crutchfield supplied last summer is a poor fit - it has to be twisted slightly in order for the holes to line up. I don't look too closely at it when the trim is back in place because if I did, it would annoy me.
3.) I have had two problems with the PAC RC4-CH11 (steeringwheel/canbus adapter/wiring harness) - A.) the firmware I got on mine has a known bug where it doesn't correctly assert reverse light, which means my backup camera is manual control only, not driven by putting the transmission in reverse, and B.) I've had a few instances of the steeringwheel controls getting stuck repeating the same button press until I powered off the Jeep.

And my maybe problem: I've never gotten good Sirius reception no matter where I put the antenna. This might be something I have to blame myself for - it is possible I pinched the antenna cable.

Another problem I just remembered, which could be my fault, but I blame the adapters that came from Crutchfield - the soundbar speakers (Polk db651) never really fit right, and one of them is loose now and rattles.

As for function of the head unit itself - I'm happy with it. I haven't had real problems with screen washout in the sun. The touchscreen isn't quite up to par with modern phones, but it works fine.
I'm amazed by this. I have had no problems.

The rear bracket is held in with a couple screws, you didn't need to saw it out.

You probably had to twist the install kit because you didn't trim the plastic on the top held of the inner dash with a dremel. Not the outer trim piece, but the one that is inside the dash. If you shave it down an 1/8", the unit tilts up a little and fits perfectly. Crutchfield won't tell you that.

Sounds like you had an older PAC unit that wasn't flashed up to date.

I re-used my factory Sirius antenna that is located on the roll bar just above the passenger. No reception probs with hard or soft tops.

Your soundbar rattles are because of the badly designed sound bar. It's thin plastic, not very air tight and needs some modification to sound decent. I reinforced mine with fiberglass, expanding foam, dynamat and polyfill and it actually sound good. No rattles, buzzing - nice mid-bass from it now.

Wish I would have read about your probs during install, I may have been able to help you out.
08-10-2013 10:28 PM
Tink8909 Yeah I think not has a nice clean fit
08-10-2013 07:40 PM
MotoRockstar777 I don't know about you guys but everything works fine for me and it was not a pain to install either. I used the PAC RC4-CH11 harness and my steering wheels controls work like they did with the stock stereo. For the support bracket i just cut the top of it off so the stereo just rests on the bottom. I put the satellite radio antenna under the padding of the roll bar and i haven't had any problems with it cutting in and out. I've had it for a few months and so far i haven't had any problems with it.



08-10-2013 07:21 PM
krawdaddy
Quote:
Originally Posted by joeuncool View Post
Car stereos just don't get stolen anymore. Even the aftermarket ones have security in them that disable them when they get jerked out of a dash. There is no market for them. Besides, the thieves are far more interested in that, laptop, iPad, iPod, iPhone, navigation device, or gym bag in your car that might contain any one of these devices.

This article was written in 2009 and I am sure car stereo theft is down even more since then.

Car Stereo Theft: A Dying Crime : NPR
maybe so, but once you have had that sick filling of walking to your vehicle in the morning and finding your door handle pried off , see the hole in your dash and find all your stereo stuff stolen, you will NEVER feel comfortable leaving your radio behind. It's even worse when it happens twice! I lived in a "good" area when it happened. It took years to get over that feeling. Its the #1 reason I went with factory nav in my JK... less inviting to thieves.

As for Pioneers, I have an AVIC D3 in my mustang. Great radio but a little lacking on features. Not a surprise since it was bought in 2006! But, it still works great, no issues with the display. Nav works great. XM works great. The only issue I have is the add on bluetooth. It only autoconnects to the first phone on the list and not mine It's a common issue.
08-10-2013 05:52 PM
Ivoryring The things I've run into are merely annoying things that are wrong, that people should know about - not things that make me hate the head-unit - the only one that really is a daily problem is the Sirius signal strength (it cuts out constantly).
08-10-2013 06:33 AM
Tink8909 Well I'm sry for all your problem and I bought off of crutchfield. And I havnt had any issues yet. I like it so far lets cross our fingers
08-10-2013 05:23 AM
Ivoryring I can comment on this head unit because I have it in my Jeep.

My install with Crutchfield kit has three problems plus a maybe problem:

1.) support bracket on the back side needs to be cut or modified. I just cut mine with a dremel - it comes out completely with two screws so if ever needed to go back to stock, I hope it isn't too expensive. I use a large zip strap to provide support back there. This is likely to be a problem with any double-din since the stock head units are something like 1/8th of an inch shy of double din height in the back.
2.) the dash adapter that Crutchfield supplied last summer is a poor fit - it has to be twisted slightly in order for the holes to line up. I don't look too closely at it when the trim is back in place because if I did, it would annoy me.
3.) I have had two problems with the PAC RC4-CH11 (steeringwheel/canbus adapter/wiring harness) - A.) the firmware I got on mine has a known bug where it doesn't correctly assert reverse light, which means my backup camera is manual control only, not driven by putting the transmission in reverse, and B.) I've had a few instances of the steeringwheel controls getting stuck repeating the same button press until I powered off the Jeep.

And my maybe problem: I've never gotten good Sirius reception no matter where I put the antenna. This might be something I have to blame myself for - it is possible I pinched the antenna cable.

Another problem I just remembered, which could be my fault, but I blame the adapters that came from Crutchfield - the soundbar speakers (Polk db651) never really fit right, and one of them is loose now and rattles.

As for function of the head unit itself - I'm happy with it. I haven't had real problems with screen washout in the sun. The touchscreen isn't quite up to par with modern phones, but it works fine.
08-09-2013 10:02 PM
joeuncool
Quote:
Originally Posted by Mattk11 View Post
That's what everyone says that gets their stereo stolen. Haha. Good luck.
Car stereos just don't get stolen anymore. Even the aftermarket ones have security in them that disable them when they get jerked out of a dash. There is no market for them. Besides, the thieves are far more interested in that, laptop, iPad, iPod, iPhone, navigation device, or gym bag in your car that might contain any one of these devices.

This article was written in 2009 and I am sure car stereo theft is down even more since then.

Car Stereo Theft: A Dying Crime : NPR
08-09-2013 09:23 PM
Tink8909 I personally like what pioneer has done with this unit. I can do alot with it.
08-09-2013 08:22 PM
woansleftpeg I think Kenwood should stick to making blenders.
08-09-2013 05:51 PM
honda400ex81 Im not a big fan of the Pioneer as their OS are known to have alot of firmware related issues. I would have wen Kenwood.
07-24-2013 03:46 PM
Tink8909 I bought it from crutchfield.
07-24-2013 03:24 PM
earroyo Make sure you purchase the Pioneer unit from an "authorized dealer" otherwise there is no warranty! Go to their website for more info!!!
07-23-2013 11:11 PM
Tink8909 Yeah I'm not worried about it.
07-23-2013 10:13 PM
lolpetewtf People who say it will get stolen clearly think it is the 1990s where you could stick four wires in a stereo and pull it out. Your average thief won't know where to start when removing a wrangler stereo.
07-23-2013 09:55 PM
Tink8909 Well lets hope not.
07-23-2013 09:51 PM
Mattk11
Quote:
Originally Posted by Tink8909 View Post
I'm not really worried about it getting stolen. I won't have it open for ppl to see much. And I park in a garage.
That's what everyone says that gets their stereo stolen. Haha. Good luck.
07-23-2013 08:55 PM
Tink8909 I'm not really worried about it getting stolen. I won't have it open for ppl to see much. And I park in a garage.
07-23-2013 08:19 PM
Mattk11
Quote:
Originally Posted by Tink8909 View Post
Looking into buy the pioneer avh-x5500 head unit. What's everyone's thoughts on this stereo.
Save a few more bucks and buy the 8500, I paid $550 for mine. The face comes off so it won't get stolen. It fits perfectly and is not a nightmare to install. You do need to remove the back bracket that holds the stock radio and you need to trim the inner plastic top edge about an 1/8" that the top of the Pioneer rests up against. I used a dermal. Not the outer dash bezel that you can see but the one inside the dash.
07-23-2013 08:04 PM
Tink8909 Thanks. I'll prob get it ill post pictures of it and my thoughts on it
07-23-2013 05:05 PM
donmeca2020 never owned or dealt with that peticular model, but i did own a F series double din nav/dvd/ipod,hd radio unit in my evo. i'm definetly a pioneer product user and you can't really go wrong with their products.
07-23-2013 03:10 PM
Tink8909 The 5500 has the tilt option. I had a pioneer before and loved it. Would like to get another. Want to know how easy it is to install.
07-23-2013 03:01 PM
DIXIEDOG The display on them sucks in sunlight....you get complete washout. With exception of the display I like all the new Pioneer dvd-x units but that would stop me from buying another. I only have the x1500 in my TDI but they have the same display problem.....if you decide to go that route try to get a mount that will tilt the screen slightly to help you see it during the daytime.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:35 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC