Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > High Pressured Blow Off Sound and Oil?

Join Wrangler Forum Today


Thread: High Pressured Blow Off Sound and Oil? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-12-2009 10:37 PM
Beowulf From some other forums it seems to be my AC high pressure relief valve. Now to figure out what caused the pressure to spike enough to blow the valve.
07-12-2009 01:29 AM
crazyredneck it might be the front axle vent tube
07-11-2009 11:02 PM
Beowulf Not that I can find. From some other forums they are saying it might be my A/C which happened to be on at the time.
07-11-2009 09:02 PM
4.0l sahara high pressure power steering hose? Any leaks?
07-11-2009 07:55 PM
4Jeepn guessing but: axle vent tube not on all the way. Power steering line same thing.
07-11-2009 07:51 PM
Beowulf
High Pressured Blow Off Sound and Oil?

High Pressured Blow Off Sound and Oil?

After driving around in the mountains for a few hours I came to the intersection of a major road. Upon waiting for traffic, I gave the jeep gas for a normal take off. I immediately heard a sound that was similar to a High Pressure Blow Off valve that seemed to come from the driver’s side. It only lasted for a seconds. I may have just been paranoid, but it seemed to have some overall vibration coming through the seat. Even my wife thought so, but the steering wheel was completely vibration free. Since it seemed normal enough I drove the remaining 5 miles home. Once home I walked around the jeep and did not see anything. However, once I crawled under the jeep I noticed a viscous liquid on the Driver side motor mount. It was coating most of the motor mount and really nothing else I could see. The liquid is similar to brake fluid, but not quite, and not quite motor oil. If I had to lean one way or another I’d say brake fluid.

There was no liquid on the engine block itself and I could not find any liquid on the Power Steering or brake lines? This is basically right under the air intake.

I checked the fluids in everything and it seems within specs and had not moved since the last time I checked. At this point I am at a total loss, but am worried something major is in the works.

Any thoughts will be appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:27 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC