Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > Right brake light problem!

Join Wrangler Forum Today


Thread: Right brake light problem! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-10-2013 12:16 AM
jeepr1106 So if I can replace that relay
08-09-2013 11:59 PM
bigal66 Exactly the same thing happened to me when I put LED bulbs in my TJ. Don't want to sound too technical, but you have to install 2 blocking diodes for the rear lights and 2 for the front turn signal/park lights. Also, since I didn't want to use load resistors to force the blinkers to work, I swapped out the blinker module for an electronic one made for LEDs.
08-05-2013 10:42 PM
jeepr1106 I check all the pins they look good
08-05-2013 09:50 PM
jeepr1106 What do I do when I open it
08-05-2013 09:02 PM
jeepr1106 Ok so, when the parking lights are on the light works. When harzards are on, right turn signal and brakes are pressed its dim
08-05-2013 08:05 PM
Water Dog
Quote:
Originally Posted by jeepr1106 View Post
Could I get a picture?
The only picture I have is the one off a "99", yours probably has the headlights on it as well.
08-05-2013 07:46 PM
jeepr1106 Could I get a picture?
08-05-2013 07:31 PM
Water Dog It's the turn signal switch on the steering column
08-05-2013 07:15 PM
jeepr1106 Were is it
08-05-2013 06:57 PM
freeskier
Quote:
Originally Posted by Water Dog View Post
I would try disconnecting the led's and use a test light to test the jeep wiring. If that works, then you know it's in the led circuitry or a ground, if it doesn't work with a standard test light, then it's probably the multifuntion switch. (You'll have to check it there.)
Yup, if it's not the lights or wiring the multifunction switch is the next likeliest thing to check. Everything goes through it and it doesn't take much fore the traces in there to short with each other. I've had mine open 3 or 4 times now to fix it.
08-05-2013 06:34 PM
Water Dog I would try disconnecting the led's and use a test light to test the jeep wiring. If that works, then you know it's in the led circuitry or a ground, if it doesn't work with a standard test light, then it's probably the multifuntion switch. (You'll have to check it there.)
08-05-2013 05:21 PM
jeepr1106 The wiring is good. Idk what the problem is
08-05-2013 04:57 PM
T2000J Past few LEDs had different pigtails on them YOUR colors I can't say but the jeep Harness is so :
Purple/black = reverse light
Black/yellow = taillight
Green /red = (left) turn/stop
Brown/ red = (right) turn/stop
08-05-2013 04:06 PM
jeepr1106 How is it supposed to be wired, there is a black, green and red wire coming from the light
08-05-2013 03:31 PM
Water Dog I think Freeskier is right....probably miswired.
08-05-2013 03:07 PM
jeepr1106 No it is also dim, but when I turn on parking lights it gets brighter
08-05-2013 02:31 PM
Water Dog
Quote:
Originally Posted by jeepr1106 View Post
Huh
Huh what? Does the right turn signal work????
08-05-2013 01:13 PM
jeepr1106 Huh
08-05-2013 10:31 AM
freeskier
Quote:
Originally Posted by T2000J View Post

I'd say ground problem them cages tend to be a PITA . My first Tj had them they worked then didn't work . Take a wire hook it to your bumper and put the other end to your light .
They are LEDs which means they are no longer grounded through the mounts. Looks like bad wiring job or multi function switch.

OP does the right blinker work?
08-05-2013 09:28 AM
Water Dog
Quote:
Originally Posted by redrider94 View Post
does your right turn signal work when you turn it on?
x2..??
08-05-2013 05:55 AM
T2000J
Quote:
Originally Posted by jeepr1106 View Post

This is what it looks like
I'd say ground problem them cages tend to be a PITA . My first Tj had them they worked then didn't work . Take a wire hook it to your bumper and put the other end to your light .
08-05-2013 02:55 AM
jeepr1106 Attachment 281799



Attachment 281798

This is what it looks like
08-05-2013 02:46 AM
jeepr1106 Ok problem is back
07-06-2013 07:29 PM
freeskier
Quote:
Originally Posted by jeepr1106 View Post
I figured it out, previous owner removed third brake light and left the wires open and not completing the circuit. i just put a load between the + and - and it fixed the problem
Not sure how this fixed the problem, can't remember the last time I had a third brake light and that certainly hasn't given me problems.

Your issue sounded like a bad ground.

Your wirings seems funky.
07-06-2013 05:07 PM
jeepr1106 I figured it out, previous owner removed third brake light and left the wires open and not completing the circuit. i just put a load between the + and - and it fixed the problem
07-06-2013 07:24 AM
Redrider94 Does your right turn signal work when you turn it on? If your turn signal works then I'd say that you may have a problem with your turn signal switch. If turn signal is not working them I'd look for a break in the brake light wiring.
07-06-2013 07:14 AM
Atthehop Check your grounds, tail lamps ground with the mounting screws.
07-05-2013 10:46 PM
jeepr1106 they are led lights in wired in Parallel
07-05-2013 10:21 PM
JimsJeep Might be as simple as a bit of corrosion in the socket. Best place to start.
07-05-2013 10:09 PM
jeepr1106
Right brake light problem!

When i press my brakes in my 04 rubicon my right light will not turn on, but when parking lights are on the light will turn on but will not get bright when brake is pressed.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:35 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC