Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 97 another t-j clunk sound

Join Wrangler Forum Today


Thread: 97 another t-j clunk sound Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
07-24-2009 08:13 PM
JEEPSAILOR
I got it

The problem was my tracksion bar bolt was broken. Going to advanced auto parts and gonna put a new one on. thanks for everything-
07-24-2009 07:10 AM
Ironman There's a screw that holds the shifter handle secure to the shifting linkage. My guess is this came loose. And the clunk sound might be in the control arms. Are they stock or aftermarket? I know that alot of aftermarket control arms with some sort of flex joint at one end can wear over time and cause a clunk sound when driving. If the arms are stock, this probably isn't the case.
07-24-2009 06:28 AM
Sb5551 Check your Tranny mount. It attaches from the bottom of the skid plate up to the transmission. You will have to drop the skid plate in order to look at it though.

Other possibilities can be control arm bushings and sway bar links.
07-23-2009 08:52 PM
JEEPSAILOR
97 another t-j clunk sound

Okay, I recently bought my first jeep. Has tons of options, 33" bfg m/t. 6" lift 3 body 3 susp etc etc. Recently i've been gettin upset.

While driving on the freeway at about 65 mph, it flipped out. Tires started shaking almost like i was in 4x4 and I pulled over. Couldnt see anything. Got back in and drove fine the rest of the way back about 50 miles. Since then theres been a small clanking sound under the jeep. U joints are in good shape from what I can see. Also the 4 wheel drive shifter is completely loose. I mean no resistance what soever. I was thinkin maybe the linkage broke.. The sound only happens when I take off in first, and when I take a slow turn. Havent been on the freeway since then.

What could it be? These are some idea's i've had-but would like to isolate the problem before i start diggin-

4x4 Linkage in the transfer case-
Slip yoke eliminator-
u joints- (still possible)
gear oil-
Something rotational could be loose-
I'm pretty sure the problem is in the transfer case, but like i said I am very new at jeeps.


Any and all help would be greatly appreciated

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 03:16 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC