Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > Clutch or trans issue?

Join Wrangler Forum Today


Thread: Clutch or trans issue? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-18-2013 09:37 PM
Surfinglbi23 Ok let me know if you figure it out. Anyone else have this happen before?
08-18-2013 08:00 PM
wildchild048 I have the same problem but if I hold shifter just about in first gear it stops.Not sure what is wrong yet.
08-18-2013 06:18 PM
Surfinglbi23 Fluid was clean, done 200 miles ago. Good suggestion though!
08-18-2013 03:21 PM
Mr.Mud clutch/flywheel issue for sure.
08-18-2013 01:45 PM
AllMudd I would start with a fluid change. Since you've replace all clutch components, put some 10w30 or Synchromesh and see what she does. If the oil that comes out is bronze/gold flakes in the oil then a rebuild might be near.
08-18-2013 01:23 PM
Surfinglbi23
Clutch or trans issue?

Hey guys - 2.5 5 speed. 1995. 179k. Not sure if the AX-5 is stock or if its been rebuilt before.

Driving the YJ today, shift out of gear into neutral rolling to a stop and it shudders, like its still IN gear, but it's in neutral.

New clutch, pressure plate, throw out bearing, slave cylinder and master cylinder. Doing it consistently now, every time I come to a stop, no matter what gear I go into neutral from. Getting some grinding going 2nd to 3rd.

Should mention, depressing the clutch helps the weird "in gear" feeling, like something is sticking as you roll to a stop. If you don't press clutch, it won't stall but feels like it is going to but then unsticks right before you come to a stop at maybe 3-5 mph. Any idea?

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:26 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC