Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > 98 TJ rough idle Help!

Join Wrangler Forum Today


Thread: 98 TJ rough idle Help! Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-21-2013 09:12 PM
00jeeper00 By the way - I found this out after replacing all my sensors up and downstream as well as my headers.... Better to start repairs at the cheaper end of the scale..
08-21-2013 09:10 PM
00jeeper00 I just went through this very same situation and if I can throw my 2c in. I replaced the TPS with a non Mopar one - Problem still there. Switched it with a Mopar one - Porblem Gone. TPS exchange has to be genuine in my experience. See if you can grab one from a TJ or XJ thats original just to test the theory.
08-21-2013 06:17 PM
DmnSlyr We replaced the TPS and it didn't really help. We think it is the IAC giving us problems. When unplugging it (the IAC) there is no change in rpms.
08-19-2013 03:47 PM
DmnSlyr Thanks guys. I will let you know how it goes
08-19-2013 02:41 PM
Notoriously_rob True point- didmt think about that- cps is 89.00 so i would check that too
08-19-2013 02:39 PM
Big Sarge Before replacling the expensive CPS unplug the TPS (throttle position sensor) and see if the problem goes away. If it does then your problem is the TPS
08-19-2013 02:32 PM
Notoriously_rob Cps. Try to replace it- helped my idle and cutting off issues..
08-19-2013 02:31 PM
DmnSlyr It has like 140k miles and the throttle body has been cleaned but thanks for the link!
08-18-2013 10:05 PM
louczar How many miles on it? Has the throttle body been cleaned? I have read that a dirty throttle body (including a AIC). give it a shot...

http://www.wranglerforum.com/f5/very...dle-52192.html
08-18-2013 08:53 PM
DmnSlyr
98 TJ rough idle Help!

I own an 98 TJ 2.5L 4 cyl. When started, and is idling the rpms drop really low and sometimes kills the motor. We know there is a small exhaust leak somewhere (seafoam test). Any other ideas how to fix the idle? I leave for college in a week and I want to take it with me.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:01 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC