Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum > wet passenger floor....not antifreeze

Join Wrangler Forum Today


Thread: wet passenger floor....not antifreeze Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-22-2013 06:39 AM
Bucktaker thanks found the drain line and will attach the new line to it.
08-20-2013 11:20 PM
lowreyfarris My 99 did the same thing in the passenger floor. The A/C drain line sticks straight out of the firewall about 2 inches, at high way speeds it is unable to drain. I used a $1 pvc elbow and some silicone from home depot to point the drain down. It is a very common problem, and a simple fix.
08-20-2013 08:00 PM
Big Sarge follow this for your a/c leaking problem

http://www.wranglerforum.com/f5/a-c-...tml?highlight=
08-20-2013 07:56 PM
larjeep The ac drain is probably clogged. You will have to blow it out.
08-20-2013 07:37 PM
Bucktaker
wet passenger floor....not antifreeze

Hello All,
Trying to determine why my 99 tj drips water in the passenger floor well.
It seems my Ac system is causing this. AC works very well and has no issue that I'm aware of it cools good. Any ideas???

Also I have having issue with the dash panel
It shuts down and I have no gauges or speedo. I have removed the panel and checked the connections but still having issues.

Help is appreciated.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:11 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC