Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > YJ Jeep Wrangler Forum > YJ Tech Forum > 95 Wrangler 2.5 w/AC

Join Wrangler Forum Today


Thread: 95 Wrangler 2.5 w/AC Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
08-30-2013 06:54 PM
btrapp79 205/210 is a good approximate temp. for a 195 thermostat. Thermostats do not actually completely open at the temp. that they are listed with, they only start to open at that temperature. A 195 thermostat is only completely open at about 206, and closes at 188 to try and maintain a middle of the road 195. I have had this problem with my YJ myself and have experimented with both 160 and 195 thermostats. The 160 usually ran about 195, while the 195 usually runs about 210.

The other thing to remember is that the 2.5 usually runs hot anyway, but this shouldn't be an issue now.
08-24-2013 07:23 PM
Onalaskawrangler
All done I think

I have checked and found that the "failsafe" thermostat has been tripped and was stuck open.
Step by step:
1-Found radiator to be filled with what looked like muddy water.
2-Flushed out system and then installed new thermostat (160) temp
The Wrangler was looking good but then I found the top of the radiator was leaking and caused it to over heat.
3-replaced with new 2core aluminum radiator. and new 16lb cap. But Wrangler running hot after running.
4-open radiator for cold start and found water flow full from startup, this told me that the radiator was stuck open.

5-Replaced (160) with stock (195) thermostat today and now no flow at startup. Running at a solid temp of 205/210 and no fluctuation.


I think I'm done.

Does the solid temp 205/210 sound correct ?

08-15-2013 05:15 AM
Hockeygeek21 My advise is get the thermostat gasket from Napa, they have one with adhesive on one side you just stick it to the head and don't have to worry about lining all the holes up.
08-14-2013 08:10 PM
Mowrangler You need to have the proper thermostat for the computer to go into CLOSED LOOP.
NEVER use blue silicone on anything. And just dont bother to check the rad cap just buck up and pay the $6 or$8 bucks to replace the one you have.I had an overheat issue , pressure tested the systen ond inspected it. All I replaced was the rad cap problem solved.
08-14-2013 07:04 AM
87 Florida YJ I would get back to basics starting with a 190* stat which is what is called for on your jeep. Many of the new ones have a 'burping hole' in the edge (or you can drill one) that should be installed with the hole at the 12 o'clock position. Finally, use a paper gasket and not that blue RTV silicon which can smeared inside the stat by mistake and gum up the way it opens and closes. That's a rookie mistake I made once. From your description I bet it's a bad or sticking stat.
08-14-2013 06:42 AM
Mowrangler Did you replace the radiator cap ? Cooling system needs to hold pressure to function properly.
08-13-2013 09:04 PM
DILLIGAF The selected temperature of the thermostat like 190 is the temp the thermostat is going to open at. if you are running hot with a 160 then either you have a bad (new) thermostat, weak water pump, maybe obstructed passages for the cooling system, I have seen some passages with excessive amounts of sealant around freeze plugs, and head gaskets, that have caused overheating.

try a new t-stat first and a good clean n flush first. good luck
08-13-2013 08:40 PM
Onalaskawrangler Onalaska Texas
08-13-2013 08:35 PM
1st87yj Honestly I have no clue. Someone will chime in. But hay! Are u in onalaska WI?
08-13-2013 08:11 PM
Onalaskawrangler
95 Wrangler 2.5 w/AC

Hello

My 95 Wrangler YJ 2.5 with AC has an issue of wanting to run hot.

It was overheating when I got it and I found that the water was like mud.
I flushed the system with top hose of and could not get any water to come out.
Removed bad thermostat and flushed, I then installed a new Failsafe 160 stat and this was much better but I found that the top seal around the radiator was leaking so I replaced the radiator.

Now I have a new radiator, stat and flushed system but still getting hot. Today I started the jeep and right from startup the water flow in the radiator was full flow.

I will replace this stat because if open when starting it must be stuck open.
Could the 160 stat allow to much flow and cause the engine to over heat with AC on.

And would it be better to put in a 190 degree stat ? and what was stock

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 10:19 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC