Jeep Wrangler Forum - Reply to Topic
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum > 430N RHB Updated with Garmin City Navigator 2014.10 NT

Join Wrangler Forum Today


Thread: 430N RHB Updated with Garmin City Navigator 2014.10 NT Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
Yesterday 11:24 PM
Crashthings sub
Yesterday 09:26 AM
vmikee Thanks Discodan0! This worked perfectly for me. I have a 2013 Rubicon that had the 43.00.13 firmware on it. I downloaded the 50.00.07 firmware iso and expanded it into a directory on my mac, then updated my Nuvi 2460 with the latest maps. Then I pulled the gmapprom.img off of the .system directory and used gimgunlock to unlock the .img file. I also pulled the D3191120A.jcv file from the JCV directory on the Nuvi. I followed your instructions below copying the gmapprom.img file to the /Garmin directory and created a JCV directory under /Garmin for the .jcv file. Then burned everything to a DVD.

The update took WAY less time than other people have reported, only about an hour. Don't know if that's because I started from the 43 firmware, but it was relatively quick. Three prompts for updates that I answered yes to. I had accidentally copied the wrong jcv file the first time so I created a new DVD with the correct file and re-inserted the disk. It prompted to update with new data, I said yes, then it said the maps were the same and prompted to re-install, I said no. Then it prompted to update 50.00.07 with 50.00.07 and I said no to that.

The maps now show parts of my new housing development. Couple of the newer streets aren't on it yet (including mine), so I'll be watching for more map updates so I can get it updated to include my new home address. But the maps are definitely newer than what I had!



Quote:
Originally Posted by discodan0 View Post
I learned a lot from this tread but it would not work for me.

I found a way to do update the radio software and maps at the same time.

This is the somewhat easy way to do it. (or just less painful)

This is for someone who knows his way around a computer.

1. First you need a copy of the radio software update. (I used the last 50.00.07)

2. Download the latest copy of Garmin City Navigator North America NT Unlocked. (I used 2014.10)

Here is the tricky step:

3. Mount the .ISO file on a virtual drive (I used Daemon tool. Its free) and open it to see its content. Copy all the file to a new folder on your computer. Lets call this Folder "Radio Update"

4. Copy the file gmapsupp.img from the newly download folder "Garmin City Navigator North America NT" to the folder called "Garmin" inside the "Radio Update" folder. Once copied inside the "Garmin" folder, rename it gmapprom.img. (the one inside the "Garmin" folder)

5. (optional) if you have the junction view files, create a folder called JCV folder inside the "Garmin" folder and copie the JCV file in there.

6. Now you need to burn the content of the "Radio Update" folder on a DVD. Burn all content and not the "Radio Update" folder.

7. Insert the DVD in the radio unit and wait for a long time. It took me almost 2 hours to complete all updates.

Do this update with the vehicle running or a charger on the battery. You can not interrupt the process. Starting the vehicle will interrupt the process.

It did not ask me for a code for the maps.

This process updated all my maps and the radio software at the same time.

I tried to make those instructions easy.

It updated from 50.xx.xx. No need to downgrade software.
04-20-2014 08:30 PM
wookard Friend of mine has same year jeep and stereo. But his was running the 43 FW. It took the 2014.40 update and the 55 FW update no issue at all.

I tried later that night and it appeared to finally want to do an update but it was too late for me to continue. Went for a drive and tried to do the update the next day and it asked to update again but then failed to continue. What the heck is the problem?

I tried 4 separated thumb drives. 3 try to read, 4th doesn't at all!

AHHHH lol
04-18-2014 05:43 PM
wookard So I am still at FW 33.

Tried 3 separate thumb drives and a DVD with 2014.40 and the JCV file.

All 3 thumb drives didn't appear to like the map and when I tried the DVD it says reading files for over 3 hours. I had the Jeep running the entire time. Didn't shut it off or anything.

No matter what I try I can't get into Engineering mode. It would be really awesome if someone could make a youtube vid and show exactly what they are doing. What firmware, what year of jeep etc..
04-16-2014 11:52 AM
fernboy61 45 minutes with a good usb stick, no longer than that.
04-13-2014 09:21 PM
wookard I have a 2013 JKU and my firmware was at 50.00.7. I was able to burn the 33 Firmware to a CD and it downgraded no problem at all.

I tried putting 2014.40 and the JCV on a DVD but it literally sat at reading for about 5 hours. I had to shut down the jeep a few times and when I started it back up it was right back to the reading screen.

When I turned it off for a good 10 minutes it went back to booting normal with firmware 33.x

I am going to try with a sandisk usb as that seems to be the winner for other people.

With the update and jcv on a thumb drive how long should it actually take to do the update and with a brand new jeep should I be able to leave it on ACC mode and now have the it fully turned on to complete the update and jcv?

-----

I can not get the Engineer/Development mode to work on 55x or 33x Firmware and I tried multiple spots in the circle. I would tap and hold for 10-15 seconds. What should happen if it does work? Does it open a new page by itself or does it ask you to change to Engineer mode? Thanks for any help!
04-01-2014 08:45 PM
JBB609 any word on a new 60.00 version coming up ? (not the NAV update)
03-31-2014 04:14 PM
kash
Quote:
Originally Posted by dmevis View Post
Responding to my own post...

Well I bought the "official" 2014 Navteq map update for $150 that Navteq said would work on my 430N. Tried installing it on my 2013 JKU with Firmware version 33.

Loaded the disk and it said it found a newer map and asked if I wanted to update the maps. I said "yes". Then it said it would overwright my existing map and might take 2 hours and was that O.K. I said "yes". It then took about 2 hours to load. When done, it reported that the map was loaded.

HOWEVER, when I tried to display the map, navigate, or do anything with navigation, it said that there was no map available... not even my original map. As far as I can tell, the map installation process did not "unlock" the map. So while the new map was was loaded, it was not unlocked, and could not be used. Turns out that as part of the map install, it is supposed to provide me with some Serial Number information and together with a code on the CD, I am supposed to get an unlock code to enter before it does the installation. But it did not show me the Serial Number information, or ask me to enter the unlock code. It just installed the map, but provided no way to unlock it.

Soooo, don't load the "official" 2014 map update on your 2013 Jeep until it reported as working and is being supported by Garmin and Navteq.
can you post the directory layout of this cd?
03-25-2014 01:55 PM
nubby105 Gewch,
I have found some posts on other threads that 43.x.x was the version that gave the black screens. I just can't seem to find it anywhere.
03-20-2014 01:21 PM
Gewch Thanks for the info nubby.

I ended up downgrading to 33 and the first time it ran, gave me a message that it had new software for the NAV part, and I hit Yes to install it, but got a PND did not update error.

I re-ran the 33 disc again and this time when I hit YES on the Nav software update, it did update the Garmin to the Black theme. Then I re-installed the 55 update but cant get the PND to update like my previous radio.

See this thread - Post 22 for pictures: http://www.wranglerforum.com/f274/20...-206676-2.html

I believe what happend is I had a late model RHB (bought in 2013) and had the graphics in the second and fourth picture. I'm guessing the dealer replaced my readio with one from the early 2012 or 2011 version that has graphics like in picture one and three. As much as I thought I would like the older graphics, they actually drive me insane and I prefer what was on my original 2013 RHB radio.

I'm guessing mine will come down to a battle with the dealership that replaced my radio.
03-20-2014 10:58 AM
nubby105 Gewch,
I have upgraded and downgraded several times and installed several map updates. The Nav has always been the same look (blue). It never changed to black.
03-16-2014 01:06 PM
Gewch I think I will try re-burning 33 and 50 using the slowest setting and re-running the downgrade.
03-15-2014 12:44 PM
Gewch Hoping someone can help me out...

My new HU came with version 23. I asked the dealer to update it, but he insisted that there are NO updates for my Year with this radio (this is after 2 different tries to get him to update it). Figured he had no clue so I would just do it at home with the many ISOs out there.

First thing - updated the maps without problems by following directions in this thread. Read that it is possible to go from 23 -> 50, so popped in the 50 update disc and let it run. When it got done and 50.00.07 was installed, all of the interfaces changed back to the black/green EXCEPT for the Garmin Navigation (still looks like it did at 23). Scratched my head for a few and thought maybe I skipped a step.

Found and burned the 33 update and downgraded the radio (all interfaces then looked blue like they did on the 23). After verifying 33, I put the 50 update disc back in with no success (all other modules look black/green except for the Garmin nav interface - still the blue).

This all started because my head unit was bad - dealer replaced it with a refurb (still had the previous owners home address etc...it had software version 23 and old maps). When I insisted there was an update - they refused to check any more...

Any ideas on how to fix this?
03-12-2014 06:54 PM
sparkfist
Quote:
Originally Posted by GeckoSupra View Post
My friend downgraded from 50.xx to 33.xx on his wife's 2013 Jeep and the $149.00 CD updated correctly on her Jeep, must just be hit or miss.
the map update "bug" will likely happen with the official and unofficial update. Once enough people report the problem, I suspect we will see a new update to fix this bug in the future.
03-07-2014 08:34 PM
GeckoSupra
Quote:
Originally Posted by dmevis View Post
Responding to my own post...

Well I bought the "official" 2014 Navteq map update for $150 that Navteq said would work on my 430N. Tried installing it on my 2013 JKU with Firmware version 33.

Loaded the disk and it said it found a newer map and asked if I wanted to update the maps. I said "yes". Then it said it would overwright my existing map and might take 2 hours and was that O.K. I said "yes". It then took about 2 hours to load. When done, it reported that the map was loaded.

HOWEVER, when I tried to display the map, navigate, or do anything with navigation, it said that there was no map available... not even my original map. As far as I can tell, the map installation process did not "unlock" the map. So while the new map was was loaded, it was not unlocked, and could not be used. Turns out that as part of the map install, it is supposed to provide me with some Serial Number information and together with a code on the CD, I am supposed to get an unlock code to enter before it does the installation. But it did not show me the Serial Number information, or ask me to enter the unlock code. It just installed the map, but provided no way to unlock it.

Soooo, don't load the "official" 2014 map update on your 2013 Jeep until it reported as working and is being supported by Garmin and Navteq.
My friend downgraded from 50.xx to 33.xx on his wife's 2013 Jeep and the $149.00 CD updated correctly on her Jeep, must just be hit or miss.
03-06-2014 11:36 PM
Hammertime
Quote:
Originally Posted by dmevis View Post
To this point, this thread seems to be dealing only with loading 2014 Garmin maps onto our 430N units. Of course, this is not the way that Jeep and NAVTEQ intended.

A new 2014 map file is now for sale for 430N units. This is the "official" map file from NAVTEQ for factory Jeep installs, and has a very official price of $149.00. Expensive, but should install and work with no problems or software engineering required. As of today, the web site says there is no update for the 2013 Wrangler, but I called them and they said the web site is in error, and the update will work for the 2013.

Shop & Update | Navigation.com
Thanks you for this information! I just ordered it for my 2012 Rubicon, and as an aside.... My wife drives a 2012 Grand Cherokee with the 430N also so I'm getting the updates for $75 each... LOL!


03-06-2014 05:50 PM
dmevis
Official Map Did Not Work

Responding to my own post...

Well I bought the "official" 2014 Navteq map update for $150 that Navteq said would work on my 430N. Tried installing it on my 2013 JKU with Firmware version 33.

Loaded the disk and it said it found a newer map and asked if I wanted to update the maps. I said "yes". Then it said it would overwright my existing map and might take 2 hours and was that O.K. I said "yes". It then took about 2 hours to load. When done, it reported that the map was loaded.

HOWEVER, when I tried to display the map, navigate, or do anything with navigation, it said that there was no map available... not even my original map. As far as I can tell, the map installation process did not "unlock" the map. So while the new map was was loaded, it was not unlocked, and could not be used. Turns out that as part of the map install, it is supposed to provide me with some Serial Number information and together with a code on the CD, I am supposed to get an unlock code to enter before it does the installation. But it did not show me the Serial Number information, or ask me to enter the unlock code. It just installed the map, but provided no way to unlock it.

Soooo, don't load the "official" 2014 map update on your 2013 Jeep until it reported as working and is being supported by Garmin and Navteq.




Quote:
Originally Posted by dmevis View Post
To this point, this thread seems to be dealing only with loading 2014 Garmin maps onto our 430N units. Of course, this is not the way that Jeep and NAVTEQ intended.

A new 2014 map file is now for sale for 430N units. This is the "official" map file from NAVTEQ for factory Jeep installs, and has a very official price of $149.00. Expensive, but should install and work with no problems or software engineering required. As of today, the web site says there is no update for the 2013 Wrangler, but I called them and they said the web site is in error, and the update will work for the 2013.

Shop & Update | Navigation.com
03-05-2014 03:53 PM
matti I have been debating about purchasing a 430N, but i want to load topo maps onto it.

I will be attempting to create a map file to load onto it.

Does anyone in canada(sorry i only have canada topo) happen to want to try a custom map load with me ?

PM me if interested.
03-02-2014 10:59 PM
Curtisrayc Just installed 2014.40. Works great!
03-02-2014 12:33 AM
autobahn
Checking map update

Could anyone tell me how to see if 2014.40 actually installed?

Thanks,

Steve
03-01-2014 09:55 PM
membrain I'm thinking about starting a new thread for those of us that can't make the update work...
02-26-2014 06:08 PM
GeckoSupra I did 2014.40 w/ D3060130A.JCV as well.........
02-26-2014 01:52 PM
fernboy61
Quote:
Originally Posted by nubby105 View Post
Anyone try 2014.40 yet?
I think most of us will wait for a firmware that doesn't ask to downgrade to 33.xx.xx before we try another update.
02-26-2014 06:48 AM
w4rmk You could probably go crazy trying to keep up with every map update, seems like once a year is probably enough.
02-25-2014 08:59 AM
nubby105 Anyone try 2014.40 yet?
02-21-2014 07:44 PM
GeckoSupra Hi - I just wanted to confirm that the bug does exist on the $150.00 NavTEQ install as well, my Jeep buddy bought last week to update his wife's RHB he bought off that auction site and had to downgrade to 33.xx firmware, update map then went back to 50xx firmware.

Also, wanted to say Thank You!!! -- I just bought my 2013 Gecko Rubicon back on 1/19/2014 -w- 800 miles and I bought a used RHB unit after reading these forums to make sure it was PnP, upgraded my firmware to 50.xx.....2 weeks later found this thread and updated my maps for free (downgraded firmware and did the routine)

Loving my new Jeep, we just went for an Osceola forest trail ride last weekend. Two buddies @ work have 2013/2014 Rubicons. I kept my 94 Toyota Supra too though :O)
02-21-2014 09:26 AM
sparkfist
Quote:
Originally Posted by dmevis View Post
To this point, this thread seems to be dealing only with loading 2014 Garmin maps onto our 430N units. Of course, this is not the way that Jeep and NAVTEQ intended.

A new 2014 map file is now for sale for 430N units. This is the "official" map file from NAVTEQ for factory Jeep installs, and has a very official price of $149.00. Expensive, but should install and work with no problems or software engineering required. As of today, the web site says there is no update for the 2013 Wrangler, but I called them and they said the web site is in error, and the update will work for the 2013.

Shop & Update | Navigation.com
I am not willing to pay $150 to test it, but I would be very curious to see if the update works. If I were to guess I would say it WILL NOT on 50.x and it turns out that it was a bug in that version that prevents the update legit or not.
02-18-2014 09:30 PM
dvitous That's why I didn't want a nav system. I had no choice, cuz it was in the only manual trans JKU I could find.

We have a Honda Odyssey Touring w/ Nav... and maps for that were $199. At least they got smart(er) and knocked it down to $99.

But this at the same time you could buy a Garmin, with better features, transportable, and lifetime maps for what you pay for an update.

And we pay $1k for the privelege of a $150 annual fee if we wanna keep current.

That just aint right.
02-18-2014 12:41 PM
dmevis
New 2014 "official" Map software released

To this point, this thread seems to be dealing only with loading 2014 Garmin maps onto our 430N units. Of course, this is not the way that Jeep and NAVTEQ intended.

A new 2014 map file is now for sale for 430N units. This is the "official" map file from NAVTEQ for factory Jeep installs, and has a very official price of $149.00. Expensive, but should install and work with no problems or software engineering required. As of today, the web site says there is no update for the 2013 Wrangler, but I called them and they said the web site is in error, and the update will work for the 2013.

Shop & Update | Navigation.com
02-15-2014 03:15 PM
dvitous Well.. we'll see what happens. Just dropped 50.00 on. Headed out in a few.
This thread has more than 30 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:07 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC